[packages] socat: update to 1.7.2.1 (CVE-2012-0219), use CONFIGURE_{ARGS,VARS}
- Update socat to 1.7.2.0 (main reason: avoids compile-error against kernel 3.3.5 with ext2_fs.h which seems to got removed/changed to not being used from userspace from current kernel) - remove 502-no_sslv2.patch which doesn't apply surely and looks quite outdated to me, socat isn't linked against *ssl* anyway, compiles and works fine, verified on ar71xx Michael Signed-off-by: Michael Markstaller <mm@elabnet.de> git-svn-id: svn://svn.openwrt.org/openwrt/packages@31818 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
5dfb822811
commit
7ba23075b8
@ -1,5 +1,5 @@
|
||||
#
|
||||
# Copyright (C) 2006 OpenWrt.org
|
||||
# Copyright (C) 2006-2012 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
@ -8,12 +8,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=socat
|
||||
PKG_VERSION:=1.7.1.3
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=1.7.2.1
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=http://www.dest-unreach.org/socat/download/
|
||||
PKG_MD5SUM:=2081987fb0cb0290b8105574058cb329
|
||||
PKG_SOURCE_URL:=http://www.dest-unreach.org/socat/download
|
||||
PKG_MD5SUM:=7ddfea7e9e85f868670f94d3ea08358b
|
||||
|
||||
PKG_INSTALL:=1
|
||||
|
||||
@ -36,19 +36,17 @@ define Package/socat/description
|
||||
many more options.
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
$(call Build/Configure/Default, \
|
||||
CONFIGURE_ARGS += \
|
||||
--disable-libwrap \
|
||||
--disable-readline \
|
||||
--disable-openssl \
|
||||
--enable-termios \
|
||||
, \
|
||||
--enable-termios
|
||||
|
||||
CONFIGURE_VARS += \
|
||||
sc_cv_termios_ispeed="no" \
|
||||
sc_cv_sys_crdly_shift=9 \
|
||||
sc_cv_sys_tabdly_shift=11 \
|
||||
sc_cv_sys_csize_shift=4 \
|
||||
)
|
||||
endef
|
||||
sc_cv_sys_csize_shift=4
|
||||
|
||||
define Package/socat/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/Makefile.in
|
||||
+++ b/Makefile.in
|
||||
@@ -37,7 +37,8 @@
|
||||
@@ -38,7 +38,8 @@ INSTALL = @INSTALL@
|
||||
|
||||
#0 CFLAGS = @CFLAGS@ $(CCOPTS) $(DEFS) $(INCLS)
|
||||
CFLAGS = @CFLAGS@ $(CCOPTS) $(DEFS) $(CPPFLAGS)
|
||||
|
@ -1,48 +0,0 @@
|
||||
--- a/sslcls.c
|
||||
+++ b/sslcls.c
|
||||
@@ -35,6 +35,7 @@
|
||||
return result;
|
||||
}
|
||||
|
||||
+#ifndef OPENSSL_NO_SSL2
|
||||
SSL_METHOD *sycSSLv2_client_method(void) {
|
||||
SSL_METHOD *result;
|
||||
Debug("SSLv2_client_method()");
|
||||
@@ -50,6 +51,7 @@
|
||||
Debug1("SSLv2_server_method() -> %p", result);
|
||||
return result;
|
||||
}
|
||||
+#endif
|
||||
|
||||
SSL_METHOD *sycSSLv3_client_method(void) {
|
||||
SSL_METHOD *result;
|
||||
--- a/xio-openssl.c
|
||||
+++ b/xio-openssl.c
|
||||
@@ -676,9 +676,12 @@
|
||||
|
||||
if (!server) {
|
||||
if (me_str != 0) {
|
||||
+#ifndef OPENSSL_NO_SSL2
|
||||
if (!strcasecmp(me_str, "SSLv2") || !strcasecmp(me_str, "SSL2")) {
|
||||
method = sycSSLv2_client_method();
|
||||
- } else if (!strcasecmp(me_str, "SSLv3") || !strcasecmp(me_str, "SSL3")) {
|
||||
+ } else
|
||||
+#endif
|
||||
+ if (!strcasecmp(me_str, "SSLv3") || !strcasecmp(me_str, "SSL3")) {
|
||||
method = sycSSLv3_client_method();
|
||||
} else if (!strcasecmp(me_str, "SSLv23") || !strcasecmp(me_str, "SSL23") ||
|
||||
!strcasecmp(me_str, "SSL")) {
|
||||
@@ -695,9 +698,12 @@
|
||||
}
|
||||
} else /* server */ {
|
||||
if (me_str != 0) {
|
||||
+#ifndef OPENSSL_NO_SSL2
|
||||
if (!strcasecmp(me_str, "SSLv2") || !strcasecmp(me_str, "SSL2")) {
|
||||
method = sycSSLv2_server_method();
|
||||
- } else if (!strcasecmp(me_str, "SSLv3") || !strcasecmp(me_str, "SSL3")) {
|
||||
+ } else
|
||||
+#endif
|
||||
+ if (!strcasecmp(me_str, "SSLv3") || !strcasecmp(me_str, "SSL3")) {
|
||||
method = sycSSLv3_server_method();
|
||||
} else if (!strcasecmp(me_str, "SSLv23") || !strcasecmp(me_str, "SSL23") ||
|
||||
!strcasecmp(me_str, "SSL")) {
|
Loading…
x
Reference in New Issue
Block a user