libdlna: Fix parallel build
git-svn-id: svn://svn.openwrt.org/openwrt/packages@23330 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
ed8e4dd485
commit
7d3462e4c6
@ -15,6 +15,7 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=http://libdlna.geexbox.org/releases/
|
||||
PKG_MD5SUM:=2c974f95b711e5fd07f78fc4ebfcca66
|
||||
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
PKG_INSTALL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
17
libs/libdlna/patches/200-parallel-build.patch
Normal file
17
libs/libdlna/patches/200-parallel-build.patch
Normal file
@ -0,0 +1,17 @@
|
||||
---
|
||||
Makefile | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
--- libdlna-0.2.3.orig/Makefile
|
||||
+++ libdlna-0.2.3/Makefile
|
||||
@@ -32,8 +32,8 @@ lib:
|
||||
|
||||
test: $(LIBTEST)
|
||||
|
||||
-$(LIBTEST): $(SRCS)
|
||||
- $(CC) $? $(OPTFLAGS) $(CFLAGS) $(LDFLAGS) -o $@
|
||||
+$(LIBTEST): lib $(SRCS)
|
||||
+ $(CC) $(SRCS) $(OPTFLAGS) $(CFLAGS) $(LDFLAGS) -o $@
|
||||
|
||||
clean:
|
||||
$(MAKE) -C src clean
|
Loading…
x
Reference in New Issue
Block a user