Port portsentry to -ng
git-svn-id: svn://svn.openwrt.org/openwrt/packages@4496 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
2ee8aac3f6
commit
7d6c6de241
47
net/portsentry/Makefile
Normal file
47
net/portsentry/Makefile
Normal file
@ -0,0 +1,47 @@
|
||||
#
|
||||
# Copyright (C) 2006 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
# $Id$
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=portsentry
|
||||
PKG_VERSION:=1.2
|
||||
PKG_RELEASE:=1
|
||||
PKG_MD5SUM:=3ebd3618ba9abfea2525e236bd44cebd
|
||||
|
||||
PKG_SOURCE_URL:=@SF/sentrytools
|
||||
PKG_SOURCE:=$(PKG_NAME)-1.2.tar.gz
|
||||
PKG_CAT:=zcat
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)_beta
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/portsentry
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
TITLE:=Portscan protection utility
|
||||
DESCRIPTION:=Software for protection against port scans
|
||||
URL:=http://sourceforge.net/projects/sentrytools
|
||||
endef
|
||||
|
||||
define Package/portsentry/conffiles
|
||||
/etc/portsentry.conf
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) linux
|
||||
endef
|
||||
|
||||
define Package/portsentry/install
|
||||
mkdir -p $(1)/usr/bin
|
||||
mkdir -p $(1)/etc
|
||||
$(CP) $(PKG_BUILD_DIR)/$(PKG_NAME).conf $(1)/etc/
|
||||
$(CP) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/bin/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,portsentry))
|
11
net/portsentry/patches/100-conf_location.patch
Normal file
11
net/portsentry/patches/100-conf_location.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- portsentry/portsentry_config.h 2003-05-23 20:10:13.000000000 +0200
|
||||
+++ portsentry.old/portsentry_config.h 2005-07-09 21:21:15.000000000 +0200
|
||||
@@ -22,7 +22,7 @@
|
||||
|
||||
/* These are probably ok. Be sure you change the Makefile if you */
|
||||
/* change the path */
|
||||
-#define CONFIG_FILE "/usr/local/psionic/portsentry/portsentry.conf"
|
||||
+#define CONFIG_FILE "/etc/portsentry.conf"
|
||||
|
||||
/* The location of Wietse Venema's TCP Wrapper hosts.deny file */
|
||||
#define WRAPPER_HOSTS_DENY "/etc/hosts.deny"
|
12
net/portsentry/patches/101-postsentry_c.patch
Normal file
12
net/portsentry/patches/101-postsentry_c.patch
Normal file
@ -0,0 +1,12 @@
|
||||
--- portsentry/portsentry.c 2003-05-23 20:10:13.000000000 +0200
|
||||
+++ portsentry.old/portsentry.c 2005-07-09 21:57:24.000000000 +0200
|
||||
@@ -1581,8 +1581,7 @@
|
||||
Usage (void)
|
||||
{
|
||||
printf ("PortSentry - Port Scan Detector.\n");
|
||||
- printf ("Copyright 1997-2003 Craig H. Rowland <craigrowland at users dot
|
||||
-sourceforget dot net>\n");
|
||||
+ printf ("Copyright 1997-2003 Craig H. Rowland <craigrowland at users dot sourceforget dot net>\n");
|
||||
printf ("Licensing restrictions apply. Please see documentation\n");
|
||||
printf ("Version: %s\n\n", VERSION);
|
||||
#ifdef SUPPORT_STEALTH
|
Loading…
x
Reference in New Issue
Block a user