iodine: moved to github
git-svn-id: svn://svn.openwrt.org/openwrt/packages@41800 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
6c2031627b
commit
7ff7d83d0c
@ -1,69 +0,0 @@
|
|||||||
#
|
|
||||||
# Copyright (C) 2006-2011 OpenWrt.org
|
|
||||||
#
|
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
|
||||||
# See /LICENSE for more information.
|
|
||||||
#
|
|
||||||
|
|
||||||
include $(TOPDIR)/rules.mk
|
|
||||||
|
|
||||||
PKG_NAME:=iodine
|
|
||||||
PKG_VERSION:=0.6.0-rc1
|
|
||||||
PKG_RELEASE:=5
|
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
|
||||||
PKG_SOURCE_URL:=http://code.kryo.se/iodine/
|
|
||||||
PKG_MD5SUM:=a15bb4faba020d217016fde6e231074a
|
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
|
||||||
|
|
||||||
define Package/iodine/Default
|
|
||||||
SECTION:=net
|
|
||||||
CATEGORY:=Network
|
|
||||||
SUBMENU:=Firewall Tunnel
|
|
||||||
DEPENDS:= +kmod-tun +zlib
|
|
||||||
TITLE:=IP over DNS tunneling
|
|
||||||
URL:=http://code.kryo.se/iodine/
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/iodine
|
|
||||||
$(call Package/iodine/Default)
|
|
||||||
TITLE+= client version
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/iodine/description
|
|
||||||
iodine client version
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/iodined
|
|
||||||
$(call Package/iodine/Default)
|
|
||||||
TITLE+= server version
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/iodined/description
|
|
||||||
iodine server version
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Build/Configure
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/iodine/install
|
|
||||||
$(INSTALL_DIR) $(1)/usr/sbin
|
|
||||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/bin/iodine $(1)/usr/sbin
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/iodined/install
|
|
||||||
$(INSTALL_DIR) $(1)/etc/init.d
|
|
||||||
$(INSTALL_BIN) ./files/iodined.init $(1)/etc/init.d/iodined
|
|
||||||
$(INSTALL_DIR) $(1)/etc/config
|
|
||||||
$(INSTALL_DATA) ./files/iodined.config $(1)/etc/config/iodined
|
|
||||||
$(INSTALL_DIR) $(1)/usr/sbin
|
|
||||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/bin/iodined $(1)/usr/sbin
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/iodined/conffiles
|
|
||||||
/etc/config/iodined
|
|
||||||
endef
|
|
||||||
|
|
||||||
$(eval $(call BuildPackage,iodine))
|
|
||||||
$(eval $(call BuildPackage,iodined))
|
|
@ -1,5 +0,0 @@
|
|||||||
config iodined
|
|
||||||
option address ''
|
|
||||||
option password ''
|
|
||||||
option tunnelip '10.0.0.1'
|
|
||||||
option tld ''
|
|
@ -1,23 +0,0 @@
|
|||||||
#!/bin/sh /etc/rc.common
|
|
||||||
# Copyright (C) 2006-2011 OpenWrt.org
|
|
||||||
|
|
||||||
START=50
|
|
||||||
|
|
||||||
start_instance () {
|
|
||||||
local section="$1"
|
|
||||||
config_get address "$section" 'address'
|
|
||||||
config_get password "$section" 'password'
|
|
||||||
config_get tunnelip "$section" 'tunnelip'
|
|
||||||
config_get tld "$section" 'tld'
|
|
||||||
|
|
||||||
service_start /usr/sbin/iodined -l "$address" -P "$password" "$tunnelip" "$tld"
|
|
||||||
}
|
|
||||||
|
|
||||||
start() {
|
|
||||||
config_load 'iodined'
|
|
||||||
config_foreach start_instance 'iodined'
|
|
||||||
}
|
|
||||||
|
|
||||||
stop() {
|
|
||||||
service_stop /usr/sbin/iodined
|
|
||||||
}
|
|
@ -1,22 +0,0 @@
|
|||||||
--- a/src/osflags
|
|
||||||
+++ b/src/osflags
|
|
||||||
@@ -16,9 +16,6 @@ link)
|
|
||||||
windows32)
|
|
||||||
echo '-lws2_32 -liphlpapi';
|
|
||||||
;;
|
|
||||||
- Linux)
|
|
||||||
- [ -e /usr/include/selinux/selinux.h ] && echo '-lselinux';
|
|
||||||
- ;;
|
|
||||||
esac
|
|
||||||
;;
|
|
||||||
cflags)
|
|
||||||
@@ -26,9 +23,6 @@ cflags)
|
|
||||||
BeOS)
|
|
||||||
echo '-Dsocklen_t=int';
|
|
||||||
;;
|
|
||||||
- Linux)
|
|
||||||
- [ -e /usr/include/selinux/selinux.h ] && echo '-DHAVE_SETCON';
|
|
||||||
- ;;
|
|
||||||
esac
|
|
||||||
;;
|
|
||||||
*)
|
|
Loading…
x
Reference in New Issue
Block a user