lighttpd: update to verion 1.4.28 and add mod
closes #7755 and partly #8415 git-svn-id: svn://svn.openwrt.org/openwrt/packages@24767 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
b38fb0f551
commit
800f998912
@ -8,12 +8,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=lighttpd
|
||||
PKG_VERSION:=1.4.26
|
||||
PKG_RELEASE:=3
|
||||
PKG_VERSION:=1.4.28
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=http://download.lighttpd.net/lighttpd/releases-1.4.x/
|
||||
PKG_MD5SUM:=a682c8efce47a2f4263a247ba0813c9b
|
||||
PKG_MD5SUM:=586eb535d31ac299652495b058dd87c4
|
||||
|
||||
PKG_FIXUP:=libtool
|
||||
PKG_INSTALL:=1
|
||||
@ -82,6 +82,12 @@ define Package/lighttpd-mod-evasive
|
||||
TITLE:=Evasive module
|
||||
endef
|
||||
|
||||
define Package/lighttpd-mod-evhost
|
||||
$(call Package/lighttpd/Default)
|
||||
DEPENDS:=lighttpd
|
||||
TITLE:=Exnhanced Virtual-Hosting module
|
||||
endef
|
||||
|
||||
define Package/lighttpd-mod-expire
|
||||
$(call Package/lighttpd/Default)
|
||||
DEPENDS:=lighttpd
|
||||
@ -293,10 +299,12 @@ $(eval $(call BuildPlugin,lighttpd-mod-cgi,cgi))
|
||||
$(eval $(call BuildPlugin,lighttpd-mod-cml,cml))
|
||||
$(eval $(call BuildPlugin,lighttpd-mod-compress,compress))
|
||||
$(eval $(call BuildPlugin,lighttpd-mod-evasive,evasive))
|
||||
$(eval $(call BuildPlugin,lighttpd-mod-expire, expire))
|
||||
$(eval $(call BuildPlugin,lighttpd-mod-extforward, extforward))
|
||||
$(eval $(call BuildPlugin,lighttpd-mod-evhost,evhost))
|
||||
$(eval $(call BuildPlugin,lighttpd-mod-expire,expire))
|
||||
$(eval $(call BuildPlugin,lighttpd-mod-extforward,extforward))
|
||||
$(eval $(call BuildPlugin,lighttpd-mod-fastcgi,fastcgi))
|
||||
$(eval $(call BuildPlugin,lighttpd-mod-flv-streaming,flv_streaming))
|
||||
$(eval $(call BuildPlugin,lighttpd-mod-magnet,magnet))
|
||||
$(eval $(call BuildPlugin,lighttpd-mod-proxy,proxy))
|
||||
$(eval $(call BuildPlugin,lighttpd-mod-redirect,redirect))
|
||||
$(eval $(call BuildPlugin,lighttpd-mod-rewrite,rewrite))
|
||||
|
@ -1,13 +0,0 @@
|
||||
http://redmine.lighttpd.net/issues/2157
|
||||
|
||||
--- a/src/network.c
|
||||
+++ b/src/network.c
|
||||
@@ -525,7 +525,7 @@ int network_init(server *srv) {
|
||||
|
||||
if (!s->ssl_use_sslv2) {
|
||||
/* disable SSLv2 */
|
||||
- if (SSL_OP_NO_SSLv2 != SSL_CTX_set_options(s->ssl_ctx, SSL_OP_NO_SSLv2)) {
|
||||
+ if (!(SSL_OP_NO_SSLv2 & SSL_CTX_set_options(s->ssl_ctx, SSL_OP_NO_SSLv2))) {
|
||||
log_error_write(srv, __FILE__, __LINE__, "ss", "SSL:",
|
||||
ERR_error_string(ERR_get_error(), NULL));
|
||||
return -1;
|
Loading…
x
Reference in New Issue
Block a user