stm32flash: make sure we pass our CFLAGS
Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/packages@39823 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
8a059416a7
commit
80f004125d
@ -1,5 +1,5 @@
|
|||||||
#
|
#
|
||||||
# Copyright (C) 2012 OpenWrt.org
|
# Copyright (C) 2012-2014 OpenWrt.org
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
|
|||||||
PKG_NAME:=stm32flash
|
PKG_NAME:=stm32flash
|
||||||
PKG_REV:=61
|
PKG_REV:=61
|
||||||
PKG_VERSION:=r$(PKG_REV)
|
PKG_VERSION:=r$(PKG_REV)
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=2
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
PKG_SOURCE_URL:=http://stm32flash.googlecode.com/svn/trunk
|
PKG_SOURCE_URL:=http://stm32flash.googlecode.com/svn/trunk
|
||||||
|
30
utils/stm32flash/patches/001-cflags_override.patch
Normal file
30
utils/stm32flash/patches/001-cflags_override.patch
Normal file
@ -0,0 +1,30 @@
|
|||||||
|
--- a/Makefile
|
||||||
|
+++ b/Makefile
|
||||||
|
@@ -5,7 +5,7 @@ export AR
|
||||||
|
|
||||||
|
all:
|
||||||
|
$(MAKE) -C parsers
|
||||||
|
- $(CC) -g -o stm32flash -I./ \
|
||||||
|
+ $(CC) $(LDFLAGS) -o stm32flash -I./ \
|
||||||
|
main.c \
|
||||||
|
utils.c \
|
||||||
|
stm32.c \
|
||||||
|
@@ -13,7 +13,7 @@ all:
|
||||||
|
serial_platform.c \
|
||||||
|
parsers/parsers.a \
|
||||||
|
stm32/stmreset_binary.c \
|
||||||
|
- -Wall
|
||||||
|
+ $(CFLAGS)
|
||||||
|
|
||||||
|
clean:
|
||||||
|
$(MAKE) -C parsers clean
|
||||||
|
--- a/parsers/Makefile
|
||||||
|
+++ b/parsers/Makefile
|
||||||
|
@@ -1,6 +1,6 @@
|
||||||
|
|
||||||
|
all:
|
||||||
|
- $(CC) -g -Wall -c -I../ binary.c hex.c
|
||||||
|
+ $(CC) $(CFLAGS) -Wall -c -I../ binary.c hex.c
|
||||||
|
$(AR) r parsers.a binary.o hex.o
|
||||||
|
|
||||||
|
clean:
|
Loading…
x
Reference in New Issue
Block a user