remove the need for C99 math (closes: #1579)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@6929 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
8a929b7fbd
commit
8139f60ed2
@ -20,6 +20,8 @@ PKG_SOURCE_URL:=\
|
|||||||
PKG_MD5SUM:=cb47771004d53505200ffd00ac45bc32
|
PKG_MD5SUM:=cb47771004d53505200ffd00ac45bc32
|
||||||
PKG_CAT:=bzcat
|
PKG_CAT:=bzcat
|
||||||
|
|
||||||
|
PKG_BUILD_DEPENDS:=libnotimpl
|
||||||
|
|
||||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
@ -45,7 +47,7 @@ endef
|
|||||||
define Package/pgsql-server
|
define Package/pgsql-server
|
||||||
SECTION:=utils
|
SECTION:=utils
|
||||||
CATEGORY:=Utilities
|
CATEGORY:=Utilities
|
||||||
DEPENDS:=+libpq @C99_MATH
|
DEPENDS:=+libpq
|
||||||
TITLE:=PostgreSQL databases Server
|
TITLE:=PostgreSQL databases Server
|
||||||
DESCRIPTION:=PostgreSQL databases Server.
|
DESCRIPTION:=PostgreSQL databases Server.
|
||||||
URL:=http://www.postgresql.org/
|
URL:=http://www.postgresql.org/
|
||||||
@ -96,8 +98,9 @@ define Build/Configure
|
|||||||
(cd $(PKG_BUILD_DIR); rm -f config.cache; \
|
(cd $(PKG_BUILD_DIR); rm -f config.cache; \
|
||||||
$(TARGET_CONFIGURE_OPTS) \
|
$(TARGET_CONFIGURE_OPTS) \
|
||||||
CFLAGS="$(TARGET_CFLAGS)" \
|
CFLAGS="$(TARGET_CFLAGS)" \
|
||||||
CPPFLAGS="$$$$CPPFLAGS $(EXTRA_CPPFLAGS)" \
|
CPPFLAGS="$$$$CPPFLAGS $(TARGET_CPPFLAGS)" \
|
||||||
LDFLAGS="$(EXTRA_LDFLAGS)" \
|
LDFLAGS="$(TARGET_LDFLAGS)" \
|
||||||
|
LIBS="-lnotimpl" \
|
||||||
./configure \
|
./configure \
|
||||||
--target=$(GNU_TARGET_NAME) \
|
--target=$(GNU_TARGET_NAME) \
|
||||||
--host=$(GNU_TARGET_NAME) \
|
--host=$(GNU_TARGET_NAME) \
|
||||||
|
23
libs/postgresql/patches/850-uclibc_no_cbrt.patch
Normal file
23
libs/postgresql/patches/850-uclibc_no_cbrt.patch
Normal file
@ -0,0 +1,23 @@
|
|||||||
|
diff -ruN postgresql-8.2.3-old/src/backend/utils/adt/float.c postgresql-8.2.3-new/src/backend/utils/adt/float.c
|
||||||
|
--- postgresql-8.2.3-old/src/backend/utils/adt/float.c 2006-10-05 03:40:45.000000000 +0200
|
||||||
|
+++ postgresql-8.2.3-new/src/backend/utils/adt/float.c 2007-04-10 23:13:16.000000000 +0200
|
||||||
|
@@ -110,7 +110,9 @@
|
||||||
|
static int float8_cmp_internal(float8 a, float8 b);
|
||||||
|
|
||||||
|
#ifndef HAVE_CBRT
|
||||||
|
-static double cbrt(double x);
|
||||||
|
+#undef cbrt
|
||||||
|
+#define cbrt(x) pg_cbrt(x)
|
||||||
|
+static double pg_cbrt(double x);
|
||||||
|
#endif /* HAVE_CBRT */
|
||||||
|
|
||||||
|
|
||||||
|
@@ -2831,7 +2833,7 @@
|
||||||
|
#ifndef HAVE_CBRT
|
||||||
|
|
||||||
|
static double
|
||||||
|
-cbrt(double x)
|
||||||
|
+pg_cbrt(double x)
|
||||||
|
{
|
||||||
|
int isneg = (x < 0.0);
|
||||||
|
double absx = fabs(x);
|
Loading…
x
Reference in New Issue
Block a user