port lzo to buildroot-ng
git-svn-id: svn://svn.openwrt.org/openwrt/packages@4140 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
b336af8435
commit
822b05e6a9
91
libs/lzo/Makefile
Normal file
91
libs/lzo/Makefile
Normal file
@ -0,0 +1,91 @@
|
|||||||
|
#
|
||||||
|
# Copyright (C) 2006 OpenWrt.org
|
||||||
|
#
|
||||||
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
|
# See /LICENSE for more information.
|
||||||
|
#
|
||||||
|
# $Id$
|
||||||
|
|
||||||
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
|
PKG_NAME:=lzo
|
||||||
|
PKG_VERSION:=1.08
|
||||||
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
|
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||||
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
|
PKG_SOURCE_URL:=http://www.oberhumer.com/opensource/lzo/download/
|
||||||
|
PKG_MD5SUM:=ab94d3da364c7cbd5b78d76f1875b0f6
|
||||||
|
PKG_CAT:=zcat
|
||||||
|
|
||||||
|
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||||
|
|
||||||
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
define Package/liblzo
|
||||||
|
SECTION:=libs
|
||||||
|
CATEGORY:=Libraries
|
||||||
|
TITLE:=A real-time data compression library
|
||||||
|
DESCRIPTION:=A real-time data compression library.
|
||||||
|
URL:=http://www.oberhumer.com/opensource/lzo/
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Build/Configure
|
||||||
|
(cd $(PKG_BUILD_DIR); rm -f config.cache; \
|
||||||
|
$(TARGET_CONFIGURE_OPTS) \
|
||||||
|
CFLAGS="$(strip $(TARGET_CFLAGS))" \
|
||||||
|
CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
|
||||||
|
LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
|
||||||
|
./configure \
|
||||||
|
--target=$(GNU_TARGET_NAME) \
|
||||||
|
--host=$(GNU_TARGET_NAME) \
|
||||||
|
--build=$(GNU_HOST_NAME) \
|
||||||
|
--program-prefix="" \
|
||||||
|
--program-suffix="" \
|
||||||
|
--prefix=/usr \
|
||||||
|
--exec-prefix=/usr \
|
||||||
|
--bindir=/usr/bin \
|
||||||
|
--datadir=/usr/share \
|
||||||
|
--includedir=/usr/include \
|
||||||
|
--infodir=/usr/share/info \
|
||||||
|
--libdir=/usr/lib \
|
||||||
|
--libexecdir=/usr/lib \
|
||||||
|
--localstatedir=/var \
|
||||||
|
--mandir=/usr/share/man \
|
||||||
|
--sbindir=/usr/sbin \
|
||||||
|
--sysconfdir=/etc \
|
||||||
|
$(DISABLE_LARGEFILE) \
|
||||||
|
$(DISABLE_NLS) \
|
||||||
|
--enable-shared \
|
||||||
|
--enable-static \
|
||||||
|
);
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Build/Compile
|
||||||
|
rm -rf $(PKG_INSTALL_DIR)
|
||||||
|
mkdir -p $(PKG_INSTALL_DIR)
|
||||||
|
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||||
|
CFLAGS_O="$(TARGET_CFLAGS)" \
|
||||||
|
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||||
|
all install
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/liblzo/install
|
||||||
|
install -d -m0755 $(1)/usr/lib
|
||||||
|
$(CP) $(PKG_INSTALL_DIR)/usr/lib/liblzo.so.* $(1)/usr/lib
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Build/InstallDev
|
||||||
|
mkdir -p $(STAGING_DIR)/usr/include
|
||||||
|
$(CP) $(PKG_INSTALL_DIR)/usr/include/lzo*.h $(STAGING_DIR)/usr/include/
|
||||||
|
mkdir -p $(STAGING_DIR)/usr/lib
|
||||||
|
$(CP) $(PKG_INSTALL_DIR)/usr/lib/liblzo.{a,so*} $(STAGING_DIR)/usr/lib/
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Build/UninstallDev
|
||||||
|
rm -rf \
|
||||||
|
$(STAGING_DIR)/usr/include/lzo*.h \
|
||||||
|
$(STAGING_DIR)/usr/lib/liblzo.{a,so*}
|
||||||
|
endef
|
||||||
|
|
||||||
|
$(eval $(call BuildPackage,liblzo))
|
43
libs/lzo/patches/lzo-cross-compile.patch
Normal file
43
libs/lzo/patches/lzo-cross-compile.patch
Normal file
@ -0,0 +1,43 @@
|
|||||||
|
For some reason the lzo autoconf script uses a local macro that does
|
||||||
|
a test for cross-compiles, and assumes that if the build target name
|
||||||
|
and the host target name are the same that --host was not specified to
|
||||||
|
the configure script. In the uClibc buildroot, this is not the case.
|
||||||
|
|
||||||
|
--- lzo-1.08/aclocal.m4 2002-07-12 18:31:52.000000000 -0700
|
||||||
|
+++ lzo-1.08/aclocal.m4.new 2004-03-10 15:32:42.000000000 -0700
|
||||||
|
@@ -205,12 +205,6 @@
|
||||||
|
[
|
||||||
|
AC_REQUIRE([AC_PROG_CC])
|
||||||
|
|
||||||
|
-if test "X$cross_compiling" = Xyes; then
|
||||||
|
- if test "X$build" = "X$host"; then
|
||||||
|
- AC_MSG_ERROR([you are cross compiling - please use the \`--host=' option])
|
||||||
|
- fi
|
||||||
|
-fi
|
||||||
|
-
|
||||||
|
])
|
||||||
|
|
||||||
|
|
||||||
|
--- lzo-1.08/configure-dist 2004-03-11 02:18:28.000000000 -0600
|
||||||
|
+++ lzo-1.08/configure 2004-03-11 02:19:16.000000000 -0600
|
||||||
|
@@ -2282,13 +2282,13 @@
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
|
-if test "X$cross_compiling" = Xyes; then
|
||||||
|
- if test "X$build" = "X$host"; then
|
||||||
|
- { { echo "$as_me:$LINENO: error: you are cross compiling - please use the \`--host=' option" >&5
|
||||||
|
-echo "$as_me: error: you are cross compiling - please use the \`--host=' option" >&2;}
|
||||||
|
- { (exit 1); exit 1; }; }
|
||||||
|
- fi
|
||||||
|
-fi
|
||||||
|
+#if test "X$cross_compiling" = Xyes; then
|
||||||
|
+# if test "X$build" = "X$host"; then
|
||||||
|
+# { { echo "$as_me:$LINENO: error: you are cross compiling - please use the \`--host=' option" >&5
|
||||||
|
+#echo "$as_me: error: you are cross compiling - please use the \`--host=' option" >&2;}
|
||||||
|
+# { (exit 1); exit 1; }; }
|
||||||
|
+# fi
|
||||||
|
+#fi
|
||||||
|
|
||||||
|
|
||||||
|
|
Loading…
x
Reference in New Issue
Block a user