port libcli to buildroot-ng
git-svn-id: svn://svn.openwrt.org/openwrt/packages@4294 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
90105a7cf8
commit
8561b1f8f6
libs/libcli
68
libs/libcli/Makefile
Executable file
68
libs/libcli/Makefile
Executable file
@ -0,0 +1,68 @@
|
||||
#
|
||||
# Copyright (C) 2006 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
# $Id$
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=libcli
|
||||
PKG_VERSION:=1.8.5
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@SF/libcli
|
||||
PKG_MD5SUM:=0fdd30df5a8c1388a4549751ba61247a
|
||||
PKG_CAT:=zcat
|
||||
|
||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/libcli
|
||||
SECTION:=libs
|
||||
CATEGORY:=Libraries
|
||||
TITLE:=A Cisco-like CLI library
|
||||
DESCRIPTION:=A Cisco-like Command Line Interface (CLI) library.\\\
|
||||
Provides a shared library for including a Cisco-like \\\
|
||||
command-line interface into other software. It's a telnet \\\
|
||||
interface which supports command-line editing, history, \\\
|
||||
authentication and callbacks for a user-definable function tree
|
||||
URL:=http://libcli.sourceforge.net/
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
rm -rf $(PKG_INSTALL_DIR)
|
||||
mkdir -p $(PKG_INSTALL_DIR)
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
CC="$(TARGET_CC)" \
|
||||
LD="$(TARGET_CC)" \
|
||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||
all install
|
||||
endef
|
||||
|
||||
define Package/libcli/install
|
||||
install -d -m0755 $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libcli.so.* $(1)/usr/lib
|
||||
endef
|
||||
|
||||
define Build/InstallDev
|
||||
mkdir -p $(STAGING_DIR)/usr/include
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/libcli.h $(STAGING_DIR)/usr/include/
|
||||
mkdir -p $(STAGING_DIR)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libcli.so* $(STAGING_DIR)/usr/lib/
|
||||
endef
|
||||
|
||||
define Build/UninstallDev
|
||||
rm -rf \
|
||||
$(STAGING_DIR)/usr/include/libcli.h \
|
||||
$(STAGING_DIR)/usr/lib/libcli.so*
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,libcli))
|
19
libs/libcli/patches/01-remove_debug_honor_prefix.patch
Normal file
19
libs/libcli/patches/01-remove_debug_honor_prefix.patch
Normal file
@ -0,0 +1,19 @@
|
||||
diff -urN orig/libcli-1.8.5/Makefile libcli-1.8.5/Makefile
|
||||
--- orig/libcli-1.8.5/Makefile 2005-05-02 11:57:39.000000000 +0200
|
||||
+++ libcli-1.8.5/Makefile 2005-12-13 17:42:46.000000000 +0100
|
||||
@@ -1,13 +1,12 @@
|
||||
DESTDIR =
|
||||
-PREFIX = /usr/local
|
||||
+PREFIX = /usr/
|
||||
|
||||
MAJOR = 1
|
||||
MINOR = 8
|
||||
REVISION = 5
|
||||
LIB = libcli.so
|
||||
|
||||
-CC = gcc
|
||||
-DEBUG = -g
|
||||
+DEBUG =
|
||||
OPTIM = -O3
|
||||
CFLAGS += $(DEBUG) $(OPTIM) -Wall -Wformat-security -Wno-format-zero-length
|
||||
LDFLAGS += -shared -Wl,-soname,$(LIB).$(MAJOR).$(MINOR)
|
Loading…
x
Reference in New Issue
Block a user