[packages/nfs-kernel-server]: update to v1.2.8

git-svn-id: svn://svn.openwrt.org/openwrt/packages@36857 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
tripolar 2013-06-05 18:36:16 +00:00
parent d0866d3010
commit 868bc27cbc
2 changed files with 4 additions and 17 deletions

View File

@ -7,9 +7,9 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=nfs-kernel-server
PKG_VERSION:=1.2.7
PKG_VERSION:=1.2.8
PKG_RELEASE:=1
PKG_MD5SUM:=3b5ca797197765dc0c3a4122720c7716
PKG_MD5SUM:=6e7d97de51e428a0b8698c16ca23db77
PKG_SOURCE_URL:=@SF/nfs
PKG_SOURCE:=nfs-utils-$(PKG_VERSION).tar.bz2

View File

@ -1,16 +1,3 @@
--- a/support/include/sockaddr.h
+++ b/support/include/sockaddr.h
@@ -20,7 +20,10 @@
#ifndef NFS_UTILS_SOCKADDR_H
#define NFS_UTILS_SOCKADDR_H
+/* uClibc doesn't have/need libio.h */
+#ifndef __UCLIBC__
#include <libio.h>
+#endif
#include <stdbool.h>
#include <sys/socket.h>
#include <netinet/in.h>
--- a/support/nfs/svc_socket.c
+++ b/support/nfs/svc_socket.c
@@ -40,10 +40,13 @@ int getservport(u_long number, const cha
@ -31,7 +18,7 @@
ret = getservbyname_r(rpcp->r_name, proto, &servbuf, servdata,
--- a/utils/mountd/cache.c
+++ b/utils/mountd/cache.c
@@ -168,6 +168,7 @@ static void auth_unix_gid(FILE *f)
@@ -166,6 +166,7 @@ static void auth_unix_gid(FILE *f)
pw = getpwuid(uid);
if (!pw)
rv = -1;
@ -39,7 +26,7 @@
else {
rv = getgrouplist(pw->pw_name, pw->pw_gid, groups, &ngroups);
if (rv == -1 && ngroups >= groups_len) {
@@ -182,6 +183,7 @@ static void auth_unix_gid(FILE *f)
@@ -180,6 +181,7 @@ static void auth_unix_gid(FILE *f)
}
}
}