[packages] ditg: update to 2.8.0-rc1, remove obsolete patch
git-svn-id: svn://svn.openwrt.org/openwrt/packages@28091 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
9e0166b215
commit
86d5ed9103
net/ditg
@ -1,5 +1,5 @@
|
|||||||
#
|
#
|
||||||
# Copyright (C) 2010 OpenWrt.org
|
# Copyright (C) 2010-2011 OpenWrt.org
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
@ -8,27 +8,27 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=ditg
|
PKG_NAME:=ditg
|
||||||
PKG_VERSION:=2.7.0
|
PKG_VERSION:=2.8.0-rc1
|
||||||
PKG_RELEASE:=Beta2
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=D-ITG-${PKG_VERSION}-${PKG_RELEASE}.zip
|
PKG_SOURCE:=D-ITG-$(PKG_VERSION).tgz
|
||||||
PKG_SOURCE_URL:=http://www.grid.unina.it/software/ITG/codice/
|
PKG_SOURCE_URL:=http://www.grid.unina.it/software/ITG/codice
|
||||||
PKG_MD5SUM:=6cf5f1a16283cff8297521ec4093df7f
|
PKG_MD5SUM:=ed8efdda540f467ef4d688ed4184b11d
|
||||||
|
|
||||||
PKG_BUILD_DIR:=$(BUILD_DIR)/D-ITG-${PKG_VERSION}-${PKG_RELEASE}
|
PKG_BUILD_DIR:=$(BUILD_DIR)/D-ITG-$(PKG_VERSION)
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
define Package/ditg/Default
|
define Package/ditg
|
||||||
TITLE:=D-ITG (Distributed Internet Traffic Generator)
|
TITLE:=D-ITG (Distributed Internet Traffic Generator)
|
||||||
SECTION:=net
|
SECTION:=net
|
||||||
CATEGORY:=Network
|
CATEGORY:=Network
|
||||||
URL:=http://www.grid.unina.it/software/ITG/
|
URL:=http://www.grid.unina.it/software/ITG/
|
||||||
MAINTAINER:=Giovanni Di Stasi <giovanni.distasi@unina.it>
|
MAINTAINER:=Giovanni Di Stasi <giovanni.distasi@unina.it>
|
||||||
DEPENDS:= +libpcap +libstdcpp
|
DEPENDS:=+libpthread +uclibcxx
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/ditg/Default/description
|
define Package/ditg/description
|
||||||
D-ITG (Distributed Internet Traffic Generator) is a platform capable
|
D-ITG (Distributed Internet Traffic Generator) is a platform capable
|
||||||
to produce traffic at packet level accurately replicating appropriate
|
to produce traffic at packet level accurately replicating appropriate
|
||||||
stochastic processes for both IDT (Inter Departure Time) and PS
|
stochastic processes for both IDT (Inter Departure Time) and PS
|
||||||
@ -39,24 +39,16 @@ define Package/ditg/Default/description
|
|||||||
when compared to other traffic generators.
|
when compared to other traffic generators.
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/ditg
|
MAKE_PATH := src
|
||||||
$(call Package/ditg/Default)
|
|
||||||
endef
|
|
||||||
|
|
||||||
# uncomment for arm targets
|
TARGET_CXX = $(STAGING_DIR)/host/bin/g++-uc
|
||||||
#EXTRA_FLAGS=" arm=on "
|
|
||||||
|
|
||||||
define Build/Compile
|
MAKE_FLAGS += \
|
||||||
$(MAKE) \
|
CXXOPT="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS) -DMULTIPORT -DARM"
|
||||||
CXX="$(TARGET_CXX)" \
|
|
||||||
CXXOPT="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
|
|
||||||
-C $(PKG_BUILD_DIR)/src $(EXTRA_CFLAGS)
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/ditg/install
|
define Package/ditg/install
|
||||||
$(INSTALL_DIR) $(1)/usr/bin/
|
$(INSTALL_DIR) $(1)/usr/bin
|
||||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/bin/{ITGSend,ITGRecv,ITGLog,ITGDec} \
|
$(INSTALL_BIN) $(PKG_BUILD_DIR)/bin/ITG{Send,Recv,Log,Dec} $(1)/usr/bin/
|
||||||
$(1)/usr/bin
|
|
||||||
endef
|
endef
|
||||||
|
|
||||||
$(eval $(call BuildPackage,ditg))
|
$(eval $(call BuildPackage,ditg))
|
||||||
|
@ -1,11 +0,0 @@
|
|||||||
--- D-ITG-2.7.0-Beta2/src/common/serial.cpp 2009-05-24 10:48:18.000000000 +0200
|
|
||||||
+++ D-ITG-2.7.0-Beta2.new/src/common/serial.cpp 2010-03-21 17:22:54.000000000 +0100
|
|
||||||
@@ -84,7 +84,7 @@
|
|
||||||
#include <unistd.h>
|
|
||||||
#include <termios.h>
|
|
||||||
#if !defined(BSD) && !defined(ARM)
|
|
||||||
-#include <stropts.h>
|
|
||||||
+//#include <stropts.h>
|
|
||||||
#endif
|
|
||||||
#include <fcntl.h>
|
|
||||||
#include <stdio.h>
|
|
Loading…
x
Reference in New Issue
Block a user