remove spca5xx, it is obsolete

git-svn-id: svn://svn.openwrt.org/openwrt/packages@31797 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
nbd 2012-05-18 19:03:57 +00:00
parent 3d76da2114
commit 87da0db2bb
6 changed files with 0 additions and 157 deletions

View File

@ -1,40 +0,0 @@
#
# Copyright (C) 2006 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=spca5xx-le
PKG_VERSION:=1
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME).tar.bz2
PKG_SOURCE_URL:=http://www.acmesystems.it/download/owrt/
PKG_MD5SUM:=
PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)
include $(INCLUDE_DIR)/package.mk
define KernelPackage/video-spca5xx-le
SUBMENU:=Video Support
TITLE:=SPCA5xx based USB webcam support (Light Edition)
URL:=http://mxhaard.free.fr/
DEPENDS:=@LINUX_2_6_23||LINUX_2_6_24||LINUX_2_6_25 @USB_SUPPORT +kmod-usb-core +kmod-video-core
FILES:=$(PKG_BUILD_DIR)/spca5xx.$(LINUX_KMOD_SUFFIX)
AUTOLOAD:=$(call AutoLoad,90,spca5xx)
endef
define Build/Compile
$(MAKE) -C $(LINUX_DIR) \
ARCH="$(LINUX_KARCH)" \
CROSS_COMPILE="$(TARGET_CROSS)" \
SUBDIRS="$(PKG_BUILD_DIR)" \
modules
endef
$(eval $(call KernelPackage,video-spca5xx-le))

View File

@ -1,21 +0,0 @@
diff -Naur spca5xx-le/spca_core.c spca5xx-le-new/spca_core.c
--- spca5xx-le/spca_core.c 2007-06-03 21:30:29.000000000 +0100
+++ spca5xx-le-new/spca_core.c 2008-01-06 12:48:08.000000000 +0000
@@ -535,7 +535,7 @@
if (!pgd_none (*pgd))
{
-#if PUD_SHIFT
+#ifdef PUD_SHIFT
pud_t *pud = pud_offset (pgd, adr);
if (!pud_none (*pud))
{
@@ -552,7 +552,7 @@
ret = (unsigned long) page_address (pte_page (pte));
ret |= (adr & (PAGE_SIZE - 1));
}
-#if PUD_SHIFT
+#ifdef PUD_SHIFT
}
#endif
}

View File

@ -1,13 +0,0 @@
diff -ruN spca5xx-le-orig/spca_core.c spca5xx-le/spca_core.c
--- spca5xx-le-orig/spca_core.c 2008-04-12 18:09:57.000000000 +0200
+++ spca5xx-le/spca_core.c 2008-04-12 18:16:45.000000000 +0200
@@ -2799,7 +2799,9 @@
.owner = THIS_MODULE,
.name = "SPCA5XX USB Camera",
.type = VID_TYPE_CAPTURE,
+#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,23)
.hardware = VID_HARDWARE_SPCA5XX,
+#endif
.fops = &spca5xx_fops,
#if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 0)
.release = video_device_release,

View File

@ -1,54 +0,0 @@
#
# Copyright (C) 2006-2011 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=spca5xx-view
PKG_VERSION:=1
PKG_RELEASE:=3
PKG_SOURCE:=spca5xx-view.tar.bz2
PKG_SOURCE_URL:=http://www.acmesystems.it/download/owrt
PKG_MD5SUM:=113357f8fbc3b994424ae37644529d55
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
include $(INCLUDE_DIR)/package.mk
define Package/spca5xx-view
SECTION:=utils
CATEGORY:=Utilities
TITLE:=spca5xx streaming applicaton
DEPENDS:=+kmod-video-spca5xx-le +libpthread
URL:=http://www.acmesystems.it/
endef
define Package/spca5xx-view/description
This package contains a streaming daemon for spca5xx based webcams
endef
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR)/servfox/ CFLAGS="$(TARTGET_CFLAGS)" CC="$(TARGET_CC)" all
$(MAKE) -C $(PKG_BUILD_DIR)/servfox/ PREFIX="$(PKG_INSTALL_DIR)" install
endef
define Package/spca5xx-view/install
$(INSTALL_DIR) $(1)/
$(CP) $(PKG_INSTALL_DIR)/* $(1)
$(INSTALL_DIR) $(1)/www/
$(CP) $(PKG_BUILD_DIR)/html-files/* $(1)/www/
$(INSTALL_DIR) $(1)/etc/config
$(INSTALL_DATA) ./files/servfox.config $(1)/etc/config/servfox
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) ./files/servfox.init $(1)/etc/init.d/servfox
endef
define Package/spca5xx-view/conffiles
/etc/config/servfox
endef
$(eval $(call BuildPackage,spca5xx-view))

View File

@ -1,4 +0,0 @@
config servfox
option device '/dev/video0'
option port '7070'
option resolution '640x480'

View File

@ -1,25 +0,0 @@
#!/bin/sh /etc/rc.common
# Copyright (C) 2006-2011 OpenWrt.org
START=90
satrt_instance() {
local cfg="$1"
local res
local dev
local port
config_get res "$cfg" 'resolution'
config_get dev "$cfg" 'device'
config_get port "$cfg" 'port'
service_start bin/servfox ${dev:+-d $dev} ${res:+-s $res} ${port:+-w $port}
}
start() {
config_load 'servfox'
config_foreach start_instance 'servfox'
}
stop() {
service_stop /bin/servfox
}