cyrus-sasl: moved to github
git-svn-id: svn://svn.openwrt.org/openwrt/packages@42006 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
3dc815faf6
commit
87f859ff6d
@ -1,111 +0,0 @@
|
|||||||
#
|
|
||||||
# Copyright (C) 2006-2008 OpenWrt.org
|
|
||||||
#
|
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
|
||||||
# See /LICENSE for more information.
|
|
||||||
#
|
|
||||||
|
|
||||||
include $(TOPDIR)/rules.mk
|
|
||||||
|
|
||||||
PKG_NAME:=cyrus-sasl
|
|
||||||
PKG_VERSION:=2.1.23
|
|
||||||
PKG_RELEASE:=2
|
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
|
||||||
PKG_SOURCE_URL:=http://ftp.andrew.cmu.edu/pub/cyrus-mail/
|
|
||||||
PKG_MD5SUM:=2eb0e48106f0e9cd8001e654f267ecbc
|
|
||||||
|
|
||||||
PKG_LICENSE:=BSD-4c BSD
|
|
||||||
PKG_LICENSE_FILES:=COPYING cmulocal/COPYING saslauthd/COPYING
|
|
||||||
|
|
||||||
PKG_BUILD_DEPENDS:=libopenssl
|
|
||||||
|
|
||||||
PKG_FIXUP:=autoreconf
|
|
||||||
PKG_MACRO_PATHS:=cmulocal config ../cmulocal ../config
|
|
||||||
PKG_AUTOMAKE_PATHS:=. saslauthd sasldb
|
|
||||||
PKG_REMOVE_FILES:=aclocal.m4 saslauthd/aclocal.m4 config/libtool.m4
|
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
|
||||||
|
|
||||||
define Package/libsasl2
|
|
||||||
SECTION:=libs
|
|
||||||
CATEGORY:=Libraries
|
|
||||||
TITLE:=A general purpose authentication library
|
|
||||||
URL:=http://asg.web.cmu.edu/sasl/
|
|
||||||
endef
|
|
||||||
|
|
||||||
TARGET_CFLAGS += $(FPIC)
|
|
||||||
CONFIGURE_ARGS += \
|
|
||||||
--enable-shared \
|
|
||||||
--enable-static \
|
|
||||||
--disable-sample \
|
|
||||||
--enable-staticdlopen \
|
|
||||||
--disable-java \
|
|
||||||
--disable-alwaystrue \
|
|
||||||
--disable-checkapop \
|
|
||||||
--enable-cram \
|
|
||||||
--enable-digest \
|
|
||||||
--without-auth-sasldb \
|
|
||||||
--disable-otp \
|
|
||||||
--disable-srp \
|
|
||||||
--disable-srp-setpass \
|
|
||||||
--disable-krb4 \
|
|
||||||
--disable-gssapi \
|
|
||||||
--disable-gss_mutexes \
|
|
||||||
--enable-plain \
|
|
||||||
--enable-anon \
|
|
||||||
--disable-login \
|
|
||||||
--disable-ntlm \
|
|
||||||
--disable-sql \
|
|
||||||
--disable-ldapdb \
|
|
||||||
--without-dblib \
|
|
||||||
--without-gdbm \
|
|
||||||
--with-devrandom="/dev/urandom" \
|
|
||||||
--without-pam \
|
|
||||||
--without-saslauthd \
|
|
||||||
--without-authdaemond \
|
|
||||||
--without-pwcheck \
|
|
||||||
--with-ipctype=unix \
|
|
||||||
--with-openssl="$(STAGING_DIR)/usr" \
|
|
||||||
--without-des \
|
|
||||||
--without-opie \
|
|
||||||
--without-ldap \
|
|
||||||
--without-mysql \
|
|
||||||
--without-pgsql \
|
|
||||||
--without-sqlite \
|
|
||||||
--without-rc4 \
|
|
||||||
--without-dmalloc \
|
|
||||||
--without-sfio \
|
|
||||||
--disable-sample
|
|
||||||
|
|
||||||
define Build/Compile
|
|
||||||
$(MAKE) -C $(PKG_BUILD_DIR)/include \
|
|
||||||
CC="$(HOSTCC)" \
|
|
||||||
LINK="$(HOSTCC) -o makemd5 -lc" \
|
|
||||||
CFLAGS="" \
|
|
||||||
CPPFLAGS="" \
|
|
||||||
makemd5
|
|
||||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
|
||||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
|
||||||
all install
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Build/InstallDev
|
|
||||||
$(INSTALL_DIR) $(1)/usr/include/
|
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/sasl $(1)/usr/include/
|
|
||||||
$(INSTALL_DIR) $(1)/usr/lib/
|
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libsasl2.{a,so*} $(1)/usr/lib/
|
|
||||||
ln -sf libsasl2.a $(1)/usr/lib/libsasl.a
|
|
||||||
ln -sf libsasl2.so $(1)/usr/lib/libsasl.so
|
|
||||||
$(INSTALL_DIR) $(1)/usr/lib/sasl2
|
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/sasl2/lib*.{a,so*} $(1)/usr/lib/sasl2/
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/libsasl2/install
|
|
||||||
$(INSTALL_DIR) $(1)/usr/lib/
|
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libsasl2.so.* $(1)/usr/lib/
|
|
||||||
$(INSTALL_DIR) $(1)/usr/lib/sasl2
|
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/sasl2/lib*.so.* $(1)/usr/lib/sasl2/
|
|
||||||
endef
|
|
||||||
|
|
||||||
$(eval $(call BuildPackage,libsasl2))
|
|
@ -1,125 +0,0 @@
|
|||||||
--- a/lib/Makefile.am
|
|
||||||
+++ b/lib/Makefile.am
|
|
||||||
@@ -44,6 +44,7 @@
|
|
||||||
sasl_version = 2:23:0
|
|
||||||
|
|
||||||
INCLUDES=-I$(top_srcdir)/include -I$(top_srcdir)/plugins -I$(top_builddir)/include -I$(top_srcdir)/sasldb
|
|
||||||
+SASL_STATIC_SRC = $(patsubst %.o, %.c, $(SASL_STATIC_OBJS))
|
|
||||||
|
|
||||||
EXTRA_DIST = windlopen.c staticopen.h NTMakefile
|
|
||||||
EXTRA_LIBRARIES = libsasl2.a
|
|
||||||
@@ -93,7 +94,7 @@ libsasl2.a: libsasl2.la $(SASL_STATIC_OB
|
|
||||||
rm -f $@
|
|
||||||
ln -s .libs/$@ $@
|
|
||||||
|
|
||||||
-$(SASL_STATIC_OBJS): linksrcs
|
|
||||||
+$(SASL_STATIC_SRC): linksrcs
|
|
||||||
|
|
||||||
linksrcs:
|
|
||||||
-ln -s $(SASL_STATIC_SRCS) .
|
|
||||||
--- a/lib/Makefile.in
|
|
||||||
+++ b/lib/Makefile.in
|
|
||||||
@@ -176,6 +176,7 @@ SASL_KRB_LIB = @SASL_KRB_LIB@
|
|
||||||
SASL_MECHS = @SASL_MECHS@
|
|
||||||
SASL_STATIC_LIBS = @SASL_STATIC_LIBS@
|
|
||||||
SASL_STATIC_OBJS = @SASL_STATIC_OBJS@
|
|
||||||
+SASL_STATIC_SRC = $(patsubst %.o, %.c, $(SASL_STATIC_OBJS))
|
|
||||||
SASL_STATIC_SRCS = @SASL_STATIC_SRCS@
|
|
||||||
SASL_UTIL_HEADERS_EXTRA = @SASL_UTIL_HEADERS_EXTRA@
|
|
||||||
SASL_UTIL_LIBS_EXTRA = @SASL_UTIL_LIBS_EXTRA@
|
|
||||||
@@ -646,7 +647,7 @@ libsasl2.a: libsasl2.la $(SASL_STATIC_OB
|
|
||||||
rm -f $@
|
|
||||||
ln -s .libs/$@ $@
|
|
||||||
|
|
||||||
-$(SASL_STATIC_OBJS): linksrcs
|
|
||||||
+$(SASL_STATIC_SRC): linksrcs
|
|
||||||
|
|
||||||
linksrcs:
|
|
||||||
-ln -s $(SASL_STATIC_SRCS) .
|
|
||||||
--- a/plugins/Makefile.am
|
|
||||||
+++ b/plugins/Makefile.am
|
|
||||||
@@ -82,12 +82,12 @@ EXTRA_LTLIBRARIES = libplain.la libanony
|
|
||||||
libntlm.la libpassdss.la libsasldb.la libsql.la libldapdb.la
|
|
||||||
|
|
||||||
libplain_la_SOURCES = plain.c plain_init.c $(common_sources)
|
|
||||||
-libplain_la_LDFLAGS = -version-info $(plain_version)
|
|
||||||
+libplain_la_LDFLAGS = -version-info $(plain_version) $(AM_LDFLAGS)
|
|
||||||
libplain_la_DEPENDENCIES = $(COMPAT_OBJS)
|
|
||||||
libplain_la_LIBADD = $(PLAIN_LIBS) $(COMPAT_OBJS)
|
|
||||||
|
|
||||||
libanonymous_la_SOURCES = anonymous.c anonymous_init.c $(common_sources)
|
|
||||||
-libanonymous_la_LDFLAGS = -version-info $(anonymous_version)
|
|
||||||
+libanonymous_la_LDFLAGS = -version-info $(anonymous_version) $(AM_LDFLAGS)
|
|
||||||
libanonymous_la_DEPENDENCIES = $(COMPAT_OBJS)
|
|
||||||
libanonymous_la_LIBADD = $(COMPAT_OBJS)
|
|
||||||
|
|
||||||
@@ -97,58 +97,58 @@ libkerberos4_la_DEPENDENCIES = $(COMPAT_
|
|
||||||
libkerberos4_la_LIBADD = $(SASL_KRB_LIB) $(LIB_SOCKET) $(COMPAT_OBJS)
|
|
||||||
|
|
||||||
libgssapiv2_la_SOURCES = gssapi.c gssapiv2_init.c $(common_sources)
|
|
||||||
-libgssapiv2_la_LDFLAGS = -version-info $(gssapiv2_version)
|
|
||||||
+libgssapiv2_la_LDFLAGS = -version-info $(gssapiv2_version) $(AM_LDFLAGS)
|
|
||||||
libgssapiv2_la_DEPENDENCIES = $(COMPAT_OBJS)
|
|
||||||
libgssapiv2_la_LIBADD = $(GSSAPIBASE_LIBS) $(GSSAPI_LIBS) $(LIB_SOCKET) $(COMPAT_OBJS)
|
|
||||||
|
|
||||||
libcrammd5_la_SOURCES = cram.c crammd5_init.c $(common_sources)
|
|
||||||
-libcrammd5_la_LDFLAGS = -version-info $(crammd5_version)
|
|
||||||
+libcrammd5_la_LDFLAGS = -version-info $(crammd5_version) $(AM_LDFLAGS)
|
|
||||||
libcrammd5_la_DEPENDENCIES = $(COMPAT_OBJS)
|
|
||||||
libcrammd5_la_LIBADD = $(COMPAT_OBJS)
|
|
||||||
|
|
||||||
libdigestmd5_la_SOURCES = digestmd5.c digestmd5_init.c $(common_sources)
|
|
||||||
-libdigestmd5_la_LDFLAGS = -version-info $(digestmd5_version)
|
|
||||||
+libdigestmd5_la_LDFLAGS = -version-info $(digestmd5_version) $(AM_LDFLAGS)
|
|
||||||
libdigestmd5_la_DEPENDENCIES = $(COMPAT_OBJS)
|
|
||||||
libdigestmd5_la_LIBADD = $(LIB_DES) $(LIB_SOCKET) $(COMPAT_OBJS)
|
|
||||||
|
|
||||||
liblogin_la_SOURCES = login.c login_init.c $(common_sources)
|
|
||||||
-liblogin_la_LDFLAGS = -version-info $(login_version)
|
|
||||||
+liblogin_la_LDFLAGS = -version-info $(login_version) $(AM_LDFLAGS)
|
|
||||||
liblogin_la_DEPENDENCIES = $(COMPAT_OBJS)
|
|
||||||
liblogin_la_LIBADD = $(PLAIN_LIBS) $(COMPAT_OBJS)
|
|
||||||
|
|
||||||
libsrp_la_SOURCES = srp.c srp_init.c $(common_sources)
|
|
||||||
-libsrp_la_LDFLAGS = -version-info $(srp_version)
|
|
||||||
+libsrp_la_LDFLAGS = -version-info $(srp_version) $(AM_LDFLAGS)
|
|
||||||
libsrp_la_DEPENDENCIES = $(COMPAT_OBJS)
|
|
||||||
libsrp_la_LIBADD = $(SRP_LIBS) $(COMPAT_OBJS)
|
|
||||||
|
|
||||||
libotp_la_SOURCES = otp.c otp_init.c otp.h $(common_sources)
|
|
||||||
-libotp_la_LDFLAGS = -version-info $(otp_version)
|
|
||||||
+libotp_la_LDFLAGS = -version-info $(otp_version) $(AM_LDFLAGS)
|
|
||||||
libotp_la_DEPENDENCIES = $(COMPAT_OBJS)
|
|
||||||
libotp_la_LIBADD = $(OTP_LIBS) $(COMPAT_OBJS)
|
|
||||||
|
|
||||||
libntlm_la_SOURCES = ntlm.c ntlm_init.c $(common_sources)
|
|
||||||
-libntlm_la_LDFLAGS = -version-info $(ntlm_version)
|
|
||||||
+libntlm_la_LDFLAGS = -version-info $(ntlm_version) $(AM_LDFLAGS)
|
|
||||||
libntlm_la_DEPENDENCIES = $(COMPAT_OBJS)
|
|
||||||
libntlm_la_LIBADD = $(NTLM_LIBS) $(COMPAT_OBJS)
|
|
||||||
|
|
||||||
libpassdss_la_SOURCES = passdss.c passdss_init.c $(common_sources)
|
|
||||||
-libpassdss_la_LDFLAGS = -version-info $(passdss_version)
|
|
||||||
+libpassdss_la_LDFLAGS = -version-info $(passdss_version) $(AM_LDFLAGS)
|
|
||||||
libpassdss_la_DEPENDENCIES = $(COMPAT_OBJS)
|
|
||||||
libpassdss_la_LIBADD = $(PASSDSS_LIBS) $(COMPAT_OBJS)
|
|
||||||
|
|
||||||
# Auxprop Plugins
|
|
||||||
libsasldb_la_SOURCES = sasldb.c sasldb_init.c $(common_sources)
|
|
||||||
-libsasldb_la_LDFLAGS = -version-info $(sasldb_version)
|
|
||||||
+libsasldb_la_LDFLAGS = -version-info $(sasldb_version) $(AM_LDFLAGS)
|
|
||||||
libsasldb_la_DEPENDENCIES = $(COMPAT_OBJS)
|
|
||||||
libsasldb_la_LIBADD = ../sasldb/libsasldb.la $(SASL_DB_LIB) $(COMPAT_OBJS)
|
|
||||||
|
|
||||||
libldapdb_la_SOURCES = ldapdb.c ldapdb_init.c $(common_sources)
|
|
||||||
-libldapdb_la_LDFLAGS = $(LIB_LDAP) -version-info $(ldapdb_version)
|
|
||||||
+libldapdb_la_LDFLAGS = $(LIB_LDAP) -version-info $(ldapdb_version) $(AM_LDFLAGS)
|
|
||||||
libldapdb_la_DEPENDENCIES = $(COMPAT_OBJS)
|
|
||||||
libldapdb_la_LIBADD = $(COMPAT_OBJS)
|
|
||||||
|
|
||||||
libsql_la_SOURCES = sql.c sql_init.c $(common_sources)
|
|
||||||
-libsql_la_LDFLAGS = $(LIB_MYSQL) $(LIB_PGSQL) $(LIB_SQLITE) -version-info $(sql_version)
|
|
||||||
+libsql_la_LDFLAGS = $(LIB_MYSQL) $(LIB_PGSQL) $(LIB_SQLITE) -version-info $(sql_version) $(AM_LDFLAGS)
|
|
||||||
libsql_la_DEPENDENCIES = $(COMPAT_OBJS)
|
|
||||||
libsql_la_LIBADD = $(COMPAT_OBJS)
|
|
||||||
|
|
@ -1,11 +0,0 @@
|
|||||||
--- a/config/config.sub
|
|
||||||
+++ b/config/config.sub
|
|
||||||
@@ -241,7 +241,7 @@ case $basic_machine in
|
|
||||||
| mips64vr5000 | mips64vr5000el | mcore | s390 | s390x \
|
|
||||||
| sparc | sparclet | sparclite | sparc64 | sparcv9 | sparcv9b \
|
|
||||||
| v850 | c4x \
|
|
||||||
- | thumb | d10v | d30v | fr30 | avr | openrisc | tic80 \
|
|
||||||
+ | thumb | d10v | d30v | fr30 | avr | avr32 | openrisc | tic80 \
|
|
||||||
| pj | pjl | h8500 | z8k)
|
|
||||||
basic_machine=$basic_machine-unknown
|
|
||||||
;;
|
|
Loading…
x
Reference in New Issue
Block a user