git-svn-id: svn://svn.openwrt.org/openwrt/packages@10572 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
olli 2008-03-09 10:07:53 +00:00
parent ed97cabd65
commit 87fbaf81df
2 changed files with 29 additions and 17 deletions

View File

@ -1,5 +1,5 @@
# #
# Copyright (C) 2007 OpenWrt.org # Copyright (C) 2007-2008 OpenWrt.org
# #
# This is free software, licensed under the GNU General Public License v2. # This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information. # See /LICENSE for more information.
@ -9,12 +9,12 @@
include $(TOPDIR)/rules.mk include $(TOPDIR)/rules.mk
PKG_NAME:=gkrellmd PKG_NAME:=gkrellmd
PKG_VERSION:=2.2.10 PKG_VERSION:=2.3.1
PKG_RELEASE:=1 PKG_RELEASE:=1
PKG_SOURCE_URL:=http://members.dslextreme.com/users/billw/gkrellm/
PKG_SOURCE:=gkrellm-$(PKG_VERSION).tar.bz2 PKG_SOURCE:=gkrellm-$(PKG_VERSION).tar.bz2
PKG_MD5SUM:=57ef0525c0997ac2e7720712811f5a84 PKG_SOURCE_URL:=http://members.dslextreme.com/users/billw/gkrellm/
PKG_MD5SUM:=009d8dddd3ce5cc83a4bb4d559ee922d
PKG_BUILD_DIR:=$(BUILD_DIR)/gkrellm-$(PKG_VERSION) PKG_BUILD_DIR:=$(BUILD_DIR)/gkrellm-$(PKG_VERSION)
@ -24,10 +24,16 @@ define Package/gkrellmd
SECTION:=admin SECTION:=admin
CATEGORY:=Administration CATEGORY:=Administration
DEPENDS:=+glib1 DEPENDS:=+glib1
TITLE:=System monitoring daemon TITLE:=The GNU Krell Monitors Server
URL:=http://gkrellm.net/ URL:=http://gkrellm.net/
endef endef
define Package/gkrellmd/description
Gkrellmd Listens for connections from gkrellm clients. When
a gkrellm client connects to a gkrellmd server all builtin
monitors collect their data from the server.
endef
define Build/Compile define Build/Compile
CFLAGS="$(TARGET_CFLAGS) $(EXTRA_CPPFLAGS)" \ CFLAGS="$(TARGET_CFLAGS) $(EXTRA_CPPFLAGS)" \
LDFLAGS="$(EXTRA_LDFLAGS) " \ LDFLAGS="$(EXTRA_LDFLAGS) " \
@ -44,7 +50,7 @@ define Package/gkrellmd/install
$(INSTALL_DIR) $(1)/etc $(INSTALL_DIR) $(1)/etc
$(INSTALL_CONF) $(PKG_BUILD_DIR)/server/$(PKG_NAME).conf $(1)/etc/ $(INSTALL_CONF) $(PKG_BUILD_DIR)/server/$(PKG_NAME).conf $(1)/etc/
$(INSTALL_DIR) $(1)/etc/init.d $(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) ./files/gkrellmd.init $(1)/etc/init.d/gkrellmd $(INSTALL_BIN) ./files/$(PKG_NAME).init $(1)/etc/init.d/$(PKG_NAME)
endef endef
$(eval $(call BuildPackage,gkrellmd)) $(eval $(call BuildPackage,gkrellmd))

View File

@ -1,6 +1,7 @@
diff -ur gkrellm-2.2.10~/server/gkrellmd.conf gkrellm-2.2.10/server/gkrellmd.conf Index: gkrellm-2.3.1/server/gkrellmd.conf
--- gkrellm-2.2.10~/server/gkrellmd.conf 2005-05-22 11:56:53.000000000 -0400 ===================================================================
+++ gkrellm-2.2.10/server/gkrellmd.conf 2007-03-10 23:32:23.000000000 -0500 --- gkrellm-2.3.1.orig/server/gkrellmd.conf 2008-03-09 10:19:26.000000000 +0100
+++ gkrellm-2.3.1/server/gkrellmd.conf 2008-03-09 10:19:26.000000000 +0100
@@ -4,7 +4,7 @@ @@ -4,7 +4,7 @@
# the client update frequency. Values may be from 1 to 10 and should be # the client update frequency. Values may be from 1 to 10 and should be
# smaller values to reduce network traffic. # smaller values to reduce network traffic.
@ -10,15 +11,16 @@ diff -ur gkrellm-2.2.10~/server/gkrellmd.conf gkrellm-2.2.10/server/gkrellmd.con
# Limit number of simultaneous clients allowed to connect. # Limit number of simultaneous clients allowed to connect.
# #
@@ -17,18 +17,18 @@ @@ -13,7 +13,7 @@
# List of hosts allowed to connect. If no hosts are specified in a # Specify a specific network interface to listen on for connections.
# gkrellmd.conf file or on the command line, all hosts will be allowed. # By default gkrellmd listens on all available network interfaces.
# #
-#allow-host localhost -address 127.0.0.1
+allow-host localhost +#address 127.0.0.1
#allow-host 127.0.0.1
#allow-host ::1 # Specify the port to listen on for connections.
#allow-host 192.168.0.* #
@@ -29,14 +29,14 @@
# Drop privileges after startup (you must start gkrellmd as root to do it). # Drop privileges after startup (you must start gkrellmd as root to do it).
# #
@ -26,6 +28,10 @@ diff -ur gkrellm-2.2.10~/server/gkrellmd.conf gkrellm-2.2.10/server/gkrellmd.con
+user nobody +user nobody
#group proc #group proc
# Create a PID file for the running gkrellmd. Default is no PID file.
-#pidfile /var/run/gkrellmd.pid
+pidfile /var/run/gkrellmd.pid
# Run in background and detach from the controlling terminal # Run in background and detach from the controlling terminal
-#detach -#detach
+detach +detach