added fltk2 (Fast Light Toolkit)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@14814 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
9254bd38bc
commit
8866ac5984
65
Xorg/lib/fltk2/Makefile
Normal file
65
Xorg/lib/fltk2/Makefile
Normal file
@ -0,0 +1,65 @@
|
|||||||
|
#
|
||||||
|
# Copyright (C) 2006-2008 OpenWrt.org
|
||||||
|
#
|
||||||
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
|
# See /LICENSE for more information.
|
||||||
|
#
|
||||||
|
# $Id: Makefile 12228 2008-08-06 22:43:15Z nbd $
|
||||||
|
|
||||||
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
|
PKG_NAME:=fltk2
|
||||||
|
PKG_REV:=6671
|
||||||
|
PKG_VERSION:=r$(PKG_REV)
|
||||||
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
|
PKG_SOURCE_PROTO:=svn
|
||||||
|
PKG_SOURCE_VERSION:=$(PKG_REV)
|
||||||
|
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
||||||
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
|
PKG_SOURCE_URL:=http://svn.easysw.com/public/fltk/fltk/trunk
|
||||||
|
PKG_BUILD_DIR=$(BUILD_DIR)/Xorg/$(_CATEGORY)/$(PKG_NAME)-$(PKG_VERSION)/
|
||||||
|
|
||||||
|
PKG_FIXUP = libtool
|
||||||
|
|
||||||
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
define Package/fltk2
|
||||||
|
SECTION:=xorg-framework
|
||||||
|
CATEGORY:=Xorg
|
||||||
|
SUBMENU:=framework
|
||||||
|
TITLE:=Fltk2
|
||||||
|
URL:=http://fltk.org/
|
||||||
|
DEPENDS:=+libXi +libstdcpp
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/fltk2/description
|
||||||
|
FLTK (pronounced <fulltick>) is a cross-platform C++ GUI toolkit for UNIX/Linux (X11), Microsoft Windows, and MacOS X. FLTK provides modern GUI functionality without the bloat and supports 3D graphics via OpenGL and its built-in GLUT emulation.
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Build/Configure
|
||||||
|
(cd $(PKG_BUILD_DIR); autoconf );
|
||||||
|
$(call Build/Configure/Default, --disable-jpeg --disable-zlib --disable-png --disable-gl --disable-xinerama --enable-shared --x-libraries=$(STAGING_DIR)/usr/lib --x-includes=$(STAGING_DIR)/usr/include)
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Build/Compile
|
||||||
|
$(MAKE) -C $(PKG_BUILD_DIR) all
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Build/Install
|
||||||
|
DESTDIR="$(PKG_INSTALL_DIR)" $(MAKE) -C $(PKG_BUILD_DIR) install
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Build/InstallDev
|
||||||
|
$(INSTALL_DIR) $(1)/usr/lib $(1)/usr/bin $(1)/usr/include
|
||||||
|
$(CP) $(PKG_INSTALL_DIR)/usr/lib/* $(1)/usr/lib/
|
||||||
|
$(CP) $(PKG_INSTALL_DIR)/usr/include/fltk $(1)/usr/include/
|
||||||
|
$(CP) $(PKG_INSTALL_DIR)/usr/bin/fltk2-config $(1)/usr/bin/
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/fltk2/install
|
||||||
|
$(INSTALL_DIR) $(1)/usr/lib
|
||||||
|
$(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so* $(1)/usr/lib/
|
||||||
|
endef
|
||||||
|
|
||||||
|
$(eval $(call BuildPackage,fltk2))
|
11
Xorg/lib/fltk2/patches/000-do-not-build-fltk-and-tests
Normal file
11
Xorg/lib/fltk2/patches/000-do-not-build-fltk-and-tests
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- fltk2/Makefile 2009-01-02 01:41:31.000000000 +0100
|
||||||
|
+++ fltk2/Makefile 2009-01-02 01:40:36.000000000 +0100
|
||||||
|
@@ -25,7 +25,7 @@
|
||||||
|
|
||||||
|
include makeinclude
|
||||||
|
|
||||||
|
-DIRS = src $(LOCALIMAGES) images OpenGL fluid glut test
|
||||||
|
+DIRS = src $(LOCALIMAGES) images
|
||||||
|
|
||||||
|
all: makeinclude
|
||||||
|
for dir in $(DIRS); do\
|
12
Xorg/lib/fltk2/patches/001-be-verbose
Normal file
12
Xorg/lib/fltk2/patches/001-be-verbose
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
--- fltk2/makeinclude.in 2009-01-02 02:28:29.000000000 +0100
|
||||||
|
+++ fltk2/makeinclude.in 2009-01-02 02:28:43.000000000 +0100
|
||||||
|
@@ -114,9 +114,6 @@
|
||||||
|
CAT1EXT = @CAT1EXT@
|
||||||
|
CAT3EXT = @CAT3EXT@
|
||||||
|
|
||||||
|
-# Be quiet when building...
|
||||||
|
-.SILENT:
|
||||||
|
-
|
||||||
|
# Build commands and filename extensions...
|
||||||
|
.SUFFIXES: .0 .1 .3 .c .cxx .h .fl .man .o .z $(EXEEXT)
|
||||||
|
|
26
Xorg/lib/fltk2/patches/002-honor-cppflags
Normal file
26
Xorg/lib/fltk2/patches/002-honor-cppflags
Normal file
@ -0,0 +1,26 @@
|
|||||||
|
--- fltk2/makeinclude.in 2009-01-02 02:58:26.000000000 +0100
|
||||||
|
+++ fltk2/makeinclude.in 2009-01-02 02:56:49.000000000 +0100
|
||||||
|
@@ -54,6 +54,7 @@
|
||||||
|
|
||||||
|
# flags for C++ compiler:
|
||||||
|
OPTIM = @OPTIM@
|
||||||
|
+CPPFLAGS = @CPPFLAGS@
|
||||||
|
CFLAGS = $(OPTIM) @CFLAGS@
|
||||||
|
CXXFLAGS = $(OPTIM) @CXXFLAGS@
|
||||||
|
|
||||||
|
--- fltk2-r6542/makeinclude.in.orig 2009-01-02 02:33:29.000000000 +0100
|
||||||
|
+++ fltk2-r6542/makeinclude.in 2009-01-02 02:37:27.000000000 +0100
|
||||||
|
@@ -124,11 +124,11 @@
|
||||||
|
|
||||||
|
.c.o:
|
||||||
|
echo Compiling $<...
|
||||||
|
- $(CC) -I.. -I../fltk/compat $(CFLAGS) -c $<
|
||||||
|
+ $(CC) $(CPPFLAGS) -I.. -I../fltk/compat $(CFLAGS) -c $<
|
||||||
|
|
||||||
|
.cxx.o:
|
||||||
|
echo Compiling $<...
|
||||||
|
- $(CXX) -I.. -I../fltk/compat $(CXXFLAGS) -c $<
|
||||||
|
+ $(CXX) $(CPPFLAGS) -I.. -I../fltk/compat $(CXXFLAGS) -c $<
|
||||||
|
|
||||||
|
.man.0 .man.1 .man.3:
|
||||||
|
echo Formatting $<...
|
Loading…
x
Reference in New Issue
Block a user