update chan_mobile to r725 based on backport patch from http://www.asterisk.org/node/48557
git-svn-id: svn://svn.openwrt.org/openwrt/packages@14337 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
0e09d54220
commit
88ff7a5838
@ -9,13 +9,12 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=asterisk
|
PKG_NAME:=asterisk
|
||||||
PKG_VERSION:=1.4.22
|
PKG_VERSION:=1.4.23.1
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=http://downloads.digium.com/pub/asterisk/releases/
|
PKG_SOURCE_URL:=http://downloads.digium.com/pub/asterisk/releases/
|
||||||
#PKG_MD5SUM:=c4cf69eb6eae3105806b08d3efc28ec7
|
PKG_MD5SUM:=4788954a93f5fbf78e55e2aa6e03329f
|
||||||
PKG_MD5SUM:=7626febc4a01e16e012dfccb9e4ab9d2
|
|
||||||
|
|
||||||
PKG_BUILD_DEPENDS:= libopenh323 pwlib
|
PKG_BUILD_DEPENDS:= libopenh323 pwlib
|
||||||
|
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
diff -Nru asterisk-1.4.22.org/acinclude.m4 asterisk-1.4.22/acinclude.m4
|
diff -Nru asterisk-1.4.23.1.org/autoconf/ast_check_openh323.m4 asterisk-1.4.23.1/autoconf/ast_check_openh323.m4
|
||||||
--- asterisk-1.4.22.org/acinclude.m4 2008-07-22 22:49:41.000000000 +0200
|
--- asterisk-1.4.23.1.org/autoconf/ast_check_openh323.m4 2008-10-20 06:57:33.000000000 +0200
|
||||||
+++ asterisk-1.4.22/acinclude.m4 2008-11-29 15:06:28.000000000 +0100
|
+++ asterisk-1.4.23.1/autoconf/ast_check_openh323.m4 2009-01-31 15:30:03.000000000 +0100
|
||||||
@@ -588,6 +588,7 @@
|
@@ -119,6 +119,7 @@
|
||||||
;;
|
;;
|
||||||
esac
|
esac
|
||||||
AC_MSG_RESULT(${OPENH323_BUILD})
|
AC_MSG_RESULT(${OPENH323_BUILD})
|
||||||
@ -9,12 +9,12 @@ diff -Nru asterisk-1.4.22.org/acinclude.m4 asterisk-1.4.22/acinclude.m4
|
|||||||
|
|
||||||
AC_SUBST([OPENH323_SUFFIX])
|
AC_SUBST([OPENH323_SUFFIX])
|
||||||
AC_SUBST([OPENH323_BUILD])
|
AC_SUBST([OPENH323_BUILD])
|
||||||
diff -Nru asterisk-1.4.22.org/configure.ac asterisk-1.4.22/configure.ac
|
diff -Nru asterisk-1.4.23.1.org/configure.ac asterisk-1.4.23.1/configure.ac
|
||||||
--- asterisk-1.4.22.org/configure.ac 2008-09-08 18:26:00.000000000 +0200
|
--- asterisk-1.4.23.1.org/configure.ac 2008-12-15 18:43:59.000000000 +0100
|
||||||
+++ asterisk-1.4.22/configure.ac 2008-11-29 15:06:28.000000000 +0100
|
+++ asterisk-1.4.23.1/configure.ac 2009-01-31 15:29:14.000000000 +0100
|
||||||
@@ -1259,7 +1259,7 @@
|
@@ -1278,7 +1278,7 @@
|
||||||
if test "${HAS_PWLIB:-unset}" != "unset"; then
|
if test "${HAS_PWLIB:-unset}" != "unset"; then
|
||||||
AST_CHECK_OPENH323_PLATFORM()
|
AST_CHECK_PWLIB_PLATFORM()
|
||||||
|
|
||||||
- PLATFORM_PWLIB="pt_${PWLIB_PLATFORM}_r"
|
- PLATFORM_PWLIB="pt_${PWLIB_PLATFORM}_r"
|
||||||
+ PLATFORM_PWLIB="pt_${PWLIB_PLATFORM}_r_s"
|
+ PLATFORM_PWLIB="pt_${PWLIB_PLATFORM}_r_s"
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
diff -Nru asterisk-1.4.22.org/acinclude.m4 asterisk-1.4.22/acinclude.m4
|
diff -Nru asterisk-1.4.23.1.org/autoconf/ast_prog_ld.m4 asterisk-1.4.23.1/autoconf/ast_prog_ld.m4
|
||||||
--- asterisk-1.4.22.org/acinclude.m4 2008-07-22 22:49:41.000000000 +0200
|
--- asterisk-1.4.23.1.org/autoconf/ast_prog_ld.m4 2008-10-20 06:45:56.000000000 +0200
|
||||||
+++ asterisk-1.4.22/acinclude.m4 2008-11-29 15:08:07.000000000 +0100
|
+++ asterisk-1.4.23.1/autoconf/ast_prog_ld.m4 2009-01-31 15:46:48.000000000 +0100
|
||||||
@@ -664,7 +664,7 @@
|
@@ -7,7 +7,7 @@
|
||||||
[assume the C compiler uses GNU ld @<:@default=no@:>@])],
|
[assume the C compiler uses GNU ld @<:@default=no@:>@])],
|
||||||
[test "$withval" = no || with_gnu_ld=yes],
|
[test "$withval" = no || with_gnu_ld=yes],
|
||||||
[with_gnu_ld=no])
|
[with_gnu_ld=no])
|
||||||
@ -10,10 +10,10 @@ diff -Nru asterisk-1.4.22.org/acinclude.m4 asterisk-1.4.22/acinclude.m4
|
|||||||
AC_REQUIRE([AC_PROG_CC])dnl
|
AC_REQUIRE([AC_PROG_CC])dnl
|
||||||
AC_REQUIRE([AC_CANONICAL_HOST])dnl
|
AC_REQUIRE([AC_CANONICAL_HOST])dnl
|
||||||
AC_REQUIRE([AC_CANONICAL_BUILD])dnl
|
AC_REQUIRE([AC_CANONICAL_BUILD])dnl
|
||||||
@@ -769,28 +769,6 @@
|
diff -Nru asterisk-1.4.23.1.org/autoconf/ast_prog_sed.m4 asterisk-1.4.23.1/autoconf/ast_prog_sed.m4
|
||||||
AC_SUBST([EGREP])
|
--- asterisk-1.4.23.1.org/autoconf/ast_prog_sed.m4 2008-10-20 06:45:56.000000000 +0200
|
||||||
])]) # AST_PROG_EGREP
|
+++ asterisk-1.4.23.1/autoconf/ast_prog_sed.m4 1970-01-01 01:00:00.000000000 +0100
|
||||||
|
@@ -1,21 +0,0 @@
|
||||||
-# AST_PROG_SED
|
-# AST_PROG_SED
|
||||||
-# -----------
|
-# -----------
|
||||||
-# Check for a fully functional sed program that truncates
|
-# Check for a fully functional sed program that truncates
|
||||||
@ -35,7 +35,3 @@ diff -Nru asterisk-1.4.22.org/acinclude.m4 asterisk-1.4.22/acinclude.m4
|
|||||||
- AC_SUBST([SED])dnl
|
- AC_SUBST([SED])dnl
|
||||||
- rm -f conftest.sed
|
- rm -f conftest.sed
|
||||||
-])# AST_PROG_SED
|
-])# AST_PROG_SED
|
||||||
-
|
|
||||||
dnl @synopsis ACX_PTHREAD([ACTION-IF-FOUND[, ACTION-IF-NOT-FOUND]])
|
|
||||||
dnl
|
|
||||||
dnl @summary figure out how to build C programs using POSIX threads
|
|
||||||
|
@ -1,12 +1,14 @@
|
|||||||
diff -Nru asterisk-1.4.22.org/main/asterisk.c asterisk-1.4.22/main/asterisk.c
|
diff -Nru asterisk-1.4.23.1.org/main/asterisk.c asterisk-1.4.23.1/main/asterisk.c
|
||||||
--- asterisk-1.4.22.org/main/asterisk.c 2008-07-26 17:31:21.000000000 +0200
|
--- asterisk-1.4.23.1.org/main/asterisk.c 2008-12-23 16:35:38.000000000 +0100
|
||||||
+++ asterisk-1.4.22/main/asterisk.c 2008-12-20 22:49:58.000000000 +0100
|
+++ asterisk-1.4.23.1/main/asterisk.c 2009-01-31 15:41:40.000000000 +0100
|
||||||
@@ -2935,7 +2935,38 @@
|
@@ -2986,9 +2986,40 @@
|
||||||
#if HAVE_WORKING_FORK
|
#if HAVE_WORKING_FORK
|
||||||
if (ast_opt_always_fork || !ast_opt_no_fork) {
|
if (ast_opt_always_fork || !ast_opt_no_fork) {
|
||||||
#ifndef HAVE_SBIN_LAUNCHD
|
#ifndef HAVE_SBIN_LAUNCHD
|
||||||
+#ifndef __UCLIBC__
|
+#ifndef __UCLIBC__
|
||||||
daemon(1, 0);
|
if (daemon(1, 0) < 0) {
|
||||||
|
ast_log(LOG_ERROR, "daemon() failed: %s\n", strerror(errno));
|
||||||
|
}
|
||||||
+#else
|
+#else
|
||||||
+/*
|
+/*
|
||||||
+ workaround for uClibc-0.9.29 mipsel bug:
|
+ workaround for uClibc-0.9.29 mipsel bug:
|
||||||
@ -16,26 +18,26 @@ diff -Nru asterisk-1.4.22.org/main/asterisk.c asterisk-1.4.22/main/asterisk.c
|
|||||||
+ (same code works if daemon() is not called)
|
+ (same code works if daemon() is not called)
|
||||||
+ but duplication of uClibc daemon.c code in here does work.
|
+ but duplication of uClibc daemon.c code in here does work.
|
||||||
+*/
|
+*/
|
||||||
+ int fd;
|
+ int fd;
|
||||||
+ switch (fork()) {
|
+ switch (fork()) {
|
||||||
+ case -1:
|
+ case -1:
|
||||||
+ exit(1);
|
+ exit(1);
|
||||||
+ case 0:
|
+ case 0:
|
||||||
+ break;
|
+ break;
|
||||||
+ default:
|
+ default:
|
||||||
+ _exit(0);
|
+ _exit(0);
|
||||||
+ }
|
+ }
|
||||||
+ if (setsid() == -1)
|
+ if (setsid() == -1)
|
||||||
+ exit(1);
|
+ exit(1);
|
||||||
+ if (fork())
|
+ if (fork())
|
||||||
+ _exit(0);
|
+ _exit(0);
|
||||||
+ if ((fd = open("/dev/null", O_RDWR, 0)) != -1) {
|
+ if ((fd = open("/dev/null", O_RDWR, 0)) != -1) {
|
||||||
+ dup2(fd, STDIN_FILENO);
|
+ dup2(fd, STDIN_FILENO);
|
||||||
+ dup2(fd, STDOUT_FILENO);
|
+ dup2(fd, STDOUT_FILENO);
|
||||||
+ dup2(fd, STDERR_FILENO);
|
+ dup2(fd, STDERR_FILENO);
|
||||||
+ if (fd > 2)
|
+ if (fd > 2)
|
||||||
+ close(fd);
|
+ close(fd);
|
||||||
+ }
|
+ }
|
||||||
+#endif
|
+#endif
|
||||||
ast_mainpid = getpid();
|
ast_mainpid = getpid();
|
||||||
/* Blindly re-write pid file since we are forking */
|
/* Blindly re-write pid file since we are forking */
|
||||||
|
@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
|
|||||||
|
|
||||||
PKG_NAME:=asterisk-addons
|
PKG_NAME:=asterisk-addons
|
||||||
PKG_VERSION:=1.4.7
|
PKG_VERSION:=1.4.7
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=2
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=http://downloads.digium.com/pub/asterisk/releases/
|
PKG_SOURCE_URL:=http://downloads.digium.com/pub/asterisk/releases/
|
||||||
|
File diff suppressed because it is too large
Load Diff
Loading…
x
Reference in New Issue
Block a user