libdnet: moved to github
Signed-off-by: Luka Perkov <luka@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/packages@44140 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
399ee9b7d1
commit
891955e4e8
@ -1,144 +0,0 @@
|
|||||||
#
|
|
||||||
# Copyright (C) 2006-2010 OpenWrt.org
|
|
||||||
#
|
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
|
||||||
# See /LICENSE for more information.
|
|
||||||
#
|
|
||||||
|
|
||||||
include $(TOPDIR)/rules.mk
|
|
||||||
|
|
||||||
PKG_NAME:=libdnet
|
|
||||||
PKG_VERSION:=1.11
|
|
||||||
PKG_RELEASE:=2
|
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
|
||||||
PKG_SOURCE_URL:=@SF/$(PKG_NAME)
|
|
||||||
PKG_MD5SUM:=04c394ed8e1e7fc455456e79e908916d
|
|
||||||
|
|
||||||
PKG_FIXUP:=autoreconf
|
|
||||||
PKG_INSTALL:=1
|
|
||||||
|
|
||||||
PKG_CONFIG_DEPENDS:=\
|
|
||||||
CONFIG_PACKAGE_libdnet \
|
|
||||||
CONFIG_PACKAGE_pydnet
|
|
||||||
|
|
||||||
PKG_BUILD_DEPENDS:=PACKAGE_pydnet:python
|
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
|
||||||
$(call include_mk, python-package.mk)
|
|
||||||
|
|
||||||
define Package/libdnet/Default
|
|
||||||
SECTION:=libs
|
|
||||||
CATEGORY:=Libraries
|
|
||||||
TITLE:=Low-level network library
|
|
||||||
URL:=http://sourceforge.net/projects/libdnet/
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/libdnet/Default/description
|
|
||||||
libdnet is a library of simplified, portable interface to several
|
|
||||||
low-level networking routines.
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/libdnet
|
|
||||||
$(call Package/libdnet/Default)
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/libdnet/description
|
|
||||||
$(call Package/libdnet/Default/description)
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/pydnet
|
|
||||||
$(call Package/libdnet/Default)
|
|
||||||
DEPENDS:=libdnet +python-mini
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/pydnet/description
|
|
||||||
$(call Package/libdnet/Default/description)
|
|
||||||
This package contains the python dnet library.
|
|
||||||
endef
|
|
||||||
|
|
||||||
TARGET_CFLAGS += $(FPIC)
|
|
||||||
|
|
||||||
CONFIGURE_ARGS += \
|
|
||||||
--enable-shared \
|
|
||||||
--enable-static \
|
|
||||||
--without-check \
|
|
||||||
--without-python
|
|
||||||
|
|
||||||
CONFIGURE_VARS += \
|
|
||||||
ac_cv_dnet_bsd_bpf=no
|
|
||||||
|
|
||||||
MAKE_FLAGS += \
|
|
||||||
CFLAGS="$(TARGET_CFLAGS) -D_GNU_SOURCE"
|
|
||||||
|
|
||||||
define Build/Configure
|
|
||||||
(cd $(PKG_BUILD_DIR); \
|
|
||||||
ln -sf config/acinclude.m4 . ; \
|
|
||||||
autoreconf -v --install || exit 1 \
|
|
||||||
);
|
|
||||||
$(call Build/Configure/Default)
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Build/Compile
|
|
||||||
$(call Build/Compile/Default)
|
|
||||||
$(if $(CONFIG_PACKAGE_pydnet), \
|
|
||||||
$(call Build/Compile/PyMod, \
|
|
||||||
python/, \
|
|
||||||
build \
|
|
||||||
) \
|
|
||||||
)
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Build/Install
|
|
||||||
$(call Build/Install/Default)
|
|
||||||
$(if $(CONFIG_PACKAGE_pydnet), \
|
|
||||||
$(call Build/Compile/PyMod, \
|
|
||||||
python/, \
|
|
||||||
install --no-compile --prefix $(PKG_INSTALL_DIR)/usr \
|
|
||||||
) \
|
|
||||||
)
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Build/InstallDev
|
|
||||||
$(INSTALL_DIR) $(2)/bin
|
|
||||||
$(INSTALL_BIN) \
|
|
||||||
$(PKG_INSTALL_DIR)/usr/bin/dnet-config \
|
|
||||||
$(2)/bin/
|
|
||||||
$(SED) \
|
|
||||||
's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' \
|
|
||||||
$(2)/bin/dnet-config
|
|
||||||
|
|
||||||
$(INSTALL_DIR) $(1)/usr/include
|
|
||||||
$(INSTALL_DATA)\
|
|
||||||
$(PKG_INSTALL_DIR)/usr/include/dnet.h \
|
|
||||||
$(1)/usr/include/
|
|
||||||
$(CP) \
|
|
||||||
$(PKG_INSTALL_DIR)/usr/include/dnet \
|
|
||||||
$(1)/usr/include/
|
|
||||||
|
|
||||||
$(INSTALL_DIR) $(1)/usr/lib
|
|
||||||
$(CP) \
|
|
||||||
$(PKG_INSTALL_DIR)/usr/lib/libdnet.{la,a,so*} \
|
|
||||||
$(1)/usr/lib/
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/libdnet/install
|
|
||||||
$(INSTALL_DIR) $(1)/usr/lib
|
|
||||||
$(CP) \
|
|
||||||
$(PKG_INSTALL_DIR)/usr/lib/libdnet.so.* \
|
|
||||||
$(1)/usr/lib/
|
|
||||||
|
|
||||||
$(INSTALL_DIR) $(1)/usr/sbin
|
|
||||||
$(INSTALL_BIN) \
|
|
||||||
$(PKG_INSTALL_DIR)/usr/sbin/dnet \
|
|
||||||
$(1)/usr/sbin/
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/pydnet/install
|
|
||||||
$(INSTALL_DIR) $(1)/usr/lib
|
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/python* $(1)/usr/lib/
|
|
||||||
endef
|
|
||||||
|
|
||||||
|
|
||||||
$(eval $(call BuildPackage,libdnet))
|
|
||||||
$(eval $(call BuildPackage,pydnet))
|
|
@ -1,23 +0,0 @@
|
|||||||
--- a/dnet-config.in
|
|
||||||
+++ b/dnet-config.in
|
|
||||||
@@ -45,10 +45,18 @@ while test $# -gt 0; do
|
|
||||||
done
|
|
||||||
|
|
||||||
if test "$echo_cflags" = "yes"; then
|
|
||||||
- echo -I@includedir@
|
|
||||||
+ includes=
|
|
||||||
+ if test "@includedir@" != "/usr/include" ; then
|
|
||||||
+ includes=-I@includedir@
|
|
||||||
+ fi
|
|
||||||
+ echo $includes
|
|
||||||
fi
|
|
||||||
|
|
||||||
if test "$echo_libs" = "yes"; then
|
|
||||||
- echo -L@libdir@ -ldnet @LIBS@
|
|
||||||
+ libs=
|
|
||||||
+ if test "@libdir@" != "/usr/lib" ; then
|
|
||||||
+ libs=-I@libdir@
|
|
||||||
+ fi
|
|
||||||
+ echo $libs -ldnet @LIBS@
|
|
||||||
fi
|
|
||||||
|
|
@ -1,20 +0,0 @@
|
|||||||
--- a/config/config.sub
|
|
||||||
+++ b/config/config.sub
|
|
||||||
@@ -228,7 +228,7 @@ case $basic_machine in
|
|
||||||
| a29k \
|
|
||||||
| alpha | alphaev[4-8] | alphaev56 | alphaev6[78] | alphapca5[67] \
|
|
||||||
| alpha64 | alpha64ev[4-8] | alpha64ev56 | alpha64ev6[78] | alpha64pca5[67] \
|
|
||||||
- | arc | arm | arm[bl]e | arme[lb] | armv[2345] | armv[345][lb] | avr \
|
|
||||||
+ | arc | arm | arm[bl]e | arme[lb] | armv[2345] | armv[345][lb] | avr | avr32 \
|
|
||||||
| c4x | clipper \
|
|
||||||
| d10v | d30v | dlx | dsp16xx \
|
|
||||||
| fr30 | frv \
|
|
||||||
@@ -290,7 +290,7 @@ case $basic_machine in
|
|
||||||
| alpha64-* | alpha64ev[4-8]-* | alpha64ev56-* | alpha64ev6[78]-* \
|
|
||||||
| alphapca5[67]-* | alpha64pca5[67]-* | arc-* \
|
|
||||||
| arm-* | armbe-* | armle-* | armeb-* | armv*-* \
|
|
||||||
- | avr-* \
|
|
||||||
+ | avr-* | avr32-* \
|
|
||||||
| bs2000-* \
|
|
||||||
| c[123]* | c30-* | [cjt]90-* | c54x-* \
|
|
||||||
| clipper-* | cydra-* \
|
|
@ -1,20 +0,0 @@
|
|||||||
--- a/python/dnet.c
|
|
||||||
+++ b/python/dnet.c
|
|
||||||
@@ -2726,7 +2726,7 @@ static PyObject *__pyx_f_4dnet_15__addr_
|
|
||||||
PyObject *__pyx_3 = 0;
|
|
||||||
unsigned short __pyx_4;
|
|
||||||
Py_INCREF(__pyx_v_self);
|
|
||||||
- ((PyObject*)__pyx_v_next) = Py_None; Py_INCREF(((PyObject*)__pyx_v_next));
|
|
||||||
+ __pyx_v_next = Py_None; Py_INCREF(((PyObject*)__pyx_v_next));
|
|
||||||
|
|
||||||
/* "/Users/dugsong/projects/libdnet/python/./dnet.pyx":634 */
|
|
||||||
__pyx_1 = (((struct __pyx_obj_4dnet___addr_ip4_iter *)__pyx_v_self)->cur <= ((struct __pyx_obj_4dnet___addr_ip4_iter *)__pyx_v_self)->max);
|
|
||||||
@@ -2738,7 +2738,7 @@ static PyObject *__pyx_f_4dnet_15__addr_
|
|
||||||
Py_DECREF(__pyx_2); __pyx_2 = 0;
|
|
||||||
if (!__Pyx_TypeTest(__pyx_3, __pyx_ptype_4dnet_addr)) {__pyx_filename = __pyx_f[0]; __pyx_lineno = 635; goto __pyx_L1;}
|
|
||||||
Py_DECREF(((PyObject *)__pyx_v_next));
|
|
||||||
- ((PyObject *)__pyx_v_next) = __pyx_3;
|
|
||||||
+ __pyx_v_next = __pyx_3;
|
|
||||||
__pyx_3 = 0;
|
|
||||||
|
|
||||||
/* "/Users/dugsong/projects/libdnet/python/./dnet.pyx":636 */
|
|
Loading…
x
Reference in New Issue
Block a user