fix bmon
git-svn-id: svn://svn.openwrt.org/openwrt/packages@5007 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
12c8c0d4df
commit
89a780a8dc
@ -3,7 +3,7 @@
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
# $Id: Makefile 4603 2006-08-18 21:21:06Z mbm $
|
||||
# $Id$
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
@ -36,9 +36,10 @@ endef
|
||||
|
||||
define Build/Configure
|
||||
$(call Build/Configure/Default, \
|
||||
--disable-cnt-workaroun \
|
||||
--disable-cnt-workaround \
|
||||
--disable-dbi \
|
||||
--disable-rrd \
|
||||
--disable-asoun \
|
||||
--disable-asound \
|
||||
)
|
||||
endef
|
||||
|
||||
@ -49,7 +50,8 @@ endef
|
||||
|
||||
define Package/bmon/install
|
||||
install -d -m0755 $(1)/usr/sbin
|
||||
$(CP) $(PKG_BUILD_DIR)/src/bmon $(1)/usr/sbin
|
||||
install -m0755 $(PKG_BUILD_DIR)/src/bmon $(1)/usr/sbin/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,bmon))
|
||||
|
||||
|
24
net/bmon/patches/01-bugfixes.patch
Normal file
24
net/bmon/patches/01-bugfixes.patch
Normal file
@ -0,0 +1,24 @@
|
||||
diff -ruN bmon-2.1.0-old/src/out_audio.c bmon-2.1.0-new/src/out_audio.c
|
||||
--- bmon-2.1.0-old/src/out_audio.c 2005-04-05 17:01:33.000000000 +0200
|
||||
+++ bmon-2.1.0-new/src/out_audio.c 2006-10-09 23:11:44.000000000 +0200
|
||||
@@ -141,7 +141,7 @@
|
||||
.om_draw = audio_draw,
|
||||
.om_set_opts = audio_set_opts,
|
||||
.om_probe = audio_probe,
|
||||
- .om_shutdown audio_shutdown,
|
||||
+ .om_shutdown = audio_shutdown,
|
||||
};
|
||||
|
||||
static void __init audio_init(void)
|
||||
diff -ruN bmon-2.1.0-old/src/out_xml_event.c bmon-2.1.0-new/src/out_xml_event.c
|
||||
--- bmon-2.1.0-old/src/out_xml_event.c 2005-04-05 17:01:33.000000000 +0200
|
||||
+++ bmon-2.1.0-new/src/out_xml_event.c 2006-10-09 23:11:59.000000000 +0200
|
||||
@@ -127,7 +127,7 @@
|
||||
.om_draw = xml_event_draw,
|
||||
.om_set_opts = xml_event_set_opts,
|
||||
.om_probe = xml_event_probe,
|
||||
- .om_shutdown xml_event_shutdown,
|
||||
+ .om_shutdown = xml_event_shutdown,
|
||||
};
|
||||
|
||||
static void __init xml_event_init(void)
|
Loading…
x
Reference in New Issue
Block a user