bluez-libs: remove

Superseeded by bluez recently added to github repo

git-svn-id: svn://svn.openwrt.org/openwrt/packages@43903 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
nico 2015-01-09 20:15:03 +00:00
parent 5fc871012e
commit 8ad093d2ad
2 changed files with 0 additions and 65 deletions

View File

@ -1,50 +0,0 @@
#
# Copyright (C) 2006-2010 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=bluez-libs
PKG_VERSION:=3.36
PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://bluez.sourceforge.net/download
PKG_MD5SUM:=8c2ca546c0e7bb73dbd0e906fce7f6b1
PKG_FIXUP:=autoreconf
PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
define Package/bluez-libs
SECTION:=libs
CATEGORY:=Libraries
TITLE:=Bluetooth library
URL:=http://www.bluez.org/
endef
CONFIGURE_ARGS += \
--enable-shared \
--enable-static \
TARGET_CFLAGS += $(FPIC)
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include/bluetooth
$(CP) $(PKG_INSTALL_DIR)/usr/include/bluetooth/*.h $(1)/usr/include/bluetooth
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libbluetooth.{a,so*} $(1)/usr/lib/
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/bluez.pc $(1)/usr/lib/pkgconfig/
endef
define Package/bluez-libs/install
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libbluetooth.so.* $(1)/usr/lib/
endef
$(eval $(call BuildPackage,bluez-libs))

View File

@ -1,15 +0,0 @@
diff --git a/configure b/configure
index 6a387c6..5ffc003 100755
--- a/configure
+++ b/configure
@@ -2430,10 +2430,6 @@ fi
prefix="${ac_default_prefix}"
fi
- if (test "${libdir}" = '${exec_prefix}/lib'); then
- libdir="${prefix}/lib"
- fi
-
if (test "$sysconfdir" = '${prefix}/etc'); then
configdir="${prefix}/etc/bluetooth"
else