[package] update httping to 1.3.1 (#5800)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@17621 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2009-09-20 10:55:03 +00:00
parent 1972759f3d
commit 8b00256d07
3 changed files with 21 additions and 14 deletions

View File

@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=httping
PKG_VERSION:=1.3.0
PKG_VERSION:=1.3.1
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
PKG_SOURCE_URL:=http://www.vanheusden.com/httping/
PKG_MD5SUM:=41c912a9ecc904e51d7260053fc2195c
PKG_MD5SUM:=fb742d577d3e7a8ea75cf97f7eb802f2
include $(INCLUDE_DIR)/package.mk

View File

@ -1,13 +1,20 @@
--- a/Makefile
+++ b/Makefile
@@ -15,8 +15,8 @@
include version
@@ -18,7 +18,7 @@ TARGET=httping
DEBUG=-g # -D_DEBUG
-LDFLAGS+=-lssl -lcrypto $(DEBUG)
-CFLAGS+=-O2 -Wall -DVERSION=\"$(VERSION)\" $(DEBUG)
+LDFLAGS+=$(EXTRA_LDFLAGS) -lssl -lcrypto $(DEBUG)
+CFLAGS+=$(EXTRA_CFLAGS) -Wall -DVERSION=\"$(VERSION)\" $(DEBUG)
WFLAGS=-Wall -W
OFLAGS=-O2
-CFLAGS=$(WFLAGS) $(OFLAGS) -DVERSION=\"$(VERSION)\"
+CFLAGS=$(EXTRA_CFLAGS) $(WFLAGS) $(OFLAGS) -DVERSION=\"$(VERSION)\"
OBJS=mem.o http.o io.o str.o error.o utils.o main.o tcp.o mssl.o res.o
PACKAGE=$(TARGET)-$(VERSION)
PREFIX=/usr
@@ -47,7 +47,7 @@ ifeq ($(SSL),no)
CFLAGS+=-DNO_SSL
else
OBJS+=mssl.o
-LDFLAGS+=-lssl -lcrypto
+LDFLAGS+=$(EXTRA_LDFLAGS) -lssl -lcrypto
endif
ifeq ($(DEBUG),yes)

View File

@ -4,7 +4,7 @@
#include "utils.h"
#include "error.h"
+#define VERSION "1.3.0"
+#define VERSION "1.3.1"
+
static volatile int stop = 0;
@ -13,12 +13,12 @@
void version(void)
{
- fprintf(stderr, "HTTPing v" VERSION ", (C) 2003-2008 folkert@vanheusden.com\n");
+ fprintf(stderr, "HTTPing v%s (C) 2003-2008 folkert@vanheusden.com\n", VERSION);
- fprintf(stderr, "HTTPing v" VERSION ", (C) 2003-2009 folkert@vanheusden.com\n");
+ fprintf(stderr, "HTTPing v%s (C) 2003-2009 folkert@vanheusden.com\n", VERSION);
#ifndef NO_SSL
fprintf(stderr, "SSL support included\n");
#endif
@@ -444,7 +446,7 @@ int main(int argc, char *argv[])
@@ -449,7 +451,7 @@ int main(int argc, char *argv[])
if (useragent)
sprintf(&request[strlen(request)], "User-Agent: %s\r\n", useragent);
else