package: haproxy

- refresh patches
 - bump to version 1.4.21



git-svn-id: svn://svn.openwrt.org/openwrt/packages@31839 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
heil 2012-05-21 21:43:44 +00:00
parent a0c3611d6b
commit 8b9c7748ad
2 changed files with 7 additions and 7 deletions

View File

@ -9,12 +9,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=haproxy
PKG_VERSION:=1.4.20
PKG_VERSION:=1.4.21
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://haproxy.1wt.eu/download/1.4/src
PKG_MD5SUM:=0cd3b91812ff31ae09ec4ace6355e29e
PKG_MD5SUM:=f36d5d13fd4a44ab454eee5d06cb38a2
include $(INCLUDE_DIR)/package.mk

View File

@ -152,7 +152,7 @@
* socket. The listener provides the protocol-specific accept() function to
--- a/src/cfgparse.c
+++ b/src/cfgparse.c
@@ -1464,6 +1464,16 @@ int cfg_parse_listen(const char *file, i
@@ -1466,6 +1466,16 @@ int cfg_parse_listen(const char *file, i
#endif
}
@ -169,7 +169,7 @@
if (!strcmp(args[cur_arg], "name")) {
struct listener *l;
@@ -1516,7 +1526,7 @@ int cfg_parse_listen(const char *file, i
@@ -1518,7 +1528,7 @@ int cfg_parse_listen(const char *file, i
continue;
}
@ -178,7 +178,7 @@
file, linenum, args[0]);
err_code |= ERR_ALERT | ERR_FATAL;
goto out;
@@ -5710,6 +5720,9 @@ out_uri_auth_compat:
@@ -5731,6 +5741,9 @@ out_uri_auth_compat:
listener->handler = process_session;
listener->analysers |= curproxy->fe_req_ana;
@ -392,7 +392,7 @@
*/
--- a/src/proto_http.c
+++ b/src/proto_http.c
@@ -4029,7 +4029,8 @@ void http_end_txn_clean_session(struct s
@@ -4087,7 +4087,8 @@ void http_end_txn_clean_session(struct s
if (s->rep->lr >= s->rep->data + s->rep->size)
s->rep->lr -= s->req->size;
@ -402,7 +402,7 @@
s->rep->analysers = 0;
http_silent_debug(__LINE__, s);
@@ -7562,7 +7563,6 @@ void http_reset_txn(struct session *s)
@@ -7624,7 +7625,6 @@ void http_reset_txn(struct session *s)
http_init_txn(s);
s->be = s->fe;