[packages] tor-alpha: update to 0.2.3.15-alpha, re-enable fixed UPnP support
git-svn-id: svn://svn.openwrt.org/openwrt/packages@31579 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
7465418a62
commit
8d45ff5a03
@ -8,15 +8,15 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=tor-alpha
|
PKG_NAME:=tor-alpha
|
||||||
PKG_VERSION:=0.2.3.13-alpha
|
PKG_VERSION:=0.2.3.15-alpha
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=tor-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=tor-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=https://www.torproject.org/dist \
|
PKG_SOURCE_URL:=https://www.torproject.org/dist \
|
||||||
https://archive.torproject.org/tor-package-archive
|
https://archive.torproject.org/tor-package-archive
|
||||||
PKG_MD5SUM:=503d7b043875e9745db7cb06a26e2c5c
|
PKG_MD5SUM:=80c6019b6cfa5106282e46ae81c9b59c
|
||||||
|
|
||||||
PKG_BUILD_DEPENDS:=libnatpmp
|
PKG_BUILD_DEPENDS:=libminiupnpc libnatpmp
|
||||||
PKG_BUILD_DIR:=$(BUILD_DIR)/tor-$(PKG_VERSION)
|
PKG_BUILD_DIR:=$(BUILD_DIR)/tor-$(PKG_VERSION)
|
||||||
PKG_INSTALL:=1
|
PKG_INSTALL:=1
|
||||||
|
|
||||||
@ -50,7 +50,7 @@ endef
|
|||||||
define Package/tor-alpha-fw-helper
|
define Package/tor-alpha-fw-helper
|
||||||
$(call Package/tor-alpha/Default)
|
$(call Package/tor-alpha/Default)
|
||||||
TITLE:=Firewall helper for tor
|
TITLE:=Firewall helper for tor
|
||||||
DEPENDS:=+tor-alpha +libnatpmp
|
DEPENDS:=+tor-alpha +libminiupnpc +libnatpmp
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/tor-alpha-fw-helper/description
|
define Package/tor-alpha-fw-helper/description
|
||||||
@ -76,6 +76,8 @@ endef
|
|||||||
CONFIGURE_ARGS += \
|
CONFIGURE_ARGS += \
|
||||||
--with-libevent-dir="$(STAGING_DIR)/usr" \
|
--with-libevent-dir="$(STAGING_DIR)/usr" \
|
||||||
--with-ssl-dir="$(STAGING_DIR)/usr" \
|
--with-ssl-dir="$(STAGING_DIR)/usr" \
|
||||||
|
--enable-upnp \
|
||||||
|
--with-libminiupnpc-dir="$(STAGING_DIR)/usr" \
|
||||||
--enable-nat-pmp \
|
--enable-nat-pmp \
|
||||||
--with-libnatpmp-dir="$(STAGING_DIR)/usr" \
|
--with-libnatpmp-dir="$(STAGING_DIR)/usr" \
|
||||||
--enable-bufferevents \
|
--enable-bufferevents \
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/src/config/torrc.sample.in
|
--- a/src/config/torrc.sample.in
|
||||||
+++ b/src/config/torrc.sample.in
|
+++ b/src/config/torrc.sample.in
|
||||||
@@ -46,11 +46,11 @@ SocksListenAddress 127.0.0.1 # accept co
|
@@ -45,11 +45,11 @@
|
||||||
## Uncomment this to start the process in the background... or use
|
## Uncomment this to start the process in the background... or use
|
||||||
## --runasdaemon 1 on the command line. This is ignored on Windows;
|
## --runasdaemon 1 on the command line. This is ignored on Windows;
|
||||||
## see the FAQ entry if you want Tor to run as an NT service.
|
## see the FAQ entry if you want Tor to run as an NT service.
|
||||||
@ -14,7 +14,7 @@
|
|||||||
|
|
||||||
## The port on which Tor will listen for local connections from Tor
|
## The port on which Tor will listen for local connections from Tor
|
||||||
## controller applications, as documented in control-spec.txt.
|
## controller applications, as documented in control-spec.txt.
|
||||||
@@ -182,3 +182,4 @@ SocksListenAddress 127.0.0.1 # accept co
|
@@ -187,3 +187,4 @@
|
||||||
## address manually to your friends, uncomment this line:
|
## address manually to your friends, uncomment this line:
|
||||||
#PublishServerDescriptor 0
|
#PublishServerDescriptor 0
|
||||||
|
|
||||||
|
Loading…
x
Reference in New Issue
Block a user