[packages] glib: the nineties called, they want their macros back...

- correct and cleanup configure.ac to make it work with autoreconf
	- fix other outstanding autofail issues
	- cleanup and refresh patches
	- drop uneeded debian patch


git-svn-id: svn://svn.openwrt.org/openwrt/packages@25961 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
jow 2011-03-08 18:47:10 +00:00
parent 0a80ed565e
commit 8d84e2f567
7 changed files with 350 additions and 19230 deletions

View File

@ -18,7 +18,9 @@ PKG_SOURCE_URL:=ftp://ftp.gtk.org/pub/gtk/v1.2 \
http://www.mirrorservice.org/sites/ftp.gimp.org/pub/gtk/v1.2/
PKG_MD5SUM:=6fe30dad87c77b91b632def29dd69ef9
PKG_FIXUP:=libtool
PKG_FIXUP:=autoreconf
PKG_REMOVE_FILES:=aclocal.m4 acinclude.m4
PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
@ -58,6 +60,11 @@ CONFIGURE_VARS += \
glib_cv_func_pthread_cond_timedwait_posix=yes \
glib_cv_sizeof_gmutex=24 \
glib_cv_byte_contents_gmutex="0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0" \
glib_cv_sys_pthread_getspecific_posix=yes \
glib_cv_sys_pthread_mutex_trylock_posix=yes \
glib_cv_sys_pthread_cond_timedwait_posix=yes \
ac_cv_func_getpwuid_r=yes \
ac_cv_func_getpwuid_r_posix=yes
define Build/InstallDev
$(INSTALL_DIR) $(1) $(2)/bin

View File

@ -0,0 +1,333 @@
--- a/configure.in
+++ b/configure.in
@@ -1,10 +1,9 @@
dnl ***********************************
dnl *** include special GLib macros ***
dnl ***********************************
-builtin(include, acglib.m4)dnl
-# require autoconf 2.13
-AC_PREREQ(2.13)
+# require autoconf 2.53
+AC_PREREQ(2.53)
# init autoconf (and check for presence of glist.c)
AC_INIT(glist.c)
@@ -13,11 +12,10 @@ AC_INIT(glist.c)
cflags_set=${CFLAGS+set}
# we rewrite this file
-rm -f glibconfig-sysdefs.h
+if test "x$cross_compiling" != "xyes"; then
+ rm -f glibconfig-sysdefs.h
+fi
-dnl we need to AC_DIVERT_PUSH/AC_DIVERT_POP these variable definitions so they
-dnl are available for $ac_help expansion (don't we all *love* autoconf?)
-AC_DIVERT_PUSH(AC_DIVERSION_NOTICE)dnl
#
# The following version number definitions apply to GLib, GModule and GThread
# as a whole, so if changes occoured in any of them, they are all
@@ -38,7 +36,6 @@ GLIB_INTERFACE_AGE=10
GLIB_BINARY_AGE=10
GLIB_VERSION=$GLIB_MAJOR_VERSION.$GLIB_MINOR_VERSION.$GLIB_MICRO_VERSION
dnl
-AC_DIVERT_POP()dnl
AC_SUBST(GLIB_MAJOR_VERSION)
AC_SUBST(GLIB_MINOR_VERSION)
@@ -77,17 +74,13 @@ AM_PROG_LIBTOOL
dnl Initialize maintainer mode
AM_MAINTAINER_MODE
-AC_CANONICAL_HOST
-
dnl figure debugging default, prior to $ac_help setup
dnl
-AC_DIVERT_PUSH(AC_DIVERSION_NOTICE)dnl
if test `expr $GLIB_MINOR_VERSION \% 2` = 1 ; then
debug_default=yes
else
debug_default=minimum
fi
-AC_DIVERT_POP()dnl
dnl declare --enable-* args and collect ac_help strings
AC_ARG_ENABLE(debug, [ --enable-debug=[no/minimum/yes] turn on debugging [default=$debug_default]],,enable_debug=$debug_default)
@@ -178,38 +171,6 @@ if test "x$GCC" = "xyes"; then
fi
changequote([,])dnl
-dnl DU4 native cc currently needs -std1 for ANSI mode (instead of K&R)
-AC_MSG_CHECKING([for extra flags to get ANSI library prototypes])
-glib_save_LIBS=$LIBS
-LIBS="$LIBS -lm"
-AC_TRY_RUN([#include <math.h>
- int main (void) { return (log(1) != log(1.)); }],
- AC_MSG_RESULT(none needed),
- glib_save_CFLAGS=$CFLAGS
- CFLAGS="$CFLAGS -std1"
- AC_TRY_RUN([#include <math.h>
- int main (void) { return (log(1) != log(1.)); }],
- AC_MSG_RESULT(-std1),
- AC_MSG_RESULT()
- CFLAGS=$glib_save_CFLAGS
- AC_MSG_WARN(
- [No ANSI prototypes found in library. (-std1 didn't work.)])
- )
-)
-LIBS=$glib_save_LIBS
-
-dnl NeXTStep cc seems to need this
-AC_MSG_CHECKING([for extra flags for POSIX compliance])
-AC_TRY_COMPILE([#include <dirent.h>], [DIR *dir;],
- AC_MSG_RESULT(none needed),
- glib_save_CFLAGS=$CFLAGS
- CFLAGS="$CFLAGS -posix"
- AC_TRY_COMPILE([#include <dirent.h>], [DIR *dir;],
- AC_MSG_RESULT(-posix),
- AC_MSG_RESULT()
- CFLAGS=$glib_save_CFLAGS
- AC_MSG_WARN([Could not determine POSIX flag. (-posix didn't work.)])))
-
# Checks for header files.
AC_HEADER_STDC
@@ -218,13 +179,6 @@ AC_FUNC_VPRINTF
AC_CHECK_FUNCS(atexit on_exit)
-AC_CHECK_SIZEOF(char)
-AC_CHECK_SIZEOF(short)
-AC_CHECK_SIZEOF(long)
-AC_CHECK_SIZEOF(int)
-AC_CHECK_SIZEOF(void *)
-AC_CHECK_SIZEOF(long long)
-
dnl long doubles were not used, and a portability problem
dnl AC_C_LONG_DOUBLE
AC_C_CONST
@@ -405,11 +359,13 @@ AC_CACHE_VAL(glib_cv_sane_realloc,[
return realloc (0, sizeof (int)) == 0;
}],
glib_cv_sane_realloc=yes
- AC_DEFINE(REALLOC_0_WORKS)
,
glib_cv_sane_realloc=no
,)
])
+if test "x$glib_cv_sane_realloc" = "xyes"; then
+ AC_DEFINE(REALLOC_0_WORKS)
+fi
AC_MSG_RESULT($glib_cv_sane_realloc)
@@ -485,7 +441,8 @@ AC_CACHE_VAL(glib_cv_va_val_copy,[
])
if test "x$glib_cv_va_copy" = "xyes"; then
AC_DEFINE(G_VA_COPY, va_copy)
-else if test "x$glib_cv___va_copy" = "xyes"; then
+else
+if test "x$glib_cv___va_copy" = "xyes"; then
AC_DEFINE(G_VA_COPY, __va_copy)
fi
fi
@@ -505,21 +462,13 @@ G_MODULE_NEED_USCORE=0
G_MODULE_BROKEN_RTLD_GLOBAL=0
G_MODULE_HAVE_DLERROR=0
dnl *** dlopen() and dlsym() in system libraries
-if test -z "$G_MODULE_IMPL"; then
- AC_CHECK_FUNC(dlopen,
- AC_CHECK_FUNC(dlsym,
- G_MODULE_IMPL=G_MODULE_IMPL_DL
- ,)
- ,)
-fi
+AC_CHECK_FUNC([dlopen], [AC_CHECK_FUNC([dlsym], [G_MODULE_IMPL=G_MODULE_IMPL_DL], [])], [])
dnl *** dlopen() and dlsym() in libdl
if test -z "$G_MODULE_IMPL"; then
- AC_CHECK_LIB(dl, dlopen,
- AC_CHECK_LIB(dl, dlsym,
- G_MODULE_LIBS=-ldl
- G_MODULE_IMPL=G_MODULE_IMPL_DL
- ,)
- ,)
+ AC_CHECK_LIB([dl], [dlopen], [AC_CHECK_LIB([dl], [dlsym], [
+ G_MODULE_LIBS=-ldl
+ G_MODULE_IMPL=G_MODULE_IMPL_DL
+ ], [])], [])
fi
dnl *** shl_load() in libdld (HP-UX)
if test -z "$G_MODULE_IMPL"; then
@@ -784,13 +733,13 @@ AC_MSG_RESULT($G_THREAD_LIBS)
dnl determination of G_THREAD_CFLAGS
dnl ********************************
-if test x"$have_threads" != xnone; then
+if test "x$have_threads" != xnone; then
G_THREAD_CFLAGS="$G_THREAD_CFLAGS -D_REENTRANT" # good default guess
case $host in
*-aix*)
G_THREAD_CFLAGS="$G_THREAD_CFLAGS -D_THREAD_SAFE"
- if test x"$GCC" = xyes; then
+ if test "x$GCC" = xyes; then
G_THREAD_CFLAGS="$G_THREAD_CFLAGS -mthreads"
fi
;;
@@ -822,7 +771,7 @@ fi
dnl check for mt safe function variants
dnl ***********************************
-if test x"$have_threads" != xnone; then
+if test "x$have_threads" != xnone; then
glib_save_LIBS="$LIBS"
glib_save_CFLAGS="$CFLAGS"
# we are not doing the following for now, as this might require glib
@@ -854,49 +803,68 @@ if test x"$have_threads" != xnone; then
AC_MSG_CHECKING(whether getpwuid_r is posix like)
# The signature for the POSIX version is:
# int getpwuid_r(uid_t, struct passwd *, char *, size_t, struct passwd **)
- AC_TRY_COMPILE([#include <pwd.h>
- #include <sys/types.h>
- #include <stdlib.h>],
- [getpwuid_r((uid_t)0, NULL, NULL, (size_t)0, NULL);],
- [AC_DEFINE(HAVE_GETPWUID_R_POSIX)
- AC_MSG_RESULT(yes)],
- [AC_MSG_RESULT(no)])
+ AC_CACHE_CHECK([whether pthread_getspecific is posix like],
+ [ac_cv_func_getpwuid_r_posix],
+ [AC_TRY_COMPILE([#include <pwd.h>
+ #include <sys/types.h>
+ #include <stdlib.h>],
+ [getpwuid_r((uid_t)0, NULL, NULL, (size_t)0, NULL);],
+ [ac_cv_func_getpwuid_r_posix=yes],
+ [ac_cv_func_getpwuid_r_posix=no])]
+ )
+ if test "x$ac_cv_func_getpwuid_r_posix" = "xyes"; then
+ AC_DEFINE(HAVE_GETPWUID_R_POSIX)
+ fi
fi
fi
- if test x"$have_threads" = xposix; then
+ if test "x$have_threads" = xposix; then
LIBS="$LIBS $G_THREAD_LIBS"
AC_MSG_CHECKING(whether pthread_getspecific is posix like)
# PCThreads has pthread_getspecific(pthread_key_t, void **);
- AC_TRY_COMPILE([#include <pthread.h>],
- [pthread_getspecific(0,NULL);],
- [AC_MSG_RESULT(no)],
- [AC_MSG_RESULT(yes)
- AC_DEFINE(HAVE_PTHREAD_GETSPECIFIC_POSIX)])
+ AC_CACHE_CHECK([whether pthread_getspecific is posix like],
+ [glib_cv_sys_pthread_getspecific_posix],
+ [AC_TRY_COMPILE([#include <pthread.h>],
+ [pthread_getspecific(0,NULL);],
+ [glib_cv_sys_pthread_getspecific_posix=no],
+ [glib_cv_sys_pthread_getspecific_posix=yes])]
+ )
+ if test "x$glib_cv_sys_pthread_getspecific_posix" = "xyes"; then
+ AC_DEFINE(HAVE_PTHREAD_GETSPECIFIC_POSIX)
+ fi
AC_MSG_CHECKING(whether pthread_mutex_trylock is posix like)
# DCE Threads return 1 as success, posix 0. what a mess.
- AC_TRY_RUN([#include <pthread.h>
- pthread_mutex_t mutex = PTHREAD_MUTEX_INITIALIZER;
- int main () {
- return !pthread_mutex_trylock (&mutex); }],
- [AC_MSG_RESULT(no)],
- [AC_MSG_RESULT(yes)
- AC_DEFINE(HAVE_PTHREAD_MUTEX_TRYLOCK_POSIX)])
+ AC_CACHE_CHECK([whether pthread_mutex_trylock is posix like],
+ [glib_cv_sys_pthread_mutex_trylock_posix],
+ [AC_TRY_RUN([#include <pthread.h>
+ pthread_mutex_t mutex = PTHREAD_MUTEX_INITIALIZER;
+ int main () {
+ return !pthread_mutex_trylock (&mutex); }],
+ [glib_cv_sys_pthread_mutex_trylock_posix=no],
+ [glib_cv_sys_pthread_mutex_trylock_posix=yes])]
+ )
+ if test "x$glib_cv_sys_pthread_mutex_trylock_posix=no" = "xyes"; then
+ AC_DEFINE(HAVE_PTHREAD_MUTEX_TRYLOCK_POSIX)
+ fi
AC_MSG_CHECKING(whether pthread_cond_timedwait is posix like)
# DCE Threads return -1 as failure, posix ETIMEDOUT.
- AC_TRY_RUN([#include <pthread.h>
- int main () {
- pthread_mutex_t mutex = PTHREAD_MUTEX_INITIALIZER;
- pthread_cond_t cond = PTHREAD_COND_INITIALIZER;
- struct timeval tval;
- struct timespec tspec;
- gettimeofday (&tval, NULL);
- tspec.tv_sec = tval.tv_sec;
- tspec.tv_nsec = 0;
- return pthread_cond_timedwait (&cond,&mutex,&tspec)
- != -1;}],
- [AC_MSG_RESULT(no)],
- [AC_MSG_RESULT(yes)
- AC_DEFINE(HAVE_PTHREAD_COND_TIMEDWAIT_POSIX)])
+ AC_CACHE_CHECK([whether pthread_cond_timedwait is posix like],
+ [glib_cv_sys_pthread_cond_timedwait_posix],
+ [AC_TRY_RUN([#include <pthread.h>
+ int main () {
+ pthread_mutex_t mutex = PTHREAD_MUTEX_INITIALIZER;
+ pthread_cond_t cond = PTHREAD_COND_INITIALIZER;
+ struct timeval tval;
+ struct timespec tspec;
+ gettimeofday (&tval, NULL);
+ tspec.tv_sec = tval.tv_sec;
+ tspec.tv_nsec = 0;
+ return pthread_cond_timedwait (&cond,&mutex,&tspec) != -1;}],
+ [glib_cv_sys_pthread_cond_timedwait_posix=no],
+ [glib_cv_sys_pthread_cond_timedwait_posix=yes])]
+ )
+ if test "x$glib_cv_sys_pthread_cond_timedwait_posix" = "xyes"; then
+ AC_DEFINE(HAVE_PTHREAD_COND_TIMEDWAIT_POSIX)
+ fi
fi
LIBS="$glib_save_LIBS"
CFLAGS="$glib_save_CFLAGS"
@@ -940,13 +908,21 @@ GLIB_IF_VAR_EQ(mutex_has_default, yes,
dnl ****************************************
dnl *** GLib POLL* compatibility defines ***
dnl ****************************************
+if test "x$cross_compiling" != "xyes"; then
GLIB_SYSDEFS(
[#include <sys/types.h>
#include <sys/poll.h>],
POLLIN:1 POLLOUT:4 POLLPRI:2 POLLERR:8 POLLHUP:16 POLLNVAL:32,
glibconfig-sysdefs.h,
=)
+fi
+dnl Needed for the gint* case switches further down ...
+AC_CHECK_SIZEOF([short])
+AC_CHECK_SIZEOF([int])
+AC_CHECK_SIZEOF([long])
+AC_CHECK_SIZEOF([long long])
+AC_CHECK_SIZEOF([void *])
dnl ******************************
dnl *** output the whole stuff ***
--- a/Makefile.am
+++ b/Makefile.am
@@ -70,7 +70,7 @@ configinclude_DATA = \
CONFIGURE_DEPENDENCIES = acglib.m4
-BUILT_SOURCES = stamp-gc-h #note: not glibconfig.h
+BUILT_SOURCES += stamp-gc-h #note: not glibconfig.h
glibconfig.h: stamp-gc-h
@:
stamp-gc-h: config.status
--- a/gmodule/Makefile.am
+++ b/gmodule/Makefile.am
@@ -42,7 +42,7 @@ libgplugin_b_la_LDFLAGS = @G_MODULE_LDFL
libgplugin_b_la_LIBADD = @G_MODULE_LIBS@ # $(libglib)
noinst_PROGRAMS = testgmodule
-testgmodule_LDFLAGS += @G_MODULE_LDFLAGS@
+testgmodule_LDFLAGS = @G_MODULE_LDFLAGS@
testgmodule_LDADD = libgmodule.la $(libglib) @G_MODULE_LIBS@
.PHONY: files release

File diff suppressed because it is too large Load Diff

View File

@ -1,210 +0,0 @@
diff -urN glib-1.2.10.old/configure glib-1.2.10/configure
--- glib-1.2.10.old/configure 2005-04-03 01:09:18.000000000 +0200
+++ glib-1.2.10/configure 2005-04-03 01:09:37.000000000 +0200
@@ -6025,7 +6025,7 @@
glib_save_LIBS=$LIBS
LIBS="$LIBS -lm"
if test "$cross_compiling" = yes; then
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
else
cat > conftest.$ac_ext <<EOF
#line 6032 "configure"
@@ -6043,7 +6043,7 @@
glib_save_CFLAGS=$CFLAGS
CFLAGS="$CFLAGS -std1"
if test "$cross_compiling" = yes; then
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
else
cat > conftest.$ac_ext <<EOF
#line 6050 "configure"
@@ -6390,7 +6390,7 @@
echo $ac_n "(cached) $ac_c" 1>&6
else
if test "$cross_compiling" = yes; then
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
else
cat > conftest.$ac_ext <<EOF
#line 6397 "configure"
@@ -6430,7 +6430,7 @@
echo $ac_n "(cached) $ac_c" 1>&6
else
if test "$cross_compiling" = yes; then
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
else
cat > conftest.$ac_ext <<EOF
#line 6437 "configure"
@@ -6470,7 +6470,7 @@
echo $ac_n "(cached) $ac_c" 1>&6
else
if test "$cross_compiling" = yes; then
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
else
cat > conftest.$ac_ext <<EOF
#line 6477 "configure"
@@ -6510,7 +6510,7 @@
echo $ac_n "(cached) $ac_c" 1>&6
else
if test "$cross_compiling" = yes; then
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
else
cat > conftest.$ac_ext <<EOF
#line 6517 "configure"
@@ -6550,7 +6550,7 @@
echo $ac_n "(cached) $ac_c" 1>&6
else
if test "$cross_compiling" = yes; then
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
else
cat > conftest.$ac_ext <<EOF
#line 6557 "configure"
@@ -6590,7 +6590,7 @@
echo $ac_n "(cached) $ac_c" 1>&6
else
if test "$cross_compiling" = yes; then
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
else
cat > conftest.$ac_ext <<EOF
#line 6597 "configure"
@@ -6708,7 +6708,7 @@
else
if test "$cross_compiling" = yes; then
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
else
cat > conftest.$ac_ext <<EOF
#line 6715 "configure"
@@ -6749,7 +6749,7 @@
else
if test "$cross_compiling" = yes; then
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
else
cat > conftest.$ac_ext <<EOF
#line 6756 "configure"
@@ -6790,7 +6790,7 @@
else
if test "$cross_compiling" = yes; then
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
else
cat > conftest.$ac_ext <<EOF
#line 6797 "configure"
@@ -6876,7 +6876,7 @@
rm -f conftest*
if test $ac_cv_c_bigendian = unknown; then
if test "$cross_compiling" = yes; then
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
else
cat > conftest.$ac_ext <<EOF
#line 6883 "configure"
@@ -7767,7 +7767,7 @@
else
if test "$cross_compiling" = yes; then
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
else
cat > conftest.$ac_ext <<EOF
#line 7774 "configure"
@@ -7809,7 +7809,7 @@
else
if test "$cross_compiling" = yes; then
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
else
cat > conftest.$ac_ext <<EOF
#line 7816 "configure"
@@ -7854,7 +7854,7 @@
else
if test "$cross_compiling" = yes; then
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
else
cat > conftest.$ac_ext <<EOF
#line 7861 "configure"
@@ -7899,7 +7899,7 @@
else
if test "$cross_compiling" = yes; then
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
else
cat > conftest.$ac_ext <<EOF
#line 7906 "configure"
@@ -8254,7 +8254,7 @@
else
if test "$cross_compiling" = yes; then
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
else
cat > conftest.$ac_ext <<EOF
#line 8261 "configure"
@@ -8306,7 +8306,7 @@
else
if test "$cross_compiling" = yes; then
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
else
cat > conftest.$ac_ext <<EOF
#line 8313 "configure"
@@ -9137,7 +9137,7 @@
echo $ac_n "(cached) $ac_c" 1>&6
else
if test "$cross_compiling" = yes; then
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
else
cat > conftest.$ac_ext <<EOF
#line 9144 "configure"
@@ -9237,7 +9237,7 @@
echo "configure:9238: checking whether pthread_mutex_trylock is posix like" >&5
# DCE Threads return 1 as success, posix 0. what a mess.
if test "$cross_compiling" = yes; then
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
else
cat > conftest.$ac_ext <<EOF
#line 9244 "configure"
@@ -9267,7 +9267,7 @@
echo "configure:9268: checking whether pthread_cond_timedwait is posix like" >&5
# DCE Threads return -1 as failure, posix ETIMEDOUT.
if test "$cross_compiling" = yes; then
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
else
cat > conftest.$ac_ext <<EOF
#line 9274 "configure"
@@ -9332,7 +9332,7 @@
echo $ac_n "(cached) $ac_c" 1>&6
else
if test "$cross_compiling" = yes; then
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
else
cat > conftest.$ac_ext <<EOF
#line 9339 "configure"
@@ -9452,7 +9452,7 @@
done
echo "return 0; }" >>confrun.c
if test "$cross_compiling" = yes; then
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
else
cat > conftest.$ac_ext <<EOF
#line 9459 "configure"

View File

@ -0,0 +1,9 @@
--- /dev/null
+++ b/glibconfig-sysdefs.h
@@ -0,0 +1,6 @@
+#define GLIB_SYSDEF_POLLIN =1
+#define GLIB_SYSDEF_POLLPRI =2
+#define GLIB_SYSDEF_POLLOUT =4
+#define GLIB_SYSDEF_POLLERR =8
+#define GLIB_SYSDEF_POLLHUP =16
+#define GLIB_SYSDEF_POLLNVAL =32

View File

@ -1,31 +0,0 @@
diff -urN glib-1.2.10.old/glib.h glib-1.2.10/glib.h
--- glib-1.2.10.old/glib.h 2001-02-27 04:44:38.000000000 +0100
+++ glib-1.2.10/glib.h 2005-04-03 01:43:17.000000000 +0200
@@ -63,6 +63,7 @@
* exist. The prototype looks like the above, give or take a const,
* or size_t.
*/
+#include <glibconfig-sysdefs.h>
#include <glibconfig.h>
/* include varargs functions for assertment macros
diff -urN glib-1.2.10.old/configure glib-1.2.10/configure
--- glib-1.2.10.old/configure 2005-04-03 01:43:49.000000000 +0200
+++ glib-1.2.10/configure 2005-04-03 01:45:47.000000000 +0200
@@ -575,16 +575,6 @@
# Save this value here, since automake will set cflags later
cflags_set=${CFLAGS+set}
-# we rewrite this file
-rm -f glibconfig-sysdefs.h
-
-
-
-
-
-
-
-
# libtool versioning
LT_RELEASE=$GLIB_MAJOR_VERSION.$GLIB_MINOR_VERSION