Port reaim to -ng

git-svn-id: svn://svn.openwrt.org/openwrt/packages@4505 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2006-08-07 12:39:12 +00:00
parent 5d7da31e96
commit 8ee1d1f0cf
3 changed files with 130 additions and 0 deletions

52
net/reaim/Makefile Normal file
View File

@ -0,0 +1,52 @@
#
# Copyright (C) 2006 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
# $Id$
include $(TOPDIR)/rules.mk
PKG_NAME:=reaim
PKG_VERSION:=0.8
PKG_RELEASE:=1
PKG_MD5SUM:=647d2ab72ec454f89294accfb3182c09
PKG_SOURCE_URL:=@SF/reaim
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_CAT:=zcat
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
include $(INCLUDE_DIR)/package.mk
define Package/reaim
SECTION:=net
CATEGORY:=Network
DEPENDS:=+iptables
TITLE:=A transparent AIM / MSN proxy
DESCRIPTION:=ReAIM is a proxy for file transfers with MSN/AIM.
URL:=http://reaim.sourceforge.net
endef
define Build/Compile
rm -rf $(PKG_INSTALL_DIR)
mkdir -p $(PKG_INSTALL_DIR)
$(MAKE) -C $(PKG_BUILD_DIR) \
CC=$(TARGET_CC) \
CFLAGS="$(TARGET_CFLAGS)" \
DESTDIR="$(PKG_INSTALL_DIR)" \
all install
endef
define Package/reaim/install
install -d -m0755 $(1)/etc/init.d
install -m0755 ./files/reaim.init $(1)/etc/init.d/reaim
ln -sf reaim $(1)/etc/init.d/S63reaim
install -d -m0755 $(1)/usr/sbin
$(CP) $(PKG_INSTALL_DIR)/usr/sbin/reaim $(1)/usr/sbin/
endef
$(eval $(call BuildPackage,reaim))

View File

@ -0,0 +1,62 @@
#! /bin/sh
PATH=/sbin:/bin:/usr/sbin:/usr/bin
NAME=reaim
DESC="Transparent proxy for IM behind NAT"
. /etc/functions.sh
WAN=$(nvram get wan_ifname)
IPT=/usr/sbin/iptables
case "$1" in
start)
if [ -e /var/run/$NAME.pid ]; then
echo "$DESC: $NAME already started."
exit 0
fi
echo -n "Starting $DESC: $NAME"
$IPT -A input_rule -i $WAN -p tcp --dport 1863:1864 -j ACCEPT
$IPT -A input_rule -i $WAN -p tcp --dport 4443 -j ACCEPT
$IPT -A input_rule -i $WAN -p tcp --dport 5566 -j ACCEPT
$IPT -A input_rule -i $WAN -p tcp --dport 40000:40099 -j ACCEPT
test -e /var/run/$NAME.pid || touch /var/run/$NAME.pid
/usr/sbin/$NAME
echo "."
;;
stop)
if [ ! -e /var/run/$NAME.pid ]; then
echo "$DESC: $NAME is not running."
exit 0
fi
echo -n "Stopping $DESC: $NAME"
killall $NAME
rm -f /var/run/$NAME.pid
echo "."
;;
restart|force-reload)
if [ ! -e /var/run/$NAME.pid ]; then
$0 start
exit 0
fi
echo -n "Restarting $DESC: $NAME"
$IPT -A input_rule -i $WAN -p tcp --dport 1863:1864 -j ACCEPT
$IPT -A input_rule -i $WAN -p tcp --dport 4443 -j ACCEPT
$IPT -A input_rule -i $WAN -p tcp --dport 5566 -j ACCEPT
$IPT -A input_rule -i $WAN -p tcp --dport 40000:40099 -j ACCEPT
killall $NAME
sleep 1
/usr/sbin/$NAME
echo "."
;;
*)
N=/etc/init.d/$NAME
echo "Usage: $N {start|stop|restart|force-reload}" >&2
exit 1
;;
esac
exit 0

View File

@ -0,0 +1,16 @@
diff -urN reaim-0.8/Makefile reaim-0.8/Makefile
--- reaim-0.8/Makefile 2002-11-28 06:10:38.000000000 +0100
+++ reaim-0.8/Makefile 2005-10-07 12:07:43.000000000 +0200
@@ -11,7 +11,10 @@
endif
reaim: reaim.c
- gcc -o reaim reaim.c -g -Wall $(FW_FLAGS)
-
+ $(CC) $(CFLAGS) -o reaim reaim.c -Wall $(FW_FLAGS)
clean:
-rm reaim
+
+install:
+ install -d -m 0755 $(DESTDIR)/usr/sbin
+ install -m 0755 reaim $(DESTDIR)/usr/sbin/