netio: fix passing our CFLAGS to the Makefile

Signed-off-by: Florian Fainelli <florian@openwrt.org>

git-svn-id: svn://svn.openwrt.org/openwrt/packages@39821 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2014-03-08 00:57:29 +00:00
parent 9f3a515d86
commit 8fa9b9c091
2 changed files with 9 additions and 7 deletions

View File

@ -1,5 +1,5 @@
# #
# Copyright (C) 2006-2011 OpenWrt.org # Copyright (C) 2006-2014 OpenWrt.org
# #
# This is free software, licensed under the GNU General Public License v2. # This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information. # See /LICENSE for more information.
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=netio PKG_NAME:=netio
PKG_VERSION:=1.31 PKG_VERSION:=1.31
PKG_RELEASE:=1 PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)$(subst .,,$(PKG_VERSION)).zip PKG_SOURCE:=$(PKG_NAME)$(subst .,,$(PKG_VERSION)).zip
PKG_SOURCE_URL:=http://www.ars.de/ars/ars.nsf/f24a6a0b94c22d82862566960071bf5a/aa577bc4be573b05c125706d004c75b5/%24FILE/ PKG_SOURCE_URL:=http://www.ars.de/ars/ars.nsf/f24a6a0b94c22d82862566960071bf5a/aa577bc4be573b05c125706d004c75b5/%24FILE/
@ -30,7 +30,7 @@ define Package/netio
endef endef
define Build/Compile define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) linux CC="$(TARGET_CC)" $(MAKE) -C $(PKG_BUILD_DIR) linux CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS) -DUNIX"
endef endef
define Package/netio/install define Package/netio/install

View File

@ -1,11 +1,13 @@
--- a/Makefile 2011-01-17 17:15:11.000000000 +0100 --- a/Makefile
+++ b/Makefile 2010-10-14 15:03:42.000000000 +0200 +++ b/Makefile
@@ -84,7 +84,7 @@ @@ -84,8 +84,8 @@ solaris:
$(MAKE) all CC="gcc -O -s" O=.o X= \ $(MAKE) all CC="gcc -O -s" O=.o X= \
CFLAGS="-DUNIX" LFLAGS="" LIBS="-lsocket -lpthread -lnsl" OUT=-o CFLAGS="-DUNIX" LFLAGS="" LIBS="-lsocket -lpthread -lnsl" OUT=-o
linux: linux:
- $(MAKE) all CC="gcc -O -s" O=.o X= \ - $(MAKE) all CC="gcc -O -s" O=.o X= \
- CFLAGS="-DUNIX" LFLAGS="" LIBS="-lpthread" OUT=-o
+ $(MAKE) all CC="$(CC) -O -s" O=.o X= \ + $(MAKE) all CC="$(CC) -O -s" O=.o X= \
CFLAGS="-DUNIX" LFLAGS="" LIBS="-lpthread" OUT=-o + LFLAGS="" LIBS="-lpthread" OUT=-o
macosx: macosx:
$(MAKE) all CC="gcc -O" O=.o X= \ $(MAKE) all CC="gcc -O" O=.o X= \
CFLAGS="-DUNIX -DSOCKLEN_T" LFLAGS="" LIBS="-lpthread" OUT=-o