[package] delete nfs-utils now that nfs-kernel-server packages this utility

git-svn-id: svn://svn.openwrt.org/openwrt/packages@16026 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2009-05-24 12:44:52 +00:00
parent aac1fa38c5
commit 9017d146a0
2 changed files with 0 additions and 94 deletions

View File

@ -1,57 +0,0 @@
#
# Copyright (C) 2006-2008 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=nfs-utils
PKG_VERSION:=1.1.5
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=@SF/nfs
PKG_MD5SUM:=2848072a5e53840b9bc520fbb6782b57
PKG_BUILD_DEPENDS:=libgssapi librpcsecgss libnfsidmap libwrap
include $(INCLUDE_DIR)/package.mk
define Package/nfs-utils/Default
SECTION:=net
CATEGORY:=Network
URL:=http://sourceforge.net/projects/nfs/
endef
define Package/nfs-utils
$(call Package/nfs-utils/Default)
DEPENDS:=+libwrap +libevent +libblkid
TITLE:=updated mount utility (includes nfs4)
endef
define Package/nfs-utils/description
Updated mount.nfs command - allows mounting nfs4 volumes
endef
CONFIGURE_ARGS += --disable-gss
TARGET_CFLAGS += -I$(PKG_BUILD_DIR)/lib
TARGET_LDFLAGS += -Wl,-rpath-link=$(STAGING_DIR)/usr/lib
define Build/Compile
$(call Build/Compile/Default, \
OPT="$(TARGET_CFLAGS)" \
INSTALLSUID="install -m 4755" \
DESTDIR="$(PKG_INSTALL_DIR)" \
all install \
)
endef
define Package/nfs-utils/install
$(INSTALL_DIR) $(1)/sbin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/sbin/mount.nfs $(1)/sbin/
(cd $(1)/sbin; ln -sf mount.nfs mount.nfs4; ln -sf mount.nfs umount.nfs; ln -sf mount.nfs umount.nfs4)
endef
$(eval $(call BuildPackage,nfs-utils))

View File

@ -1,37 +0,0 @@
diff -urN nfs-utils-1.1.5/utils/mountd/cache.c nfs-utils-1.1.5.new/utils/mountd/cache.c
--- nfs-utils-1.1.5/utils/mountd/cache.c 2009-03-05 12:42:56.000000000 +0100
+++ nfs-utils-1.1.5.new/utils/mountd/cache.c 2009-04-07 16:11:09.000000000 +0200
@@ -142,6 +142,7 @@
pw = getpwuid(uid);
if (!pw)
rv = -1;
+#ifndef __UCLIBC__
else {
rv = getgrouplist(pw->pw_name, pw->pw_gid, groups, &ngroups);
if (rv == -1 && ngroups >= 100) {
@@ -153,6 +154,7 @@
groups, &ngroups);
}
}
+#endif /* __UCLIBC__ */
qword_printint(f, uid);
qword_printint(f, time(0)+30*60);
if (rv >= 0) {
diff -burN nfs-utils-1.1.5/support/nfs/svc_socket.c nfs-utils-1.1.5.p/support/nfs/svc_socket.c
--- nfs-utils-1.1.5/support/nfs/svc_socket.c 2009-03-05 12:42:56.000000000 +0100
+++ nfs-utils-1.1.5.p/support/nfs/svc_socket.c 2009-04-07 17:33:07.307458029 +0200
@@ -66,9 +66,13 @@
memset (&addr, 0, sizeof (addr));
addr.sin_family = AF_INET;
-
+#ifndef __UCLIBC__ /* neither getrpcbynumber() nor getrpcbynumber_r() is SuSv3 */
ret = getrpcbynumber_r (number, &rpcbuf, rpcdata, sizeof rpcdata,
&rpcp);
+#else
+ rpcp = getrpcbynumber (number);
+ ret = 0;
+#endif
if (ret == 0 && rpcp != NULL)
{
/* First try name. */