xapian: update core and bindings to 1.2.8, fix compile errors

git-svn-id: svn://svn.openwrt.org/openwrt/packages@30600 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
nbd 2012-02-16 18:08:31 +00:00
parent 3a3bae91d5
commit 90e102fbef
7 changed files with 35 additions and 139 deletions

View File

@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=xapian-bindings
PKG_VERSION:=1.0.7
PKG_VERSION:=1.2.8
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://oligarchy.co.uk/xapian/$(PKG_VERSION)
PKG_MD5SUM:=a80e51f4971d7505abcc0bdde912266b
PKG_MD5SUM:=4bfe673c71ac074e349ef691d7ba56d0
PKG_FIXUP:=libtool
@ -31,6 +31,9 @@ define Package/python-xapian
DEPENDS:=+python-mini +libxapian
endef
MAKE_FLAGS += \
pkgpylib_DATA=xapian/__init__.py
CONFIGURE_ARGS+= \
--with-python \

View File

@ -1,67 +0,0 @@
--- a/python/Makefile.am
+++ b/python/Makefile.am
@@ -23,7 +23,7 @@ pylibdir = @PYTHON_LIB@
# Install as _DATA rather than _SCRIPTS because we don't want to make these
# executable (they don't have a #! line).
-pylib_DATA = xapian.py xapian.pyc xapian.pyo
+pylib_DATA = xapian.py
pylib_LTLIBRARIES = _xapian.la
@@ -53,20 +53,12 @@ _xapian_la_LIBADD = $(XAPIAN_LIBS) $(PYT
xapian.py: modern/xapian.py
cp `test -f modern/xapian.py || echo '$(srcdir)/'`modern/xapian.py .
-# We "import _xapian" first so that if we fail to import the glue library
-# we don't generate a broken xapian.pyc or xapian.pyo.
-xapian.pyc: xapian.py _xapian$(PYTHON_SO)
- PYTHONPATH=. $(PYTHON) -c "import _xapian;import xapian"
-
-xapian.pyo: xapian.py _xapian$(PYTHON_SO)
- PYTHONPATH=. $(PYTHON) -O -c "import _xapian;import xapian"
-
_xapian$(PYTHON_SO): _xapian.la
$(LIBTOOL) --config > libtoolconfig.tmp
. ./libtoolconfig.tmp; cp $$objdir/_xapian$(PYTHON_SO) .
rm -f libtoolconfig.tmp
-CLEANFILES = _xapian$(PYTHON_SO) xapian.py xapian.pyc xapian.pyo testsuite.pyc
+CLEANFILES = _xapian$(PYTHON_SO) xapian.py testsuite.pyc
if MAINTAINER_MODE
# We need to explicitly set -outdir because on Windows, SWIG splits paths at
--- a/python/Makefile.in
+++ b/python/Makefile.in
@@ -292,14 +292,14 @@ pylibdir = @PYTHON_LIB@
# Install as _DATA rather than _SCRIPTS because we don't want to make these
# executable (they don't have a #! line).
-pylib_DATA = xapian.py xapian.pyc xapian.pyo
+pylib_DATA = xapian.py
pylib_LTLIBRARIES = _xapian.la
AM_CPPFLAGS = -I$(PYTHON_INC)
AM_CXXFLAGS = $(SWIG_CXXFLAGS) $(XAPIAN_CXXFLAGS)
_xapian_la_LDFLAGS = -avoid-version -module -shrext "$(PYTHON_SO)" $(NO_UNDEFINED)
_xapian_la_SOURCES = modern/xapian_wrap.cc
_xapian_la_LIBADD = $(XAPIAN_LIBS) $(PYTHON_LIBS)
-CLEANFILES = _xapian$(PYTHON_SO) xapian.py xapian.pyc xapian.pyo \
+CLEANFILES = _xapian$(PYTHON_SO) xapian.py \
testsuite.pyc $(am__append_2)
@MAINTAINER_MODE_FALSE@MAINTAINERCLEANFILES = $(BUILT_SOURCES)
all: $(BUILT_SOURCES)
@@ -819,14 +819,6 @@ uninstall-local:
xapian.py: modern/xapian.py
cp `test -f modern/xapian.py || echo '$(srcdir)/'`modern/xapian.py .
-# We "import _xapian" first so that if we fail to import the glue library
-# we don't generate a broken xapian.pyc or xapian.pyo.
-xapian.pyc: xapian.py _xapian$(PYTHON_SO)
- PYTHONPATH=. $(PYTHON) -c "import _xapian;import xapian"
-
-xapian.pyo: xapian.py _xapian$(PYTHON_SO)
- PYTHONPATH=. $(PYTHON) -O -c "import _xapian;import xapian"
-
_xapian$(PYTHON_SO): _xapian.la
$(LIBTOOL) --config > libtoolconfig.tmp
. ./libtoolconfig.tmp; cp $$objdir/_xapian$(PYTHON_SO) .

View File

@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=xapian-core
PKG_VERSION:=1.0.7
PKG_RELEASE:=3
PKG_VERSION:=1.2.8
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://oligarchy.co.uk/xapian/$(PKG_VERSION)
PKG_MD5SUM:=b4acff50028120852d4a8d943065f6d2
PKG_MD5SUM:=6c9f9e7ac43aa4e086283201329e98ee
PKG_FIXUP:=libtool
PKG_INSTALL:=1
@ -29,6 +29,9 @@ define Package/libxapian
DEPENDS:=+libstdcpp +zlib
endef
MAKE_FLAGS += \
SUBDIRS=.
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/share/aclocal
$(INSTALL_DATA) \

View File

@ -1,7 +1,6 @@
diff -urN xapian-core-1.0.7/backends/flint/flint_version.cc xapian-core-1.0.7.new/backends/flint/flint_version.cc
--- xapian-core-1.0.7/backends/flint/flint_version.cc 2008-07-16 06:42:34.000000000 +0200
+++ xapian-core-1.0.7.new/backends/flint/flint_version.cc 2010-03-29 09:59:58.000000000 +0200
@@ -19,6 +19,7 @@
--- a/backends/flint/flint_version.cc
+++ b/backends/flint/flint_version.cc
@@ -20,6 +20,7 @@
*/
#include <config.h>
@ -9,19 +8,8 @@ diff -urN xapian-core-1.0.7/backends/flint/flint_version.cc xapian-core-1.0.7.ne
#include "safeerrno.h"
diff -urN xapian-core-1.0.7/bin/quartzdump.cc xapian-core-1.0.7.new/bin/quartzdump.cc
--- xapian-core-1.0.7/bin/quartzdump.cc 2008-07-16 06:42:28.000000000 +0200
+++ xapian-core-1.0.7.new/bin/quartzdump.cc 2010-03-29 10:18:26.000000000 +0200
@@ -29,6 +29,7 @@
#include <vector>
#include <string>
#include <ctype.h>
+#include <stdio.h>
#include "autoptr.h"
#include "gnu_getopt.h"
--- xapian-core-1.0.7/bin/xapian-progsrv.cc 2008-07-16 06:42:28.000000000 +0200
+++ xapian-core-1.0.7.new/bin/xapian-progsrv.cc 2010-03-29 10:31:16.000000000 +0200
--- a/bin/xapian-progsrv.cc
+++ b/bin/xapian-progsrv.cc
@@ -19,6 +19,7 @@
*/
@ -30,19 +18,18 @@ diff -urN xapian-core-1.0.7/bin/quartzdump.cc xapian-core-1.0.7.new/bin/quartzdu
#include "remoteserver.h"
--- xapian-core-1.0.7/bin/xapian-tcpsrv.cc 2008-07-16 06:42:28.000000000 +0200
+++ xapian-core-1.0.7.new/bin/xapian-tcpsrv.cc 2010-03-29 10:41:56.000000000 +0200
--- a/bin/xapian-tcpsrv.cc
+++ b/bin/xapian-tcpsrv.cc
@@ -21,6 +21,7 @@
*/
#include <config.h>
+#include <stdio.h>
#include <stdlib.h>
#include <cstdlib>
diff -urN xapian-core-1.0.7/examples/delve.cc xapian-core-1.0.7.new/examples/delve.cc
--- xapian-core-1.0.7/examples/delve.cc 2008-07-16 06:42:35.000000000 +0200
+++ xapian-core-1.0.7.new/examples/delve.cc 2010-03-29 11:14:26.000000000 +0200
--- a/examples/delve.cc
+++ b/examples/delve.cc
@@ -21,6 +21,7 @@
*/
@ -51,8 +38,8 @@ diff -urN xapian-core-1.0.7/examples/delve.cc xapian-core-1.0.7.new/examples/del
#include <xapian.h>
--- xapian-core-1.0.7/examples/quest.cc 2008-07-16 06:42:35.000000000 +0200
+++ xapian-core-1.0.7.new/examples/quest.cc 2010-03-29 11:33:03.000000000 +0200
--- a/examples/quest.cc
+++ b/examples/quest.cc
@@ -19,6 +19,7 @@
*/

View File

@ -1,12 +0,0 @@
diff -urN xapian-core-1.0.7/common/serialise-double.cc xapian-core-1.0.7.new/common/serialise-double.cc
--- xapian-core-1.0.7/common/serialise-double.cc 2008-07-16 06:42:30.000000000 +0200
+++ xapian-core-1.0.7.new/common/serialise-double.cc 2010-03-29 10:07:02.000000000 +0200
@@ -56,7 +56,7 @@
# define MAX_MANTISSA_BYTES ((DBL_MANT_DIG + 1 + 1) / 2)
# define MAX_EXP ((DBL_MAX_EXP + 1) / 2)
# define MAX_MANTISSA (1 << ((DBL_MAX_EXP & 1) * 4))
-#elif
+#else
# error FLT_RADIX is a value not currently handled (not 2 or 16)
// # define MAX_MANTISSA_BYTES (sizeof(double) + 1)
#endif

View File

@ -1,25 +1,29 @@
Index: xapian-core-1.0.7/m4-macros/xapian.m4
===================================================================
--- xapian-core-1.0.7.orig/m4-macros/xapian.m4 2011-10-11 16:11:04.000000000 +0200
+++ xapian-core-1.0.7/m4-macros/xapian.m4 2011-10-11 16:12:00.000000000 +0200
@@ -47,14 +47,12 @@
--- a/m4-macros/xapian.m4
+++ b/m4-macros/xapian.m4
@@ -52,11 +52,11 @@
[$2])
else
AC_MSG_CHECKING([$XAPIAN_CONFIG works])
- dnl check for --ltlibs but not --libs as "xapian-config --libs" will
- dnl fail if xapian isn't installed...
+ dnl check for --libs but not --libs as "xapian-config --libs" will
dnl fail if xapian isn't installed...
dnl run with exec to avoid leaking output on "real" bourne shells
- if (exec >&5 2>&5 ; $XAPIAN_CONFIG --ltlibs --cxxflags; exit $?) then
+ if (exec >&5 2>&5 ; $XAPIAN_CONFIG --libs --cxxflags; exit $?) then
AC_MSG_RESULT(yes)
else
case $? in
@@ -70,7 +70,7 @@
AC_MSG_ERROR([\`$XAPIAN_CONFIG' not executable, aborting])
;;
esac
- AC_MSG_ERROR([\`$XAPIAN_CONFIG --ltlibs --cxxflags' doesn't work, aborting])
+ AC_MSG_ERROR([\`$XAPIAN_CONFIG --libs --cxxflags' doesn't work, aborting])
fi
dnl If LT_INIT, AC_PROG_LIBTOOL or the deprecated older version
@@ -64,11 +62,11 @@
@@ -80,11 +80,11 @@
XAPIAN_VERSION=`$XAPIAN_CONFIG --version|sed 's/.* //;s/_svn[[0-9]]*$//'`
XAPIAN_CXXFLAGS=`$XAPIAN_CONFIG --cxxflags`
AC_PROVIDE_IFELSE([LT_INIT],
@ -34,7 +38,7 @@ Index: xapian-core-1.0.7/m4-macros/xapian.m4
dnl Pass magic option so xapian-config knows we called it (so it
dnl can choose a more appropriate error message if asked to link
dnl with an uninstalled libxapian). Also pass ac_top_srcdir
@@ -76,11 +74,11 @@
@@ -92,11 +92,11 @@
dnl "configure.in" according to which is in use.
[XAPIAN_LIBS=`ac_top_srcdir="$ac_top_srcdir" $XAPIAN_CONFIG --from-xo-lib-xapian --libs`
define([LT_INIT], defn([LT_INIT])

View File

@ -1,22 +0,0 @@
--- xapian-core-1.0.7/Makefile.am 2008-07-16 06:42:35.000000000 +0200
+++ xapian-core-1.0.7.new/Makefile.am 2010-03-29 11:01:13.000000000 +0200
@@ -14,7 +14,7 @@
endif
# Order is relevant: when building, tests must be after ".".
-SUBDIRS = . docs tests
+SUBDIRS = .
noinst_HEADERS =
BUILT_SOURCES =
--- xapian-core-1.0.7/Makefile.in 2008-07-16 06:46:51.000000000 +0200
+++ xapian-core-1.0.7.new/Makefile.in 2010-03-29 11:01:24.000000000 +0200
@@ -847,7 +847,7 @@
$(am__append_1) $(am__append_25)
# Order is relevant: when building, tests must be after ".".
-SUBDIRS = . docs tests
+SUBDIRS = .
noinst_HEADERS = api/maptermlist.h api/editdistance.h $(am__append_9) \
$(am__append_12) backends/multi/multi_postlist.h \
backends/multi/multi_termlist.h $(am__append_15) \