[python]: fix sqlite extension (#12239)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@33902 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
173bbb31e3
commit
90f0fbef2f
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=python
|
||||
PKG_VERSION:=2.7.3
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=Python-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=http://www.python.org/ftp/python/$(PKG_VERSION)
|
||||
|
10
lang/python/patches/150-no-sqlite-rpath.patch
Normal file
10
lang/python/patches/150-no-sqlite-rpath.patch
Normal file
@ -0,0 +1,10 @@
|
||||
--- a/setup.py
|
||||
+++ b/setup.py
|
||||
@@ -1021,7 +1021,6 @@ class PyBuildExt(build_ext):
|
||||
include_dirs=["Modules/_sqlite",
|
||||
sqlite_incdir],
|
||||
library_dirs=sqlite_libdir,
|
||||
- runtime_library_dirs=sqlite_libdir,
|
||||
extra_link_args=sqlite_extra_link_args,
|
||||
libraries=["sqlite3",]))
|
||||
else:
|
Loading…
x
Reference in New Issue
Block a user