[package] update wifidog to 20090925 (#5902)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@17759 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
b1c9178391
commit
9180b6b150
@ -8,12 +8,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=wifidog
|
||||
PKG_VERSION:=1.1.5
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=20090925
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:= @SF/$(PKG_NAME)
|
||||
PKG_MD5SUM:=abe5f7123179a0f08c493ce59fb3cb31
|
||||
PKG_MD5SUM:=e3ecacba67a91b6ea3c1072ba6c5a0b4
|
||||
|
||||
PKG_FIXUP = libtool
|
||||
|
||||
@ -52,6 +52,7 @@ define Package/wifidog/install
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libhttpd.so* $(1)/usr/lib/
|
||||
$(INSTALL_DIR) $(1)/etc
|
||||
$(INSTALL_DATA) ./files/wifidog.conf $(1)/etc/
|
||||
$(INSTALL_DATA) $(PKG_BUILD_DIR)/wifidog-msg.html $(1)/etc/
|
||||
$(INSTALL_DIR) $(1)/etc/init.d
|
||||
$(INSTALL_BIN) ./files/$(PKG_NAME).init $(1)/etc/init.d/wifidog
|
||||
endef
|
||||
|
@ -1,6 +1,8 @@
|
||||
#!/bin/sh /etc/rc.common
|
||||
# Copyright (C) 2006 OpenWrt.org
|
||||
START=50
|
||||
START=65
|
||||
EXTRA_COMMANDS="status"
|
||||
EXTRA_HELP=" status Print the status of the service"
|
||||
|
||||
start() {
|
||||
/usr/bin/wifidog-init start
|
||||
@ -10,3 +12,6 @@ stop() {
|
||||
/usr/bin/wifidog-init stop
|
||||
}
|
||||
|
||||
status() {
|
||||
/usr/bin/wifidog-init status
|
||||
}
|
@ -1,11 +0,0 @@
|
||||
--- wifidog-1.1.5/src/firewall.c 2008-08-29 22:44:57.000000000 +0200
|
||||
+++ wifidog-1.1.5-fixed/src/firewall.c 2008-08-29 22:45:46.000000000 +0200
|
||||
@@ -135,7 +135,7 @@
|
||||
|
||||
/* Find ip, copy mac in reply */
|
||||
reply = NULL;
|
||||
- while (!feof(proc) && (fscanf(proc, " %15[0-9.] %*s %*s %17[A-F0-9:] %*s %*s", ip, mac) == 2)) {
|
||||
+ while (!feof(proc) && (fscanf(proc, " %15[0-9.] %*s %*s %17[A-Fa-f0-9:] %*s %*s", ip, mac) == 2)) {
|
||||
if (strcmp(ip, req_ip) == 0) {
|
||||
reply = safe_strdup(mac);
|
||||
break;
|
Loading…
x
Reference in New Issue
Block a user