php5-pecl-libevent: upgrade to 0.1.0
Signed-off-by: Michael Heimpold <mhei@heimpold.de> git-svn-id: svn://svn.openwrt.org/openwrt/packages@37380 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
e78f6f9e12
commit
925791d387
@ -1,5 +1,5 @@
|
|||||||
#
|
#
|
||||||
# Copyright (C) 2012 OpenWrt.org
|
# Copyright (C) 2012-2013 OpenWrt.org
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
@ -10,9 +10,9 @@ include $(TOPDIR)/rules.mk
|
|||||||
PECL_NAME:=libevent
|
PECL_NAME:=libevent
|
||||||
PECL_LONGNAME:=Libevent - event notification
|
PECL_LONGNAME:=Libevent - event notification
|
||||||
|
|
||||||
PKG_VERSION:=0.0.5
|
PKG_VERSION:=0.1.0
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
PKG_MD5SUM:=5539f4e1f44879d5a9afae7d75a96112
|
PKG_MD5SUM:=e091371a9e714098a4c04a6e3daeb56a
|
||||||
|
|
||||||
PKG_NAME:=php5-pecl-$(PECL_NAME)
|
PKG_NAME:=php5-pecl-$(PECL_NAME)
|
||||||
PKG_SOURCE:=$(PECL_NAME)-$(PKG_VERSION).tgz
|
PKG_SOURCE:=$(PECL_NAME)-$(PKG_VERSION).tgz
|
||||||
@ -27,5 +27,5 @@ include ../php5/pecl.mk
|
|||||||
|
|
||||||
CONFIGURE_ARGS+= --with-libevent=shared,"$(STAGING_DIR)/usr"
|
CONFIGURE_ARGS+= --with-libevent=shared,"$(STAGING_DIR)/usr"
|
||||||
|
|
||||||
$(eval $(call PECLPackage,$(PECL_NAME),$(PECL_LONGNAME),+libevent))
|
$(eval $(call PECLPackage,$(PECL_NAME),$(PECL_LONGNAME),+libevent2))
|
||||||
$(eval $(call BuildPackage,$(PKG_NAME)))
|
$(eval $(call BuildPackage,$(PKG_NAME)))
|
||||||
|
@ -1,20 +0,0 @@
|
|||||||
--- a/config.m4
|
|
||||||
+++ b/config.m4
|
|
||||||
@@ -5,7 +5,7 @@ PHP_ARG_WITH(libevent, for libevent supp
|
|
||||||
|
|
||||||
if test "$PHP_LIBEVENT" != "no"; then
|
|
||||||
SEARCH_PATH="/usr /usr/local"
|
|
||||||
- SEARCH_FOR="/include/event.h"
|
|
||||||
+ SEARCH_FOR="/include/libevent/event.h"
|
|
||||||
|
|
||||||
if test "$PHP_LIBEVENT" = "yes"; then
|
|
||||||
AC_MSG_CHECKING([for libevent headers in default path])
|
|
||||||
@@ -28,7 +28,7 @@ if test "$PHP_LIBEVENT" != "no"; then
|
|
||||||
AC_MSG_ERROR([Cannot find libevent headers])
|
|
||||||
fi
|
|
||||||
|
|
||||||
- PHP_ADD_INCLUDE($LIBEVENT_DIR/include)
|
|
||||||
+ PHP_ADD_INCLUDE($LIBEVENT_DIR/include/libevent)
|
|
||||||
|
|
||||||
LIBNAME=event
|
|
||||||
LIBSYMBOL=event_base_new
|
|
@ -1,13 +0,0 @@
|
|||||||
--- a/config.m4
|
|
||||||
+++ b/config.m4
|
|
||||||
@@ -33,9 +33,7 @@ if test "$PHP_LIBEVENT" != "no"; then
|
|
||||||
LIBNAME=event
|
|
||||||
LIBSYMBOL=event_base_new
|
|
||||||
|
|
||||||
- if test "x$PHP_LIBDIR" = "x"; then
|
|
||||||
- PHP_LIBDIR=lib
|
|
||||||
- fi
|
|
||||||
+ PHP_LIBDIR=lib/libevent
|
|
||||||
|
|
||||||
PHP_CHECK_LIBRARY($LIBNAME,$LIBSYMBOL,
|
|
||||||
[
|
|
Loading…
x
Reference in New Issue
Block a user