Move unmaintained elhttp to crowdcontrol closes #544
git-svn-id: svn://svn.openwrt.org/openwrt/packages@5002 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
3dc00ce2d0
commit
927e5493d5
46
net/crowdcontrol/Makefile
Normal file
46
net/crowdcontrol/Makefile
Normal file
@ -0,0 +1,46 @@
|
||||
#
|
||||
# Copyright (C) 2006 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
# $Id$
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=crowdcontrol
|
||||
PKG_VERSION:=0.4b
|
||||
PKG_RELEASE:=1
|
||||
PKG_MD5SUM:=a0991ae3d1f1a361558bed1a4aa66a9c
|
||||
|
||||
PKG_SOURCE_URL:=@openwrt/
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_CAT:=zcat
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/crowdcontrol
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
TITLE:=The extra-light http proxy server
|
||||
DESCRIPTION:=Crowd Control is an small, cross-platform HTTP proxy (a fork of the elhttp project)\\\
|
||||
designed for systems with little RAM, such as a home router. It can filter URLs using\\\
|
||||
SquidGuard blocklists, and has the unique ability to filter HTTPS domains as well.
|
||||
URL:=http://sourceforge.net/projects/crowdcontrol/
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
$(TARGET_CC) $(TARGET_CFLAGS) -o $(PKG_BUILD_DIR)/crowdcontrol $(PKG_BUILD_DIR)/crowdcontrol.c
|
||||
endef
|
||||
|
||||
define Package/crowdcontrol/install
|
||||
mkdir -p $(1)/usr/sbin
|
||||
mkdir -p $(1)/etc/crowdcontrol
|
||||
$(CP) $(PKG_BUILD_DIR)/crowdcontrol $(1)/usr/sbin
|
||||
$(CP) $(PKG_BUILD_DIR)/*-{domains,expressions,urls} $(1)/etc/crowdcontrol/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,crowdcontrol))
|
@ -1,49 +0,0 @@
|
||||
#
|
||||
# Copyright (C) 2006 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
# $Id$
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=elhttp
|
||||
PKG_VERSION:=0.22
|
||||
PKG_RELEASE:=1
|
||||
PKG_MD5SUM:=b52f68c47f709e9fc9429250eb8f954c
|
||||
|
||||
PKG_SOURCE_URL:=http://phadej.daug.net/files/ \
|
||||
http://www.cr0.net:8040/code/network/
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
|
||||
PKG_CAT:=zcat
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/elhttp
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
TITLE:=The extra-light http proxy server
|
||||
DESCRIPTION:=The extra-light http proxy server. Features: keep-alive\\\
|
||||
connections, http connect method, SSL/TLS support, ACLs\\\
|
||||
and client requests logging.\\\
|
||||
URL:=http://www.cr0.net:8040/code/network/
|
||||
endef
|
||||
|
||||
|
||||
define Build/Compile
|
||||
mkdir -p $(PKG_INSTALL_DIR)/usr/sbin
|
||||
$(MAKE) CC="$(TARGET_CC)" CROSS="$(TARGET_CROSS)" -C "$(PKG_BUILD_DIR)" \
|
||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||
all install
|
||||
endef
|
||||
|
||||
define Package/elhttp/install
|
||||
mkdir -p $(1)
|
||||
$(CP) $(PKG_INSTALL_DIR)/* $(1)/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,elhttp))
|
@ -1,21 +0,0 @@
|
||||
--- elhttp-0.22.orig/Makefile 2004-06-18 15:32:17.000000000 +0200
|
||||
+++ elhttp-0.22/Makefile 2006-02-13 23:11:35.000000000 +0100
|
||||
@@ -1,13 +1,7 @@
|
||||
-
|
||||
+all: linux
|
||||
linux:
|
||||
- gcc -O -W -Wall -o elhttp elhttp.c
|
||||
- strip elhttp
|
||||
-
|
||||
-sunos:
|
||||
- gcc -O -W -Wall -o elhttp elhttp.c -lsocket -lnsl
|
||||
- strip elhttp
|
||||
-
|
||||
-unix:
|
||||
- cc -O -o elhttp elhttp.c
|
||||
- strip elhttp
|
||||
+ $(CC) -O -W -Wall -o elhttp elhttp.c
|
||||
|
||||
+install:
|
||||
+ install -d -m0755 $(DESTDIR)/usr/sbin
|
||||
+ install -m0755 elhttp $(DESTDIR)/usr/sbin/
|
Loading…
x
Reference in New Issue
Block a user