ez-ipudate: fix broken endian detection on uClibc
git-svn-id: svn://svn.openwrt.org/openwrt/packages@34057 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
97c201d93e
commit
928acbe600
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||||||
|
|
||||||
PKG_NAME:=ez-ipupdate
|
PKG_NAME:=ez-ipupdate
|
||||||
PKG_VERSION:=3.0.11b8
|
PKG_VERSION:=3.0.11b8
|
||||||
PKG_RELEASE:=7
|
PKG_RELEASE:=8
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
|
PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
|
||||||
PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/e/ez-ipupdate \
|
PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/e/ez-ipupdate \
|
||||||
|
11
net/ez-ipupdate/patches/005-endian-detection.patch
Normal file
11
net/ez-ipupdate/patches/005-endian-detection.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- a/md5.c
|
||||||
|
+++ b/md5.c
|
||||||
|
@@ -35,7 +35,7 @@
|
||||||
|
|
||||||
|
#include "md5.h"
|
||||||
|
|
||||||
|
-#ifdef _LIBC
|
||||||
|
+#if defined(_LIBC) || defined(__UCLIBC__)
|
||||||
|
# include <endian.h>
|
||||||
|
# if __BYTE_ORDER == __BIG_ENDIAN
|
||||||
|
# define WORDS_BIGENDIAN 1
|
Loading…
x
Reference in New Issue
Block a user