[packages] libaio: update to v0.3.107, use "make install"

git-svn-id: svn://svn.openwrt.org/openwrt/packages@17870 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
nico 2009-10-05 11:42:29 +00:00
parent d8d322e0ad
commit 947261b0a2
3 changed files with 34 additions and 39 deletions

View File

@ -1,5 +1,5 @@
# #
# Copyright (C) 2007 OpenWrt.org # Copyright (C) 2007-2009 OpenWrt.org
# #
# This is free software, licensed under the GNU General Public License v2. # This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information. # See /LICENSE for more information.
@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk include $(TOPDIR)/rules.mk
PKG_NAME:=libaio PKG_NAME:=libaio
PKG_VERSION:=0.3.106 PKG_VERSION:=0.3.107
PKG_RELEASE:=2 PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/liba/libaio/ PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/liba/libaio/
PKG_MD5SUM:=9480e31cce6506091080d59211089bd4 PKG_MD5SUM:=db32c19c61ca937bcb1ba48da9180682
include $(INCLUDE_DIR)/package.mk include $(INCLUDE_DIR)/package.mk
@ -29,7 +29,6 @@ define Build/Configure
endef endef
LIBAIO_CFLAGS:=-nostdlib -nostartfiles -I. $(TARGET_CFLAGS) $(TARGET_CPPFLAGS) LIBAIO_CFLAGS:=-nostdlib -nostartfiles -I. $(TARGET_CFLAGS) $(TARGET_CPPFLAGS)
LIBAIO_SOVER:=1.0.1
TARGET_CFLAGS += $(FPIC) TARGET_CFLAGS += $(FPIC)
@ -41,22 +40,21 @@ define Build/Compile
LD="$(TARGET_CROSS)ld" \ LD="$(TARGET_CROSS)ld" \
CFLAGS="$(LIBAIO_CFLAGS)" \ CFLAGS="$(LIBAIO_CFLAGS)" \
all all
$(MAKE) -C $(PKG_BUILD_DIR) \
prefix="$(PKG_INSTALL_DIR)/usr" \
install
endef endef
define Build/InstallDev define Build/InstallDev
mkdir -p $(1)/usr/include $(INSTALL_DIR) $(1)/usr/include
$(CP) $(PKG_BUILD_DIR)/src/libaio.h $(1)/usr/include/ $(CP) $(PKG_INSTALL_DIR)/usr/include/libaio.h $(1)/usr/include/
mkdir -p $(1)/usr/lib $(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_BUILD_DIR)/src/libaio.{a,so*} $(1)/usr/lib/ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libaio.{a,so*} $(1)/usr/lib/
ln -sf libaio.so.$(LIBAIO_SOVER) $(1)/usr/lib/libaio.so
ln -sf libaio.so.$(LIBAIO_SOVER) $(1)/usr/lib/libaio.so.1
endef endef
define Package/libaio/install define Package/libaio/install
$(INSTALL_DIR) $(1)/usr/lib $(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_BUILD_DIR)/src/libaio.so.* $(1)/usr/lib/ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libaio.so.* $(1)/usr/lib/
ln -sf libaio.so.$(LIBAIO_SOVER) $(1)/usr/lib/libaio.so
ln -sf libaio.so.$(LIBAIO_SOVER) $(1)/usr/lib/libaio.so.1
endef endef
$(eval $(call BuildPackage,libaio)) $(eval $(call BuildPackage,libaio))

View File

@ -1,5 +1,5 @@
--- libaio-0.3.106.orig/src/syscall-m68k.h --- /dev/null
+++ libaio-0.3.106/src/syscall-m68k.h +++ b/src/syscall-m68k.h
@@ -0,0 +1,78 @@ @@ -0,0 +1,78 @@
+#define __NR_io_setup 241 +#define __NR_io_setup 241
+#define __NR_io_destroy 242 +#define __NR_io_destroy 242
@ -79,8 +79,8 @@
+return (type) __res; \ +return (type) __res; \
+} +}
+ +
--- libaio-0.3.106.orig/src/syscall-sparc.h --- /dev/null
+++ libaio-0.3.106/src/syscall-sparc.h +++ b/src/syscall-sparc.h
@@ -0,0 +1,130 @@ @@ -0,0 +1,130 @@
+/* $Id: unistd.h,v 1.74 2002/02/08 03:57:18 davem Exp $ */ +/* $Id: unistd.h,v 1.74 2002/02/08 03:57:18 davem Exp $ */
+ +
@ -212,8 +212,8 @@
+return -1; \ +return -1; \
+} +}
+ +
--- libaio-0.3.106.orig/src/syscall.h --- a/src/syscall.h
+++ libaio-0.3.106/src/syscall.h +++ b/src/syscall.h
@@ -22,6 +22,16 @@ @@ -22,6 +22,16 @@
#include "syscall-s390.h" #include "syscall-s390.h"
#elif defined(__alpha__) #elif defined(__alpha__)
@ -231,8 +231,8 @@
#else #else
#error "add syscall-arch.h" #error "add syscall-arch.h"
#endif #endif
--- libaio-0.3.106.orig/src/syscall-mips.h --- /dev/null
+++ libaio-0.3.106/src/syscall-mips.h +++ b/src/syscall-mips.h
@@ -0,0 +1,223 @@ @@ -0,0 +1,223 @@
+/* +/*
+ * This file is subject to the terms and conditions of the GNU General Public + * This file is subject to the terms and conditions of the GNU General Public
@ -457,9 +457,9 @@
+ +
+#endif /* (_MIPS_SIM == _MIPS_SIM_NABI32) || (_MIPS_SIM == _MIPS_SIM_ABI64) */ +#endif /* (_MIPS_SIM == _MIPS_SIM_NABI32) || (_MIPS_SIM == _MIPS_SIM_ABI64) */
+ +
--- libaio-0.3.106.orig/src/libaio.h --- a/src/libaio.h
+++ libaio-0.3.106/src/libaio.h +++ b/src/libaio.h
@@ -72,6 +72,40 @@ @@ -73,6 +73,40 @@ typedef enum io_iocb_cmd {
#define PADDED(x, y) unsigned y; x #define PADDED(x, y) unsigned y; x
#define PADDEDptr(x, y) unsigned y; x #define PADDEDptr(x, y) unsigned y; x
#define PADDEDul(x, y) unsigned y; unsigned long x #define PADDEDul(x, y) unsigned y; unsigned long x
@ -500,8 +500,8 @@
#else #else
#error endian? #error endian?
#endif #endif
--- libaio-0.3.106.orig/src/syscall-parisc.h --- /dev/null
+++ libaio-0.3.106/src/syscall-parisc.h +++ b/src/syscall-parisc.h
@@ -0,0 +1,146 @@ @@ -0,0 +1,146 @@
+/* +/*
+ * Linux system call numbers. + * Linux system call numbers.
@ -649,8 +649,8 @@
+ return K_INLINE_SYSCALL(sname, 5, arg1, arg2, arg3, arg4, arg5); \ + return K_INLINE_SYSCALL(sname, 5, arg1, arg2, arg3, arg4, arg5); \
+} +}
+ +
--- libaio-0.3.106.orig/src/syscall-arm.h --- /dev/null
+++ libaio-0.3.106/src/syscall-arm.h +++ b/src/syscall-arm.h
@@ -0,0 +1,116 @@ @@ -0,0 +1,116 @@
+/* +/*
+ * linux/include/asm-arm/unistd.h + * linux/include/asm-arm/unistd.h

View File

@ -1,7 +1,6 @@
diff -Nur libaio-0.3.106/src/libaio.h libaio-0.3.106-avr32/src/libaio.h --- a/src/libaio.h
--- libaio-0.3.106/src/libaio.h 2007-11-27 11:07:20.000000000 +0100 +++ b/src/libaio.h
+++ libaio-0.3.106-avr32/src/libaio.h 2007-06-21 15:26:26.000000000 +0200 @@ -107,6 +107,10 @@ typedef enum io_iocb_cmd {
@@ -106,6 +106,10 @@
# else # else
# error "neither mipseb nor mipsel?" # error "neither mipseb nor mipsel?"
# endif # endif
@ -12,9 +11,8 @@ diff -Nur libaio-0.3.106/src/libaio.h libaio-0.3.106-avr32/src/libaio.h
#else #else
#error endian? #error endian?
#endif #endif
diff -Nur libaio-0.3.106/src/syscall-avr32.h libaio-0.3.106-avr32/src/syscall-avr32.h --- /dev/null
--- libaio-0.3.106/src/syscall-avr32.h 1970-01-01 01:00:00.000000000 +0100 +++ b/src/syscall-avr32.h
+++ libaio-0.3.106-avr32/src/syscall-avr32.h 2007-06-21 15:26:26.000000000 +0200
@@ -0,0 +1,91 @@ @@ -0,0 +1,91 @@
+/* +/*
+ * Copyright (C) 2007 Atmel Corporation + * Copyright (C) 2007 Atmel Corporation
@ -107,9 +105,8 @@ diff -Nur libaio-0.3.106/src/syscall-avr32.h libaio-0.3.106-avr32/src/syscall-av
+ : "memory"); \ + : "memory"); \
+ return (type) __res_r12; \ + return (type) __res_r12; \
+} +}
diff -Nur libaio-0.3.106/src/syscall.h libaio-0.3.106-avr32/src/syscall.h --- a/src/syscall.h
--- libaio-0.3.106/src/syscall.h 2007-11-27 11:07:20.000000000 +0100 +++ b/src/syscall.h
+++ libaio-0.3.106-avr32/src/syscall.h 2007-06-21 15:26:26.000000000 +0200
@@ -32,6 +32,8 @@ @@ -32,6 +32,8 @@
#include "syscall-parisc.h" #include "syscall-parisc.h"
#elif defined(__mips__) #elif defined(__mips__)