fix libnet-1.0.x build on osx
git-svn-id: svn://svn.openwrt.org/openwrt/packages@6798 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
399dc08981
commit
94b2dc4dbb
@ -35,6 +35,16 @@ ifeq ($(CONFIG_BIG_ENDIAN),y)
|
|||||||
ENDIANESS:=big
|
ENDIANESS:=big
|
||||||
endif
|
endif
|
||||||
|
|
||||||
|
CONFIGURE_ARGS += \
|
||||||
|
--enable-shared \
|
||||||
|
--enable-static \
|
||||||
|
--with-pf_packet=yes
|
||||||
|
|
||||||
|
CONFIGURE_VARS += \
|
||||||
|
ac_cv_libnet_endianess=$(ENDIANESS) \
|
||||||
|
ac_libnet_have_pf_packet=yes \
|
||||||
|
LL_INT_TYPE=sockpacket
|
||||||
|
|
||||||
define Build/Configure
|
define Build/Configure
|
||||||
(cd $(PKG_BUILD_DIR); touch \
|
(cd $(PKG_BUILD_DIR); touch \
|
||||||
configure.in \
|
configure.in \
|
||||||
@ -43,14 +53,7 @@ define Build/Configure
|
|||||||
Makefile.in \
|
Makefile.in \
|
||||||
configure \
|
configure \
|
||||||
);
|
);
|
||||||
$(call Build/Configure/Default, \
|
$(call Build/Configure/Default)
|
||||||
--enable-shared \
|
|
||||||
--enable-static \
|
|
||||||
--with-pf_packet=yes \
|
|
||||||
, \
|
|
||||||
ac_cv_libnet_endianess=$(ENDIANESS) \
|
|
||||||
ac_libnet_have_pf_packet=yes \
|
|
||||||
)
|
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Build/Compile
|
define Build/Compile
|
||||||
|
28
libs/libnet-1.0.x/patches/150-portability.patch
Normal file
28
libs/libnet-1.0.x/patches/150-portability.patch
Normal file
@ -0,0 +1,28 @@
|
|||||||
|
diff -ur libnet.old/configure libnet.dev/configure
|
||||||
|
--- libnet.old/configure 2007-04-01 17:36:55.000000000 +0200
|
||||||
|
+++ libnet.dev/configure 2007-04-01 17:40:06.000000000 +0200
|
||||||
|
@@ -8613,7 +8613,9 @@
|
||||||
|
echo "$as_me:$LINENO: checking low-level packet interface type" >&5
|
||||||
|
echo $ECHO_N "checking low-level packet interface type... $ECHO_C" >&6
|
||||||
|
|
||||||
|
-if test -r /dev/bpf0 ; then
|
||||||
|
+if [ -n "$LL_INT_TYPE" ]; then
|
||||||
|
+ echo "$as_me:$LINENO: result: found $LL_INT_TYPE (cached)" >&5
|
||||||
|
+elif test -r /dev/bpf0 ; then
|
||||||
|
LL_INT_TYPE=bpf
|
||||||
|
echo "$as_me:$LINENO: result: found bpf" >&5
|
||||||
|
echo "${ECHO_T}found bpf" >&6
|
||||||
|
diff -ur libnet.old/configure.in libnet.dev/configure.in
|
||||||
|
--- libnet.old/configure.in 2007-04-01 17:36:55.000000000 +0200
|
||||||
|
+++ libnet.dev/configure.in 2007-04-01 17:41:08.000000000 +0200
|
||||||
|
@@ -97,7 +97,9 @@
|
||||||
|
dnl
|
||||||
|
AC_MSG_CHECKING(low-level packet interface type)
|
||||||
|
|
||||||
|
-if test -r /dev/bpf0 ; then
|
||||||
|
+if [ -n "$LL_INT_TYPE" ]; then
|
||||||
|
+ AC_MSG_RESULT(found $LL_INT_TYPE (cached))
|
||||||
|
+elif test -r /dev/bpf0 ; then
|
||||||
|
LL_INT_TYPE=bpf
|
||||||
|
AC_MSG_RESULT(found bpf)
|
||||||
|
elif test -r /usr/include/net/pfilt.h ; then
|
Loading…
x
Reference in New Issue
Block a user