[packages] bash: update to 4.2
git-svn-id: svn://svn.openwrt.org/openwrt/packages@27442 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
833246c6aa
commit
9565ff42b7
@ -8,12 +8,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=bash
|
||||
PKG_VERSION:=3.2
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=4.2
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@GNU/bash
|
||||
PKG_MD5SUM:=00bfa16d58e034e3c2aa27f390390d30
|
||||
PKG_MD5SUM:=3fb927c7c33022f1c327f14a81c0d4b0
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
|
17
utils/bash/patches/001-compile-fix.patch
Normal file
17
utils/bash/patches/001-compile-fix.patch
Normal file
@ -0,0 +1,17 @@
|
||||
Index: bash-4.2/execute_cmd.c
|
||||
===================================================================
|
||||
--- bash-4.2.orig/execute_cmd.c 2011-07-04 11:16:23.000000000 +0200
|
||||
+++ bash-4.2/execute_cmd.c 2011-07-04 11:17:33.000000000 +0200
|
||||
@@ -2202,7 +2202,11 @@
|
||||
/* If the `lastpipe' option is set with shopt, and job control is not
|
||||
enabled, execute the last element of non-async pipelines in the
|
||||
current shell environment. */
|
||||
- if (lastpipe_opt && job_control == 0 && asynchronous == 0 && pipe_out == NO_PIPE && prev > 0)
|
||||
+ if (lastpipe_opt &&
|
||||
+#if defined(JOB_CONTROL)
|
||||
+ job_control == 0 &&
|
||||
+#endif
|
||||
+ asynchronous == 0 && pipe_out == NO_PIPE && prev > 0)
|
||||
{
|
||||
lstdin = move_to_high_fd (0, 0, 255);
|
||||
if (lstdin > 0)
|
@ -1,20 +0,0 @@
|
||||
--- bash-3.2/support/config.sub.orig 2008-05-15 22:22:52.000000000 -0500
|
||||
+++ bash-3.2/support/config.sub 2008-05-15 22:23:23.000000000 -0500
|
||||
@@ -228,7 +228,7 @@
|
||||
| a29k \
|
||||
| alpha | alphaev[4-8] | alphaev56 | alphaev6[78] | alphapca5[67] \
|
||||
| alpha64 | alpha64ev[4-8] | alpha64ev56 | alpha64ev6[78] | alpha64pca5[67] \
|
||||
- | arc | arm | arm[bl]e | arme[lb] | armv[2345] | armv[345][lb] | avr \
|
||||
+ | arc | arm | arm[bl]e | arme[lb] | armv[2345] | armv[345][lb] | avr | avr32 \
|
||||
| clipper \
|
||||
| d10v | d30v | dlx | dsp16xx \
|
||||
| fr30 | frv \
|
||||
@@ -293,7 +293,7 @@
|
||||
| alphapca5[67]-* | alpha64pca5[67]-* | arc-* \
|
||||
| amd64-* \
|
||||
| arm-* | armbe-* | armle-* | armeb-* | armv*-* \
|
||||
- | avr-* \
|
||||
+ | avr-* | avr32-* \
|
||||
| bs2000-* \
|
||||
| c[123]* | c30-* | [cjt]90-* | c4x-* | c54x-* \
|
||||
| clipper-* | cydra-* \
|
Loading…
x
Reference in New Issue
Block a user