rblibtorrent, deluge: broken for ages, moved to abandoned github feed
Signed-off-by: Nicolas Thill <nico@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/packages@44476 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
85507f70dd
commit
978b0af2dd
@ -1,77 +0,0 @@
|
||||
#
|
||||
# Copyright (C) 2007 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
# $Id: Makefile 9173 2007-10-07 03:20:26Z blogic $
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=rblibtorrent
|
||||
PKG_VERSION:=0.14.7
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=libtorrent-rasterbar-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@SF/libtorrent
|
||||
PKG_MD5SUM:=6959f719245d82758235fd73d93373b2
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/libtorrent-rasterbar-$(PKG_VERSION)
|
||||
PKG_BUILD_DEPENDS:=libtool
|
||||
BOOSTPOSTFIX=mt
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/rblibtorrent
|
||||
SECTION:=libs
|
||||
CATEGORY:=Libraries
|
||||
TITLE:=Rasterbar BitTorrent library
|
||||
URL:=http://www.rasterbar.com/products/libtorrent/
|
||||
DEPENDS:=+boost +boost-python +boost-filesystem +boost-regex +boost-thread +boost-program_options +boost-system +libopenssl @BROKEN
|
||||
endef
|
||||
|
||||
define Package/rblibtorrent/description
|
||||
Rasterbar libtorrent is a C++ library that aims to be a good alternative to
|
||||
all the other bittorrent implementations around. It is a library and not a
|
||||
full featured client, although it comes with a working example client.
|
||||
endef
|
||||
|
||||
CONFIGURE_ARGS+= \
|
||||
--enable-shared \
|
||||
--disable-debug \
|
||||
--enable-python-binding \
|
||||
--with-ssl=$(STAGING_DIR)/usr \
|
||||
--with-boost=$(STAGING_DIR)/usr/include \
|
||||
--with-boost-libdir=$(STAGING_DIR)/usr/lib \
|
||||
--with-zlib=detect \
|
||||
--with-boost-system=boost_system-$(BOOSTPOSTFIX) \
|
||||
--with-boost-filesystem=boost_filesystem-$(BOOSTPOSTFIX) \
|
||||
--with-boost-thread=boost_thread-$(BOOSTPOSTFIX) \
|
||||
--with-boost-regex=boost_regex-$(BOOSTPOSTFIX) \
|
||||
--with-boost-python=boost_python-$(BOOSTPOSTFIX) \
|
||||
--with-boost-program_options=boost_program_options-$(BOOSTPOSTFIX)
|
||||
|
||||
CONFIGURE_VARS+=CC="$(TARGET_CXX)"
|
||||
|
||||
EXTRA_LDFLAGS+=-lz -lpthread
|
||||
|
||||
define Build/Compile
|
||||
$(call Build/Compile/Default)
|
||||
$(call Build/Install/Default)
|
||||
endef
|
||||
|
||||
define Build/InstallDev
|
||||
mkdir -p $(1)/usr/include
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/libtorrent $(1)/usr/include/
|
||||
mkdir -p $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so* $(1)/usr/lib/
|
||||
mkdir -p $(1)/usr/lib/pkgconfig
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libtorrent-rasterbar.pc $(1)/usr/lib/pkgconfig/
|
||||
endef
|
||||
|
||||
define Package/rblibtorrent/install
|
||||
$(INSTALL_DIR) $(1)/usr/lib $(1)/usr/lib/python2.6/site-packages/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so* $(1)/usr/lib/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/python2.6/site-packages/*.so* $(1)/usr/lib/python2.6/site-packages/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,rblibtorrent))
|
@ -1,11 +0,0 @@
|
||||
--- libtorrent-rasterbar-0.14.7/bindings/python/Makefile.in 2009-11-18 09:25:39.000000000 +0100
|
||||
+++ libtorrent-rasterbar-0.14.7/bindings/python/Makefile.in 2010-02-26 13:27:58.000000000 +0100
|
||||
@@ -408,7 +408,7 @@
|
||||
|
||||
|
||||
@ENABLE_PYTHON_BINDING_TRUE@all-local:
|
||||
-@ENABLE_PYTHON_BINDING_TRUE@ $(PYTHON) setup.py build
|
||||
+@ENABLE_PYTHON_BINDING_TRUE@ CXX="$(CXX) -pthread -shared" $(PYTHON) setup.py build
|
||||
|
||||
@ENABLE_PYTHON_BINDING_TRUE@install-exec-local:
|
||||
@ENABLE_PYTHON_BINDING_TRUE@ $(PYTHON) setup.py install @PYTHON_INSTALL_PARAMS@
|
@ -1,111 +0,0 @@
|
||||
#
|
||||
# Copyright (C) 2008-2011 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=deluge
|
||||
PKG_VERSION:=1.2.0
|
||||
PKG_RELEASE:=3
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://download.deluge-torrent.org/source/
|
||||
PKG_MD5SUM:=cec6b48f0abd79ea2cff3815a1124192
|
||||
|
||||
PKG_BUILD_DEPENDS:=distribute/host
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
$(call include_mk, python-package.mk)
|
||||
|
||||
define Package/deluge/Default
|
||||
SUBMENU:=BitTorrent
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
TITLE:=A lightweight BitTorrent client
|
||||
URL:=http://deluge-torrent.org/
|
||||
endef
|
||||
|
||||
define Package/deluge
|
||||
$(call Package/deluge/Default)
|
||||
TITLE+= (console UI & daemon)
|
||||
DEPENDS+=+python +rblibtorrent +python2-chardet +pyxdg +twisted +twisted-web +pyopenssl
|
||||
endef
|
||||
|
||||
define Package/deluge-ui-gtk
|
||||
$(call Package/deluge/Default)
|
||||
TITLE+= (GTK+ UI)
|
||||
DEPENDS+=deluge +python-gtk
|
||||
endef
|
||||
|
||||
define Package/deluge-ui-web
|
||||
$(call Package/deluge/Default)
|
||||
TITLE+= (Web UI)
|
||||
DEPENDS+=deluge +mako
|
||||
endef
|
||||
|
||||
define Package/deluge/description
|
||||
BitTorrent client with a client/server model.
|
||||
endef
|
||||
|
||||
define Package/deluge/conffiles
|
||||
/etc/config/deluge
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
$(call Build/Compile/PyMod,,install --prefix=/usr --root=$(PKG_INSTALL_DIR))
|
||||
|
||||
$(SED) 's,#!$(STAGING_DIR)/host/bin/$(PYTHON),#!/usr/bin/$(PYTHON),' $(PKG_INSTALL_DIR)/usr/bin/*
|
||||
endef
|
||||
|
||||
define Package/deluge/install
|
||||
$(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)
|
||||
$(CP) \
|
||||
$(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/* \
|
||||
$(1)$(PYTHON_PKG_DIR)/
|
||||
rm -rf $(1)$(PYTHON_PKG_DIR)/deluge/ui/gtkui
|
||||
rm -rf $(1)$(PYTHON_PKG_DIR)/deluge/ui/web
|
||||
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(CP) \
|
||||
$(PKG_INSTALL_DIR)/usr/bin/* \
|
||||
$(1)/usr/bin/
|
||||
rm -rf $(1)/usr/bin/deluge-gtk
|
||||
rm -rf $(1)/usr/bin/deluge-web
|
||||
|
||||
$(INSTALL_DIR) $(1)/etc/config
|
||||
$(INSTALL_CONF) ./files/deluge.config $(1)/etc/config/deluge
|
||||
|
||||
$(INSTALL_DIR) $(1)/etc/init.d
|
||||
$(INSTALL_BIN) ./files/deluge.init $(1)/etc/init.d/deluge
|
||||
endef
|
||||
|
||||
define Package/deluge-ui-gtk/install
|
||||
$(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)/deluge/ui
|
||||
$(CP) \
|
||||
$(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/deluge/ui/gtkui \
|
||||
$(1)$(PYTHON_PKG_DIR)/deluge/ui/
|
||||
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(CP) \
|
||||
$(PKG_INSTALL_DIR)/usr/bin/deluge-gtk \
|
||||
$(1)/usr/bin/
|
||||
endef
|
||||
|
||||
define Package/deluge-ui-web/install
|
||||
$(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)/deluge/ui
|
||||
$(CP) \
|
||||
$(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/deluge/ui/web \
|
||||
$(1)$(PYTHON_PKG_DIR)/deluge/ui/
|
||||
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(CP) \
|
||||
$(PKG_INSTALL_DIR)/usr/bin/deluge-web \
|
||||
$(1)/usr/bin/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,deluge))
|
||||
$(eval $(call BuildPackage,deluge-ui-gtk))
|
||||
$(eval $(call BuildPackage,deluge-ui-web))
|
@ -1,6 +0,0 @@
|
||||
config global deluged
|
||||
option 'user' 'deluge'
|
||||
option 'group' 'deluge'
|
||||
option 'home' ''
|
||||
option 'options' ''
|
||||
option 'enabled' 1
|
@ -1,86 +0,0 @@
|
||||
#!/bin/sh /etc/rc.common
|
||||
# Copyright (C) 2010-2011 OpenWrt.org
|
||||
# Copyright (C) 2010 Alexander Sulfrian
|
||||
|
||||
START=50
|
||||
STOP=50
|
||||
|
||||
SERVICE_DAEMONIZE=1
|
||||
SERVICE_WRITE_PID=1
|
||||
SERVICE_PID_FILE="/var/run/deluged.pid"
|
||||
|
||||
error() {
|
||||
echo "${initscript}:" "$@" 1>&2
|
||||
}
|
||||
|
||||
section_enabled() {
|
||||
config_get_bool enabled "$1" 'enabled' 0
|
||||
[ $enabled -gt 0 ]
|
||||
}
|
||||
|
||||
start_instance() {
|
||||
local s="$1"
|
||||
|
||||
section_enabled "$s" || return 1
|
||||
|
||||
config_get uid "$s" 'user'
|
||||
[ -n "$uid" ] || {
|
||||
error "user is not set"
|
||||
return 1
|
||||
}
|
||||
user_exists $uid || {
|
||||
error "user '$uid' dos not exist"
|
||||
return 1
|
||||
}
|
||||
|
||||
config_get gid "$s" 'group'
|
||||
[ -n "$gid" ] || {
|
||||
error "group is not set"
|
||||
return 1
|
||||
}
|
||||
group_exists $gid || {
|
||||
error "group '$gid' dos not exist"
|
||||
return 1
|
||||
}
|
||||
|
||||
config_get home "$s" 'home'
|
||||
[ -n "$home" ] || {
|
||||
home=$(grep "^${user}:" /etc/passwd | cut -d ':' -f 6)
|
||||
fi
|
||||
[ -d "$home" ] || {
|
||||
error "home directory '$home' for user '$uid' dos not exist"
|
||||
return 1
|
||||
}
|
||||
|
||||
config_get options "$s" 'options'
|
||||
|
||||
HOME="$home" \
|
||||
SERVICE_UID="$uid" \
|
||||
SERVICE_GID="$gid" \
|
||||
service_start /usr/bin/python2.6 /usr/bin/deluged --do-not-daemonize $options
|
||||
}
|
||||
|
||||
stop_instance() {
|
||||
local s="$1"
|
||||
|
||||
section_enabled "$s" || return 1
|
||||
|
||||
config_get uid "$s" 'user'
|
||||
config_get gid "$s" 'group'
|
||||
|
||||
SERVICE_UID="$uid" \
|
||||
SERVICE_GID="$gid" \
|
||||
service_stop /usr/bin/python2.6
|
||||
}
|
||||
|
||||
start()
|
||||
{
|
||||
config_load 'deluged'
|
||||
config_foreach start_instance 'deluged'
|
||||
}
|
||||
|
||||
stop()
|
||||
{
|
||||
config_load 'deluged'
|
||||
config_foreach stop_instance 'deluged'
|
||||
}
|
Loading…
x
Reference in New Issue
Block a user