[packages] libsrtp:

- move srtp to libsrtp, rename package from srtp to libsrtp
  - use CONIGURE_ARGS instead of overriding Build/Configure
  - use PKG_INSTALL instead of overriding Build/Compile
  - refresh patches

git-svn-id: svn://svn.openwrt.org/openwrt/packages@29808 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
jow 2012-01-19 15:55:18 +00:00
parent 79c9e8681d
commit 979ab4aaf4
6 changed files with 23 additions and 36 deletions

View File

@ -1,5 +1,5 @@
#
# Copyright (C) 2011 OpenWrt.org
# Copyright (C) 2011-2012 OpenWrt.org
# Copyright (C) 2011 Victor Seva <linuxmaniac@torreviejawireless.org>
#
# This is free software, licensed under the GNU General Public License v2.
@ -7,18 +7,21 @@
#
include $(TOPDIR)/rules.mk
PKG_NAME:=srtp
PKG_NAME:=libsrtp
PKG_VERSION:=1.4.4
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
PKG_SOURCE:=srtp-$(PKG_VERSION).tgz
PKG_SOURCE_URL:=@SF/srtp
PKG_MD5SUM:=9b449edb011c934ca97009e7e0566d22
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
PKG_BUILD_DIR:=$(BUILD_DIR)/srtp
PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
TARGET_CFLAGS += $(FPIC)
CONFIGURE_ARGS += --disable-stdout --enable-syslog
define Package/libsrtp
SECTION:=libs
@ -34,18 +37,6 @@ define Package/libsrtp/description
It is available under a BSD-style license.
endef
define Build/Configure
$(call Build/Configure/Default, \
--disable-stdout \
--enable-syslog \
)
endef
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
DESTDIR="$(PKG_INSTALL_DIR)" all install
endef
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include
$(CP) $(PKG_INSTALL_DIR)/usr/include/srtp $(1)/usr/include/

View File

@ -5,7 +5,7 @@ Bug-Debian: http://bugs.debian.org/439976
Last-Update: 2010-02-28
--- a/test/srtp_driver.c
+++ b/test/srtp_driver.c
@@ -338,7 +338,7 @@
@@ -314,7 +314,7 @@ main (int argc, char *argv[]) {
if (do_codec_timing) {
srtp_policy_t policy;
int ignore;
@ -14,8 +14,8 @@ Last-Update: 2010-02-28
crypto_policy_set_rtp_default(&policy.rtp);
crypto_policy_set_rtcp_default(&policy.rtcp);
@@ -350,33 +350,33 @@
policy.allow_repeat_tx = 0;
@@ -323,33 +323,33 @@ main (int argc, char *argv[]) {
policy.key = test_key;
policy.next = NULL;
- printf("mips estimate: %e\n", mips);

View File

@ -6,15 +6,15 @@ Bug-Debian: http://bugs.debian.org/470505
Last-Update: 2011-05-30
--- a/test/srtp_driver.c
+++ b/test/srtp_driver.c
@@ -1195,7 +1195,6 @@
@@ -1129,7 +1129,6 @@ mips_estimate(int num_trials, int *ignor
* These packets were made with the default SRTP policy.
*/
-
err_status_t
srtp_validate() {
uint8_t srtp_plaintext_ref[28] = {
@@ -1204,14 +1203,14 @@
unsigned char test_key[30] = {
@@ -1144,14 +1143,14 @@ srtp_validate() {
0xab, 0xab, 0xab, 0xab, 0xab, 0xab, 0xab, 0xab,
0xab, 0xab, 0xab, 0xab
};

View File

@ -3,7 +3,7 @@ Author: Jonas Smedegaard <dr@jones.dk>
Last-Update: 2010-02-28
--- a/doc/Makefile.in
+++ b/doc/Makefile.in
@@ -25,6 +25,7 @@
@@ -25,6 +25,7 @@ libsrtpdoc:
echo "*** Sorry, can't build doc outside source dir"; exit 1; \
fi
sed 's/LIBSRTPVERSION/$(version)/' header.template > header.tex
@ -11,7 +11,7 @@ Last-Update: 2010-02-28
doxygen
sed 's/\subsection/\section/' latex/index.tex > latex/index.tmp
mv latex/index.tmp latex/index.tex
@@ -38,7 +39,7 @@
@@ -38,7 +39,7 @@ cryptodoc: clean
cp latex/refman.pdf crypto.pdf
clean:
@ -81,7 +81,7 @@ Last-Update: 2010-02-28
\begin{titlepage}
\vspace*{4cm}
%\begin{center}
@@ -107,9 +121,6 @@
@@ -107,9 +121,6 @@ This reference material in this documena
\clearemptydoublepage
\pagenumbering{roman}
\tableofcontents

View File

@ -13,7 +13,7 @@ Last-Update: 2010-03-19
runtest: build_table_apps test
@echo "running libsrtp test applications..."
@@ -67,7 +67,7 @@
@@ -67,7 +67,7 @@ libdir = @libdir@
# implicit rules for object files and test apps
%.o: %.c
@ -22,7 +22,7 @@ Last-Update: 2010-03-19
%$(EXE): %.c
$(COMPILE) $(LDFLAGS) $< -o $@ $(SRTPLIB) $(LIBS)
@@ -105,6 +105,9 @@
@@ -105,6 +105,9 @@ libsrtp.a: $(srtpobj) $(cryptobj) $(gdoi
ar cr libsrtp.a $^
$(RANLIB) libsrtp.a
@ -32,9 +32,9 @@ Last-Update: 2010-03-19
# libcryptomath.a contains general-purpose routines that are used to
# generate tables and verify cryptoalgorithm implementations - this
# library is not meant to be included in production code
@@ -198,6 +201,11 @@
cp $(srcdir)/crypto/include/*.h $(DESTDIR)$(includedir)/srtp
if [ "$(srcdir)" != "." ]; then cp crypto/include/*.h $(DESTDIR)$(includedir)/srtp; fi
@@ -197,6 +200,11 @@ install:
cp include/*.h $(DESTDIR)$(includedir)/srtp
cp crypto/include/*.h $(DESTDIR)$(includedir)/srtp
if [ -f libsrtp.a ]; then cp libsrtp.a $(DESTDIR)$(libdir)/; fi
+ if [ -f libsrtp.so.0.0 ]; then \
+ cp libsrtp.so.0.0 $(DESTDIR)$(libdir)/; \
@ -43,8 +43,8 @@ Last-Update: 2010-03-19
+ fi
uninstall:
rm -f $(DESTDIR)$(includedir)/srtp/*.h
@@ -206,7 +214,7 @@
rm -rf $(DESTDIR)$(includedir)/srtp
@@ -204,7 +212,7 @@ uninstall:
clean:
rm -rf $(cryptobj) $(srtpobj) $(cryptomath) TAGS \

View File

@ -1,4 +0,0 @@
1003_fix_mips_namespace_collision.patch
1005_fix_data_alignment.patch
1007_update_Doxyfile.patch
1008_shared-lib.patch