Upgrade strace to 4.5.14 (latest), differentiate sigcontext when we have 2.4 or 2.6 kernel (#959), should also fix #668
git-svn-id: svn://svn.openwrt.org/openwrt/packages@5531 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
0dde786155
commit
98365f351d
@ -9,12 +9,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=strace
|
||||
PKG_VERSION:=4.5.11
|
||||
PKG_VERSION:=4.5.14
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=@SF/strace
|
||||
PKG_MD5SUM:=28335e15c83456a3db055a0a0efcb4fe
|
||||
PKG_MD5SUM:=09bcd5d00ece28f8154dec11cadfce3c
|
||||
PKG_CAT:=bzcat
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
|
14
utils/strace/patches/01-linux_sigcontext.patch
Normal file
14
utils/strace/patches/01-linux_sigcontext.patch
Normal file
@ -0,0 +1,14 @@
|
||||
--- strace-4.5.11/signal.c 2005-02-02 05:16:54.000000000 +0100
|
||||
+++ strace-4.5.11.new/signal.c 2006-11-14 15:33:54.000000000 +0100
|
||||
@@ -1422,7 +1422,11 @@
|
||||
if (umove(tcp, sp, &sc) < 0)
|
||||
return 0;
|
||||
tcp->u_arg[0] = 1;
|
||||
+#ifdef LINUX_2_4
|
||||
tcp->u_arg[1] = sc.sc_sigset;
|
||||
+#else
|
||||
+ tcp->u_arg[1] = sc.sc_hi2;
|
||||
+#endif
|
||||
} else {
|
||||
tcp->u_rval = tcp->u_error = 0;
|
||||
if(tcp->u_arg[0] == 0)
|
Loading…
x
Reference in New Issue
Block a user