bump gtk2-version, some minor adjustments

git-svn-id: svn://svn.openwrt.org/openwrt/packages@18021 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
mirko 2009-10-10 23:06:44 +00:00
parent 26c148ede4
commit 9861055643
2 changed files with 41 additions and 41 deletions

View File

@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=gtk2
PKG_VERSION:=2.14.4
PKG_RELEASE:=6
PKG_VERSION:=2.18.2
PKG_RELEASE:=1
PKG_SOURCE:=gtk+-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=@GNOME/gtk+/2.14
PKG_SOURCE_URL:=@GNOME/gtk+/2.18
PKG_BUILD_DIR=$(BUILD_DIR)/gtk+-$(PKG_VERSION)
PKG_MD5SUM:=72bf65a54d2d29a6644dc0d28313ee67
iPKG_MD5SUM:=9477986b58d7ee5e559b96e7a124bead
PKG_FIXUP:=libtool
include $(INCLUDE_DIR)/package.mk
@ -22,9 +22,10 @@ include $(INCLUDE_DIR)/package.mk
PKG_INSTALL:=1
TARGET_CFLAGS+=\
-I$(STAGING_DIR)/usr/lib/libintl/include/
-I$(STAGING_DIR)/usr/lib/libintl/include/ \
-I$(STAGING_DIR)/usr/lib/libiconv/include/
EXTRA_LDFLAGS+=\
TARGET_LDFLAGS+=\
-Wl,-rpath-link=$(STAGING_DIR)/usr/lib \
-L$(STAGING_DIR)/usr/lib/libintl/lib/ \
-L$(STAGING_DIR)/usr/lib/libiconv/lib/ \

View File

@ -1,40 +1,39 @@
diff -urN gtk+-2.14.3.orig/gdk/Makefile.in gtk+-2.14.3/gdk/Makefile.in
--- gtk+-2.14.3.orig/gdk/Makefile.in 2008-10-03 23:14:22.000000000 +0200
+++ gtk+-2.14.3/gdk/Makefile.in 2008-10-03 23:19:30.000000000 +0200
@@ -424,8 +424,8 @@
--- gtk+-2.18.2.orig/Makefile.in 2009-10-10 17:23:54.000000000 +0200
+++ gtk+-2.18.2/Makefile.in 2009-10-05 22:46:12.000000000 +0200
@@ -464,8 +464,8 @@
|| { echo "Gtk+Tests:ERROR: Failed to start Xvfb environment for X11 target tests."; exit 1; } \
&& DISPLAY=:$$XID && export DISPLAY
-SUBDIRS = $(gdktarget) . tests
-DIST_SUBDIRS = win32 x11 quartz directfb tests
+SUBDIRS = $(gdktarget) .
+DIST_SUBDIRS = x11 directfb
INCLUDES = \
-DG_LOG_DOMAIN=\"Gdk\" \
diff -urN gtk+-2.14.3.orig/gtk/Makefile.in gtk+-2.14.3/gtk/Makefile.in
--- gtk+-2.14.3.orig/gtk/Makefile.in 2008-10-03 23:14:06.000000000 +0200
+++ gtk+-2.14.3/gtk/Makefile.in 2008-10-03 23:20:08.000000000 +0200
@@ -465,8 +465,8 @@
@USE_QUARTZ_TRUE@GTK_PRINT_PREVIEW_COMMAND = "open -a /Applications/Preview.app %f"
@USE_QUARTZ_FALSE@GTK_PRINT_PREVIEW_COMMAND = "evince --unlink-tempfile --preview --print-settings %s %f"
-SUBDIRS = theme-bits . tests
-DIST_SUBDIRS = theme-bits tests
+SUBDIRS = theme-bits .
+DIST_SUBDIRS = theme-bits
@HAVE_CUPS_FALSE@GTK_PRINT_BACKENDS = file,lpr
@HAVE_CUPS_TRUE@GTK_PRINT_BACKENDS = file,cups
diff -urN gtk+-2.14.3.orig/Makefile.in gtk+-2.14.3/Makefile.in
--- gtk+-2.14.3.orig/Makefile.in 2008-10-03 23:13:54.000000000 +0200
+++ gtk+-2.14.3/Makefile.in 2008-10-03 23:18:13.000000000 +0200
@@ -516,7 +516,7 @@
&& DISPLAY=:$$XID && export DISPLAY
-SRC_SUBDIRS = gdk-pixbuf gdk gtk modules demos tests perf contrib
+SRC_SUBDIRS = gdk-pixbuf gdk gtk modules contrib
SUBDIRS = po po-properties $(SRC_SUBDIRS) docs m4macros
+SUBDIRS = po po-properties $(SRC_SUBDIRS) m4macros
-SRC_SUBDIRS = gdk-pixbuf gdk gtk modules demos tests perf contrib
-SUBDIRS = po po-properties $(SRC_SUBDIRS) docs m4macros
# require automake 1.4
AUTOMAKE_OPTIONS = 1.7
--- gtk+-2.18.2.orig/gdk/Makefile.in 2009-10-10 17:22:54.000000000 +0200
+++ gtk+-2.18.2/gdk/Makefile.in 2009-10-05 22:46:07.000000000 +0200
@@ -510,8 +510,8 @@
|| { echo "Gtk+Tests:ERROR: Failed to start Xvfb environment for X11 target tests."; exit 1; } \
&& DISPLAY=:$$XID && export DISPLAY
+SUBDIRS = $(gdktarget) .
+DIST_SUBDIRS = x11 directfb
-SUBDIRS = $(gdktarget) . tests
-DIST_SUBDIRS = win32 x11 quartz directfb tests
INCLUDES = \
-DG_LOG_DOMAIN=\"Gdk\" \
-DGDK_COMPILATION \
--- gtk+-2.18.2.orig/gtk/Makefile.in 2009-10-10 17:23:29.000000000 +0200
+++ gtk+-2.18.2/gtk/Makefile.in 2009-10-05 22:46:09.000000000 +0200
@@ -928,8 +928,8 @@
# Makefile.am for gtk+/gtk
@USE_QUARTZ_TRUE@GTK_PRINT_PREVIEW_COMMAND = "open -a /Applications/Preview.app %f"
+SUBDIRS = theme-bits .
+DIST_SUBDIRS = theme-bits
-SUBDIRS = theme-bits . tests
-DIST_SUBDIRS = theme-bits tests
@HAVE_CUPS_FALSE@@HAVE_PAPI_CUPS_FALSE@@HAVE_PAPI_FALSE@GTK_PRINT_BACKENDS = file,lpr
@HAVE_CUPS_FALSE@@HAVE_PAPI_CUPS_FALSE@@HAVE_PAPI_TRUE@GTK_PRINT_BACKENDS = file,papi
@HAVE_CUPS_TRUE@@HAVE_PAPI_CUPS_FALSE@GTK_PRINT_BACKENDS = file,cups