* Update: 7.0 > 7.2
 * Refresh patches
 * Cleanup Makefile

git-svn-id: svn://svn.openwrt.org/openwrt/packages@8001 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
olli 2007-07-16 06:51:11 +00:00
parent 4616a83f5a
commit 9872d7b827
3 changed files with 22 additions and 43 deletions

View File

@ -9,13 +9,12 @@
include $(TOPDIR)/rules.mk include $(TOPDIR)/rules.mk
PKG_NAME:=pcre PKG_NAME:=pcre
PKG_VERSION:=7.0 PKG_VERSION:=7.2
PKG_RELEASE:=1 PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=@SF/pcre PKG_SOURCE_URL:=@SF/pcre
PKG_MD5SUM:=b97e3bb84bd665e0fbb7a90344d65a43 PKG_MD5SUM:=53305db73855f1ff155dcd2c05d448d3
PKG_CAT:=bzcat
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION) PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
@ -28,32 +27,23 @@ define Package/libpcre
URL:=http://www.pcre.org/ URL:=http://www.pcre.org/
endef endef
define Build/Configure CONFIGURE_ARGS += \
$(call Build/Configure/Default, \
--enable-shared \ --enable-shared \
--enable-static \ --enable-static \
--enable-utf8 \ --enable-utf8 \
) --disable-cpp
endef
define Build/Compile MAKE_FLAGS += \
$(MAKE) -C "$(PKG_BUILD_DIR)" \ $(TARGET_CONFIGURE_OPTS \
CC_FOR_BUILD="$(HOSTCC)" \
LINK_FOR_BUILD="$(HOSTCC)" \
CFLAGS_FOR_BUILD="" \
dftables
$(MAKE) -C "$(PKG_BUILD_DIR)" \
$(TARGET_CONFIGURE_OPTS) \
CFLAGS="$(TARGET_CFLAGS)" \ CFLAGS="$(TARGET_CFLAGS)" \
all all
endef
define Build/InstallDev define Build/InstallDev
mkdir -p $(STAGING_DIR)/usr/bin $(INSTALL_DIR) $(STAGING_DIR)/usr/bin
$(CP) $(PKG_BUILD_DIR)/pcre-config $(STAGING_DIR)/usr/bin/ $(CP) $(PKG_BUILD_DIR)/pcre-config $(STAGING_DIR)/usr/bin/
mkdir -p $(STAGING_DIR)/usr/include $(INSTALL_DIR) $(STAGING_DIR)/usr/include
$(CP) $(PKG_BUILD_DIR)/pcre{,posix}.h $(STAGING_DIR)/usr/include/ $(CP) $(PKG_BUILD_DIR)/pcre{,posix}.h $(STAGING_DIR)/usr/include/
mkdir -p $(STAGING_DIR)/usr/lib $(INSTALL_DIR) $(STAGING_DIR)/usr/lib
$(CP) $(PKG_BUILD_DIR)/.libs/libpcre{,posix}.{a,so*} $(STAGING_DIR)/usr/lib/ $(CP) $(PKG_BUILD_DIR)/.libs/libpcre{,posix}.{a,so*} $(STAGING_DIR)/usr/lib/
endef endef

View File

@ -1,12 +0,0 @@
diff -urN pcre-7.0/Makefile.in pcre-7.0.new/Makefile.in
--- pcre-7.0/Makefile.in 2006-12-19 10:31:35.000000000 +0100
+++ pcre-7.0.new/Makefile.in 2007-01-01 21:43:22.000000000 +0100
@@ -102,7 +102,7 @@
# to do one or the other or both by ./configure.
LIBTOOL = @LIBTOOL@
-LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) -c $(CFLAGS) -I. -I$(top_srcdir) $(NEWLINE) $(LINK_SIZE) $(MATCH_LIMIT) $(NO_RECURSE) $(EBCDIC)
+LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) -c $(CFLAGS) -I. -I$(top_srcdir) $(CPPFLAGS) $(NEWLINE) $(LINK_SIZE) $(MATCH_LIMIT) $(NO_RECURSE) $(EBCDIC)
LTCXXCOMPILE = $(LIBTOOL) --mode=compile $(CXX) -c $(CXXFLAGS) -I. -I$(top_srcdir) $(NEWLINE) $(LINK_SIZE) $(MATCH_LIMIT) $(NO_RECURSE) $(EBCDIC)
@ON_WINDOWS@LINK = $(CC) $(LDFLAGS) -I. -I$(top_srcdir) -L.libs
@NOT_ON_WINDOWS@LINK = $(LIBTOOL) --mode=link $(CC) $(CFLAGS) $(LDFLAGS) -I. -I$(top_srcdir)

View File

@ -1,8 +1,9 @@
diff -ruN pcre-5.0-old/pcre-config.in pcre-5.0-new/pcre-config.in Index: pcre-7.2/pcre-config.in
--- pcre-5.0-old/pcre-config.in 2004-09-13 16:20:00.000000000 +0200 ===================================================================
+++ pcre-5.0-new/pcre-config.in 2005-09-04 16:34:39.000000000 +0200 --- pcre-7.2.orig/pcre-config.in 2007-07-16 08:33:37.000000000 +0200
@@ -18,6 +18,10 @@ +++ pcre-7.2/pcre-config.in 2007-07-16 08:33:37.000000000 +0200
libR=" -R@libdir@" @@ -21,6 +21,10 @@
libR=" -Wl,-R@libdir@"
;; ;;
esac esac
+libS= +libS=
@ -12,7 +13,7 @@ diff -ruN pcre-5.0-old/pcre-config.in pcre-5.0-new/pcre-config.in
while test $# -gt 0; do while test $# -gt 0; do
case "$1" in case "$1" in
@@ -52,10 +56,10 @@ @@ -55,10 +59,10 @@
echo $includes echo $includes
;; ;;
--libs-posix) --libs-posix)