[package] update iptraf to 3.0.1 (#5866)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@17646 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
9d038fb0d6
commit
987b192ee2
@ -8,13 +8,13 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=iptraf
|
||||
PKG_VERSION:=3.0.0
|
||||
PKG_VERSION:=3.0.1
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=ftp://iptraf.seul.org/pub/iptraf/ \
|
||||
ftp://the.wiretapped.net/pub/security/network-monitoring/iptraf/
|
||||
PKG_MD5SUM:=377371c28ee3c21a76f7024920649ea8
|
||||
PKG_MD5SUM:=004c2c005a1b78739e22bc49d33e244d
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
@ -27,20 +27,22 @@ define Package/iptraf
|
||||
endef
|
||||
|
||||
define Package/iptraf/description
|
||||
IPTraf is a console-based network statistics utility for Linux. It gathers
|
||||
a variety of figures such as TCP connection packet and byte counts,
|
||||
interface statistics and activity indicators, TCP/UDP traffic breakdowns,
|
||||
and LAN station packet and byte counts.
|
||||
IPTraf is a console-based network statistics utility for Linux. It gathers a
|
||||
variety of figures such as TCP connection packet and byte counts, interface
|
||||
statistics and activity indicators, TCP/UDP traffic breakdowns, and LAN
|
||||
station packet and byte counts.
|
||||
endef
|
||||
|
||||
define Package/iptraf/postinst
|
||||
#!/bin/sh
|
||||
if [ -z "$${IPKG_INSTROOT}" ]; then
|
||||
mkdir -p $${IPKG_INSTROOT}/var/log/iptraf $${IPKG_INSTROOT}/var/run/iptraf $${IPKG_INSTROOT}/var/lib/iptraf/
|
||||
mkdir -p $${IPKG_INSTROOT}/var/log/iptraf \
|
||||
$${IPKG_INSTROOT}/var/run/iptraf \
|
||||
$${IPKG_INSTROOT}/var/lib/iptraf
|
||||
fi
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
define Build/Compile
|
||||
$(MAKE) -C $(PKG_BUILD_DIR)/src \
|
||||
$(TARGET_CONFIGURE_OPTS) \
|
||||
CFLAGS="$(TARGET_CFLAGS)" \
|
||||
@ -53,7 +55,7 @@ define Build/Compile
|
||||
all
|
||||
endef
|
||||
|
||||
define Package/iptraf/install
|
||||
define Package/iptraf/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/iptraf $(1)/usr/bin/
|
||||
endef
|
||||
|
@ -1,7 +1,6 @@
|
||||
diff -urN iptraf-3.0.0/support/Makefile iptraf-3.0.0.new/support/Makefile
|
||||
--- iptraf-3.0.0/support/Makefile 2002-07-19 18:31:48.000000000 +0200
|
||||
+++ iptraf-3.0.0.new/support/Makefile 2006-04-16 16:07:58.000000000 +0200
|
||||
@@ -3,16 +3,14 @@
|
||||
--- a/support/Makefile
|
||||
+++ b/support/Makefile
|
||||
@@ -3,16 +3,14 @@ INCLUDEDIR = -I/usr/include/ncurses
|
||||
OBJS = input.o menurt.o listbox.o winops.o labels.o \
|
||||
msgboxes.o txbox.o
|
||||
|
||||
|
@ -1,6 +1,5 @@
|
||||
diff -urN iptraf-3.0.0/src/dirs.h iptraf-3.0.0.new/src/dirs.h
|
||||
--- iptraf-3.0.0/src/dirs.h 2005-09-13 08:42:54.000000000 +0200
|
||||
+++ iptraf-3.0.0.new/src/dirs.h 2006-04-16 16:08:27.000000000 +0200
|
||||
--- a/src/dirs.h
|
||||
+++ b/src/dirs.h
|
||||
@@ -155,7 +155,6 @@
|
||||
*/
|
||||
|
||||
@ -9,18 +8,17 @@ diff -urN iptraf-3.0.0/src/dirs.h iptraf-3.0.0.new/src/dirs.h
|
||||
|
||||
/*
|
||||
* The rvnamed program file
|
||||
diff -urN iptraf-3.0.0/src/hostmon.c iptraf-3.0.0.new/src/hostmon.c
|
||||
--- iptraf-3.0.0/src/hostmon.c 2005-09-13 08:42:54.000000000 +0200
|
||||
+++ iptraf-3.0.0.new/src/hostmon.c 2006-04-16 16:29:27.000000000 +0200
|
||||
@@ -30,7 +30,6 @@
|
||||
#include <netinet/in.h>
|
||||
--- a/src/hostmon.c
|
||||
+++ b/src/hostmon.c
|
||||
@@ -31,7 +31,6 @@ details.
|
||||
#include <linux/if_packet.h>
|
||||
#include <linux/if_ether.h>
|
||||
#include <linux/netdevice.h>
|
||||
-#include <linux/if_fddi.h>
|
||||
#include <linux/if_tr.h>
|
||||
#include <net/if_arp.h>
|
||||
#include <stdlib.h>
|
||||
@@ -293,8 +292,6 @@
|
||||
@@ -294,8 +293,6 @@ void printethent(struct ethtab *table, s
|
||||
wprintw(table->tabwin, "Ethernet");
|
||||
else if (entry->un.desc.linktype == LINK_PLIP)
|
||||
wprintw(table->tabwin, "PLIP");
|
||||
@ -29,16 +27,16 @@ diff -urN iptraf-3.0.0/src/hostmon.c iptraf-3.0.0.new/src/hostmon.c
|
||||
|
||||
wprintw(table->tabwin, " HW addr: %s", entry->un.desc.ascaddr);
|
||||
|
||||
@@ -722,7 +719,7 @@
|
||||
@@ -723,7 +720,7 @@ void hostmon(const struct OPTIONS *optio
|
||||
unsigned long long updtime_usec = 0;
|
||||
|
||||
struct desclist elist; /* Ethernet description list */
|
||||
- struct desclist flist; /* FDDI description list */
|
||||
+ struct desclist flist; /* Other links description list */
|
||||
+ struct desclist flist; /* Other links description list */
|
||||
struct desclist *list = NULL;
|
||||
|
||||
FILE *logfile = NULL;
|
||||
@@ -786,7 +783,6 @@
|
||||
@@ -787,7 +784,6 @@ void hostmon(const struct OPTIONS *optio
|
||||
|
||||
initethtab(&table, options->actmode);
|
||||
loaddesclist(&elist, LINK_ETHERNET, WITHETCETHERS);
|
||||
@ -46,7 +44,7 @@ diff -urN iptraf-3.0.0/src/hostmon.c iptraf-3.0.0.new/src/hostmon.c
|
||||
|
||||
if (logging) {
|
||||
if (strcmp(current_logfile, "") == 0) {
|
||||
@@ -900,9 +896,7 @@
|
||||
@@ -901,9 +897,7 @@ void hostmon(const struct OPTIONS *optio
|
||||
if (pkt_result != PACKET_OK)
|
||||
continue;
|
||||
|
||||
@ -57,7 +55,7 @@ diff -urN iptraf-3.0.0/src/hostmon.c iptraf-3.0.0.new/src/hostmon.c
|
||||
|
||||
if (fromaddr.sll_protocol == htons(ETH_P_IP))
|
||||
is_ip = 1;
|
||||
@@ -920,12 +914,6 @@
|
||||
@@ -921,12 +915,6 @@ void hostmon(const struct OPTIONS *optio
|
||||
memcpy(scratch_daddr, ((struct ethhdr *) buf)->h_dest,
|
||||
ETH_ALEN);
|
||||
list = &elist;
|
||||
@ -70,10 +68,9 @@ diff -urN iptraf-3.0.0/src/hostmon.c iptraf-3.0.0.new/src/hostmon.c
|
||||
} else if (linktype == LINK_TR) {
|
||||
memcpy(scratch_saddr, ((struct trh_hdr *) buf)->saddr,
|
||||
TR_ALEN);
|
||||
diff -urN iptraf-3.0.0/src/ifaces.c iptraf-3.0.0.new/src/ifaces.c
|
||||
--- iptraf-3.0.0/src/ifaces.c 2005-09-13 08:42:54.000000000 +0200
|
||||
+++ iptraf-3.0.0.new/src/ifaces.c 2006-04-16 16:10:10.000000000 +0200
|
||||
@@ -37,7 +37,7 @@
|
||||
--- a/src/ifaces.c
|
||||
+++ b/src/ifaces.c
|
||||
@@ -37,7 +37,7 @@ extern int accept_unsupported_interfaces
|
||||
extern int daemonized;
|
||||
|
||||
char ifaces[][6] =
|
||||
@ -82,10 +79,9 @@ diff -urN iptraf-3.0.0/src/ifaces.c iptraf-3.0.0.new/src/ifaces.c
|
||||
"pvc", "hdlc", "ipsec", "sbni", "tr", "wvlan", "wlan", "sm2", "sm3",
|
||||
"pent", "lec", "brg", "tun", "tap", "cipcb", "tunl", "vlan"
|
||||
};
|
||||
diff -urN iptraf-3.0.0/src/landesc.c iptraf-3.0.0.new/src/landesc.c
|
||||
--- iptraf-3.0.0/src/landesc.c 2005-09-13 08:42:54.000000000 +0200
|
||||
+++ iptraf-3.0.0.new/src/landesc.c 2006-04-16 16:10:29.000000000 +0200
|
||||
@@ -83,8 +83,6 @@
|
||||
--- a/src/landesc.c
|
||||
+++ b/src/landesc.c
|
||||
@@ -83,8 +83,6 @@ void loaddesclist(struct desclist *list,
|
||||
|
||||
if (linktype == LINK_ETHERNET)
|
||||
fd = fopen(ETHFILE, "r");
|
||||
@ -94,7 +90,7 @@ diff -urN iptraf-3.0.0/src/landesc.c iptraf-3.0.0.new/src/landesc.c
|
||||
|
||||
if (fd == NULL) {
|
||||
return;
|
||||
@@ -205,8 +203,6 @@
|
||||
@@ -205,8 +203,6 @@ void savedesclist(struct desclist *list,
|
||||
|
||||
if (linktype == LINK_ETHERNET)
|
||||
fd = fopen(ETHFILE, "w");
|
||||
@ -103,9 +99,8 @@ diff -urN iptraf-3.0.0/src/landesc.c iptraf-3.0.0.new/src/landesc.c
|
||||
|
||||
if (fd < 0) {
|
||||
etherr();
|
||||
diff -urN iptraf-3.0.0/src/links.h iptraf-3.0.0.new/src/links.h
|
||||
--- iptraf-3.0.0/src/links.h 2005-09-13 08:42:54.000000000 +0200
|
||||
+++ iptraf-3.0.0.new/src/links.h 2006-04-16 16:10:39.000000000 +0200
|
||||
--- a/src/links.h
|
||||
+++ b/src/links.h
|
||||
@@ -6,7 +6,6 @@
|
||||
#define LINK_ISDN_RAWIP 6
|
||||
#define LINK_ISDN_CISCOHDLC 7
|
||||
@ -114,10 +109,9 @@ diff -urN iptraf-3.0.0/src/links.h iptraf-3.0.0.new/src/links.h
|
||||
#define LINK_FRAD 9
|
||||
#define LINK_DLCI 10
|
||||
#define LINK_TR 11
|
||||
diff -urN iptraf-3.0.0/src/log.c iptraf-3.0.0.new/src/log.c
|
||||
--- iptraf-3.0.0/src/log.c 2005-09-13 08:42:54.000000000 +0200
|
||||
+++ iptraf-3.0.0.new/src/log.c 2006-04-16 16:10:53.000000000 +0200
|
||||
@@ -491,8 +491,6 @@
|
||||
--- a/src/log.c
|
||||
+++ b/src/log.c
|
||||
@@ -491,8 +491,6 @@ void writeethlog(struct ethtabent *list,
|
||||
ptmp->un.desc.ascaddr);
|
||||
else if (ptmp->un.desc.linktype == LINK_PLIP)
|
||||
fprintf(fd, "\nPLIP address: %s", ptmp->un.desc.ascaddr);
|
||||
@ -126,10 +120,9 @@ diff -urN iptraf-3.0.0/src/log.c iptraf-3.0.0.new/src/log.c
|
||||
|
||||
if (ptmp->un.desc.withdesc)
|
||||
fprintf(fd, " (%s)", ptmp->un.desc.desc);
|
||||
diff -urN iptraf-3.0.0/src/options.c iptraf-3.0.0.new/src/options.c
|
||||
--- iptraf-3.0.0/src/options.c 2005-09-13 08:42:54.000000000 +0200
|
||||
+++ iptraf-3.0.0.new/src/options.c 2006-04-16 16:23:52.000000000 +0200
|
||||
@@ -68,8 +68,6 @@
|
||||
--- a/src/options.c
|
||||
+++ b/src/options.c
|
||||
@@ -68,8 +68,6 @@ void makeoptionmenu(struct MENU *menu)
|
||||
tx_additem(menu, NULL, NULL);
|
||||
tx_additem(menu, " ^E^thernet/PLIP host descriptions...",
|
||||
"Manages descriptions for Ethernet and PLIP addresses");
|
||||
@ -138,7 +131,7 @@ diff -urN iptraf-3.0.0/src/options.c iptraf-3.0.0.new/src/options.c
|
||||
tx_additem(menu, NULL, NULL);
|
||||
tx_additem(menu, " E^x^it configuration", "Returns to main menu");
|
||||
}
|
||||
@@ -371,9 +369,6 @@
|
||||
@@ -371,9 +369,6 @@ void setoptions(struct OPTIONS *options,
|
||||
case 14:
|
||||
ethdescmgr(LINK_ETHERNET);
|
||||
break;
|
||||
@ -148,18 +141,17 @@ diff -urN iptraf-3.0.0/src/options.c iptraf-3.0.0.new/src/options.c
|
||||
}
|
||||
|
||||
indicatesetting(row, options, statwin);
|
||||
diff -urN iptraf-3.0.0/src/othptab.c iptraf-3.0.0.new/src/othptab.c
|
||||
--- iptraf-3.0.0/src/othptab.c 2005-09-13 08:42:54.000000000 +0200
|
||||
+++ iptraf-3.0.0.new/src/othptab.c 2006-04-16 16:24:21.000000000 +0200
|
||||
@@ -19,7 +19,6 @@
|
||||
#include <asm/types.h>
|
||||
--- a/src/othptab.c
|
||||
+++ b/src/othptab.c
|
||||
@@ -22,7 +22,6 @@ details.
|
||||
#include <linux/if_ether.h>
|
||||
#include <linux/if_tr.h>
|
||||
#include <linux/netdevice.h>
|
||||
-#include <linux/if_fddi.h>
|
||||
#include <winops.h>
|
||||
#include "arphdr.h"
|
||||
#include "options.h"
|
||||
@@ -139,11 +138,6 @@
|
||||
@@ -142,11 +141,6 @@ struct othptabent *add_othp_entry(struct
|
||||
new_entry->smacaddr);
|
||||
convmacaddr(((struct ethhdr *) packet)->h_dest,
|
||||
new_entry->dmacaddr);
|
||||
@ -171,7 +163,7 @@ diff -urN iptraf-3.0.0/src/othptab.c iptraf-3.0.0.new/src/othptab.c
|
||||
} else if (linkproto == LINK_TR) {
|
||||
convmacaddr(((struct trh_hdr *) packet)->saddr,
|
||||
new_entry->smacaddr);
|
||||
@@ -373,8 +367,7 @@
|
||||
@@ -376,8 +370,7 @@ void printothpentry(struct othptable *ta
|
||||
strcat(msgstring, scratchpad);
|
||||
|
||||
if ((entry->linkproto == LINK_ETHERNET) ||
|
||||
@ -181,18 +173,17 @@ diff -urN iptraf-3.0.0/src/othptab.c iptraf-3.0.0.new/src/othptab.c
|
||||
sprintf(scratchpad, " from %s to %s on %s",
|
||||
entry->smacaddr, entry->dmacaddr, entry->iface);
|
||||
|
||||
diff -urN iptraf-3.0.0/src/packet.c iptraf-3.0.0.new/src/packet.c
|
||||
--- iptraf-3.0.0/src/packet.c 2005-09-13 08:42:54.000000000 +0200
|
||||
+++ iptraf-3.0.0.new/src/packet.c 2006-04-16 16:11:55.000000000 +0200
|
||||
@@ -35,7 +35,6 @@
|
||||
#include <sys/ioctl.h>
|
||||
--- a/src/packet.c
|
||||
+++ b/src/packet.c
|
||||
@@ -35,7 +35,6 @@ details.
|
||||
#include <linux/if_packet.h>
|
||||
#include <linux/if_ether.h>
|
||||
#include <linux/netdevice.h>
|
||||
-#include <linux/if_fddi.h>
|
||||
#include <linux/if_tr.h>
|
||||
#include <linux/isdn.h>
|
||||
#include <linux/sockios.h>
|
||||
@@ -81,8 +80,6 @@
|
||||
@@ -81,8 +80,6 @@ unsigned short getlinktype(unsigned shor
|
||||
result = LINK_ETHERNET;
|
||||
else if (strncmp(ifname, "plip", 4) == 0)
|
||||
result = LINK_PLIP;
|
||||
@ -201,7 +192,7 @@ diff -urN iptraf-3.0.0/src/packet.c iptraf-3.0.0.new/src/packet.c
|
||||
else if (strncmp(ifname, "dvb", 3) == 0)
|
||||
result = LINK_ETHERNET;
|
||||
else if (strncmp(ifname, "sbni", 4) == 0)
|
||||
@@ -136,9 +133,6 @@
|
||||
@@ -136,9 +133,6 @@ unsigned short getlinktype(unsigned shor
|
||||
case ARPHRD_PPP:
|
||||
result = LINK_PPP;
|
||||
break;
|
||||
@ -211,7 +202,7 @@ diff -urN iptraf-3.0.0/src/packet.c iptraf-3.0.0.new/src/packet.c
|
||||
case ARPHRD_IEEE802:
|
||||
case ARPHRD_IEEE802_TR:
|
||||
result = LINK_TR;
|
||||
@@ -194,19 +188,6 @@
|
||||
@@ -194,19 +188,6 @@ void adjustpacket(char *tpacket, unsigne
|
||||
*packet = tpacket + 4;
|
||||
*readlen -= 4;
|
||||
break;
|
||||
@ -231,20 +222,19 @@ diff -urN iptraf-3.0.0/src/packet.c iptraf-3.0.0.new/src/packet.c
|
||||
case LINK_TR:
|
||||
/*
|
||||
* Token Ring patch supplied by Tomas Dvorak
|
||||
diff -urN iptraf-3.0.0/src/promisc.c iptraf-3.0.0.new/src/promisc.c
|
||||
--- iptraf-3.0.0/src/promisc.c 2005-09-13 08:42:54.000000000 +0200
|
||||
+++ iptraf-3.0.0.new/src/promisc.c 2006-04-16 16:12:56.000000000 +0200
|
||||
@@ -81,8 +81,8 @@
|
||||
--- a/src/promisc.c
|
||||
+++ b/src/promisc.c
|
||||
@@ -81,8 +81,8 @@ void init_promisc_list(struct promisc_st
|
||||
*/
|
||||
|
||||
if ((strncmp(buf, "eth", 3) == 0) ||
|
||||
- (strncmp(buf, "fddi", 4) == 0) ||
|
||||
(strncmp(buf, "tr", 2) == 0) ||
|
||||
+ (strncmp(buf, "vlan", 4) == 0) ||
|
||||
+ (strncmp(buf, "vlan", 4) == 0) ||
|
||||
(strncmp(ptmp->params.ifname, "wvlan", 4) == 0) ||
|
||||
(strncmp(ptmp->params.ifname, "lec", 3) == 0) ||
|
||||
(accept_unsupported_interfaces)) {
|
||||
@@ -195,7 +195,7 @@
|
||||
@@ -195,7 +195,7 @@ void srpromisc(int mode, struct promisc_
|
||||
|
||||
while (ptmp != NULL) {
|
||||
if (((strncmp(ptmp->params.ifname, "eth", 3) == 0) ||
|
||||
@ -253,9 +243,8 @@ diff -urN iptraf-3.0.0/src/promisc.c iptraf-3.0.0.new/src/promisc.c
|
||||
(strncmp(ptmp->params.ifname, "tr", 2) == 0) ||
|
||||
(strncmp(ptmp->params.ifname, "wvlan", 4) == 0) ||
|
||||
(strncmp(ptmp->params.ifname, "lec", 3) == 0)) &&
|
||||
diff -urN iptraf-3.0.0/src/rvnamed.h iptraf-3.0.0.new/src/rvnamed.h
|
||||
--- iptraf-3.0.0/src/rvnamed.h 2005-09-13 08:42:54.000000000 +0200
|
||||
+++ iptraf-3.0.0.new/src/rvnamed.h 2006-04-16 16:13:39.000000000 +0200
|
||||
--- a/src/rvnamed.h
|
||||
+++ b/src/rvnamed.h
|
||||
@@ -1,9 +1,9 @@
|
||||
#include <netinet/in.h>
|
||||
#include <arpa/inet.h>
|
||||
@ -269,10 +258,9 @@ diff -urN iptraf-3.0.0/src/rvnamed.h iptraf-3.0.0.new/src/rvnamed.h
|
||||
|
||||
#define SOCKET_PREFIX "isock"
|
||||
|
||||
diff -urN iptraf-3.0.0/src/tcptable.c iptraf-3.0.0.new/src/tcptable.c
|
||||
--- iptraf-3.0.0/src/tcptable.c 2005-09-13 08:42:54.000000000 +0200
|
||||
+++ iptraf-3.0.0.new/src/tcptable.c 2006-04-16 16:13:54.000000000 +0200
|
||||
@@ -600,8 +600,6 @@
|
||||
--- a/src/tcptable.c
|
||||
+++ b/src/tcptable.c
|
||||
@@ -600,8 +600,6 @@ void updateentry(struct tcptable *table,
|
||||
|
||||
if ((linkproto == LINK_ETHERNET) || (linkproto == LINK_PLIP)) {
|
||||
convmacaddr(((struct ethhdr *) packet)->h_source, newmacaddr);
|
||||
@ -281,14 +269,13 @@ diff -urN iptraf-3.0.0/src/tcptable.c iptraf-3.0.0.new/src/tcptable.c
|
||||
} else if (linkproto == LINK_TR) {
|
||||
convmacaddr(((struct trh_hdr *) packet)->saddr, newmacaddr);
|
||||
}
|
||||
diff -urN iptraf-3.0.0/src/tcptable.h iptraf-3.0.0.new/src/tcptable.h
|
||||
--- iptraf-3.0.0/src/tcptable.h 2005-09-13 08:42:54.000000000 +0200
|
||||
+++ iptraf-3.0.0.new/src/tcptable.h 2006-04-16 16:14:03.000000000 +0200
|
||||
@@ -22,7 +22,6 @@
|
||||
#include <asm/types.h>
|
||||
--- a/src/tcptable.h
|
||||
+++ b/src/tcptable.h
|
||||
@@ -23,7 +23,6 @@
|
||||
#include <linux/if_packet.h>
|
||||
#include <linux/if_ether.h>
|
||||
#include <linux/netdevice.h>
|
||||
-#include <linux/if_fddi.h>
|
||||
#include <linux/if_tr.h>
|
||||
#include <net/if.h>
|
||||
// #include <net/if.h>
|
||||
#include <netinet/ip.h>
|
||||
|
@ -1,7 +1,6 @@
|
||||
diff -urN iptraf-3.0.0/src/options.c iptraf-3.0.0.new/src/options.c
|
||||
--- iptraf-3.0.0/src/options.c 2005-09-13 08:42:54.000000000 +0200
|
||||
+++ iptraf-3.0.0.new/src/options.c 2007-03-23 13:31:37.000000000 +0100
|
||||
@@ -377,7 +377,7 @@
|
||||
--- a/src/options.c
|
||||
+++ b/src/options.c
|
||||
@@ -372,7 +372,7 @@ void setoptions(struct OPTIONS *options,
|
||||
}
|
||||
|
||||
indicatesetting(row, options, statwin);
|
||||
|
@ -1,17 +1,15 @@
|
||||
diff -urN iptraf-3.0.0/src/othptab.c iptraf-3.0.0.new/src/othptab.c
|
||||
--- iptraf-3.0.0/src/othptab.c 2005-09-13 08:42:54.000000000 +0200
|
||||
+++ iptraf-3.0.0.new/src/othptab.c 2009-01-16 15:45:08.000000000 +0100
|
||||
@@ -17,6 +17,7 @@
|
||||
***/
|
||||
--- a/src/othptab.c
|
||||
+++ b/src/othptab.c
|
||||
@@ -18,6 +18,7 @@ details.
|
||||
|
||||
#include <stdlib.h>
|
||||
#include <asm/types.h>
|
||||
+#include <sys/types.h>
|
||||
#include <sys/socket.h>
|
||||
#include <linux/if_ether.h>
|
||||
#include <linux/if_tr.h>
|
||||
#include <linux/if_fddi.h>
|
||||
diff -urN iptraf-3.0.0/src/tr.c iptraf-3.0.0.new/src/tr.c
|
||||
--- iptraf-3.0.0/src/tr.c 2005-09-13 08:42:54.000000000 +0200
|
||||
+++ iptraf-3.0.0.new/src/tr.c 2009-01-16 15:47:47.000000000 +0100
|
||||
--- a/src/tr.c
|
||||
+++ b/src/tr.c
|
||||
@@ -7,6 +7,7 @@
|
||||
*/
|
||||
|
||||
|
Loading…
x
Reference in New Issue
Block a user