Update smartmontools to 5.37 (#1238)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@6207 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
0ad1d19a23
commit
98b59e24ec
@ -9,12 +9,12 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=smartmontools
|
PKG_NAME:=smartmontools
|
||||||
PKG_VERSION:=5.36
|
PKG_VERSION:=5.37
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=@SF/smartmontools
|
PKG_SOURCE_URL:=@SF/smartmontools
|
||||||
PKG_MD5SUM:=2e424f2d35efa38a29ebca419c1dbe3c
|
PKG_MD5SUM:=4ab3668b7d1362ce923f64a211e0e568
|
||||||
PKG_CAT:=zcat
|
PKG_CAT:=zcat
|
||||||
|
|
||||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||||
|
@ -1,6 +1,7 @@
|
|||||||
--- smartmontools-5.36/configure.in.orig 2006-12-17 03:01:38.000000000 +0100
|
diff -urN smartmontools-5.37/configure.in smartmontools-5.37.new/configure.in
|
||||||
+++ smartmontools-5.36/configure.in 2006-12-17 03:00:35.000000000 +0100
|
--- smartmontools-5.37/configure.in 2006-12-20 21:39:25.000000000 +0100
|
||||||
@@ -74,16 +74,16 @@
|
+++ smartmontools-5.37.new/configure.in 2007-01-26 11:37:41.000000000 +0100
|
||||||
|
@@ -76,18 +76,18 @@
|
||||||
AC_CHECK_FUNCS([uname])
|
AC_CHECK_FUNCS([uname])
|
||||||
|
|
||||||
# Check whether snprintf appends null char and returns expected length on overflow
|
# Check whether snprintf appends null char and returns expected length on overflow
|
||||||
@ -8,7 +9,9 @@
|
|||||||
-AC_MSG_CHECKING([for working snprintf])
|
-AC_MSG_CHECKING([for working snprintf])
|
||||||
-AC_RUN_IFELSE([AC_LANG_PROGRAM([[#include <stdio.h>]], [[ char buf[]="ABCDEFGHI";
|
-AC_RUN_IFELSE([AC_LANG_PROGRAM([[#include <stdio.h>]], [[ char buf[]="ABCDEFGHI";
|
||||||
- int i=snprintf(buf,8,"12345678"); return !(!buf[7] && i==8); ]])],
|
- int i=snprintf(buf,8,"12345678"); return !(!buf[7] && i==8); ]])],
|
||||||
- [libc_have_working_snprintf=yes], [libc_have_working_snprintf=no])
|
- [libc_have_working_snprintf=yes],
|
||||||
|
- [libc_have_working_snprintf=no],
|
||||||
|
- [libc_have_working_snprintf=no])
|
||||||
-AC_SUBST(libc_have_working_snprintf)
|
-AC_SUBST(libc_have_working_snprintf)
|
||||||
-if test "$libc_have_working_snprintf" = "yes"; then
|
-if test "$libc_have_working_snprintf" = "yes"; then
|
||||||
- AC_DEFINE(HAVE_WORKING_SNPRINTF)
|
- AC_DEFINE(HAVE_WORKING_SNPRINTF)
|
||||||
@ -18,7 +21,9 @@
|
|||||||
+#AC_MSG_CHECKING([for working snprintf])
|
+#AC_MSG_CHECKING([for working snprintf])
|
||||||
+#AC_RUN_IFELSE([AC_LANG_PROGRAM([[#include <stdio.h>]], [[ char buf[]="ABCDEFGHI";
|
+#AC_RUN_IFELSE([AC_LANG_PROGRAM([[#include <stdio.h>]], [[ char buf[]="ABCDEFGHI";
|
||||||
+# int i=snprintf(buf,8,"12345678"); return !(!buf[7] && i==8); ]])],
|
+# int i=snprintf(buf,8,"12345678"); return !(!buf[7] && i==8); ]])],
|
||||||
+# [libc_have_working_snprintf=yes], [libc_have_working_snprintf=no])
|
+# [libc_have_working_snprintf=yes],
|
||||||
|
+# [libc_have_working_snprintf=no],
|
||||||
|
+# [libc_have_working_snprintf=no])
|
||||||
+#AC_SUBST(libc_have_working_snprintf)
|
+#AC_SUBST(libc_have_working_snprintf)
|
||||||
+#if test "$libc_have_working_snprintf" = "yes"; then
|
+#if test "$libc_have_working_snprintf" = "yes"; then
|
||||||
+# AC_DEFINE(HAVE_WORKING_SNPRINTF)
|
+# AC_DEFINE(HAVE_WORKING_SNPRINTF)
|
||||||
@ -26,4 +31,4 @@
|
|||||||
+#AC_MSG_RESULT([$libc_have_working_snprintf])
|
+#AC_MSG_RESULT([$libc_have_working_snprintf])
|
||||||
|
|
||||||
# check for __attribute__((packed))
|
# check for __attribute__((packed))
|
||||||
AH_TEMPLATE(HAVE_ATTR_PACKED, [Define to 1 if C compiler supports __attribute__((packed))])
|
AH_TEMPLATE(HAVE_ATTR_PACKED, [Define to 1 if C++ compiler supports __attribute__((packed))])
|
||||||
|
Loading…
x
Reference in New Issue
Block a user