[packages] weechat: update to 0.3.5, use cmake for building

git-svn-id: svn://svn.openwrt.org/openwrt/packages@26964 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
loswillios 2011-05-20 17:40:50 +00:00
parent 2be5098dc2
commit 992b7adc02
6 changed files with 11 additions and 239 deletions

View File

@ -8,18 +8,18 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=weechat
PKG_VERSION:=0.2.6
PKG_VERSION:=0.3.5
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://www.weechat.org/files/src
PKG_MD5SUM:=ccdecf663b0050a23049acb4b9a76193
PKG_MD5SUM:=0d2a089bfbfa550e0c65618a171fb3c4
PKG_FIXUP = libtool
PKG_CONFIG_DEPENDS = CONFIG_PACKAGE_weechat-mod-lua
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/nls.mk
include $(INCLUDE_DIR)/cmake.mk
define Package/weechat/Default
SUBMENU:=Instant Messaging
@ -36,94 +36,29 @@ endef
define Package/weechat
$(call Package/weechat/Default)
MENU=1
DEPENDS:=+libgnutls +libncurses $(ICONV_DEPENDS)
DEPENDS:=+libgnutls +libncursesw $(ICONV_DEPENDS)
endef
define Package/weechat/description
$(call Package/weechat/Default/description)
endef
define Package/weechat-mod-charset
$(call Package/weechat/Default)
TITLE+= (charset plugin)
DEPENDS:=weechat
endef
define Package/weechat-mod-charset/description
$(call Package/weechat/Default/description)
This packages contains a charset plugin for Weechat.
endef
define Package/weechat-mod-lua
$(call Package/weechat/Default)
TITLE+= (Lua plugin)
DEPENDS:=weechat +liblua @BROKEN
endef
define Package/weechat-mod-lua/description
$(call Package/weechat/Default/description)
This packages contains an Lua scripting plugin for Weechat.
endef
CONFIGURE_ARGS+= \
--with-debug=0 \
--without-doc-xsl-prefix \
--with-libiconv-prefix="$(ICONV_PREFIX)" \
--without-libintl-prefix \
--disable-aspell \
--disable-perl \
--disable-python \
--disable-ruby \
LUACONFIG="" \
ac_cv_path_LIBGNUTLS_CONFIG="pkg-config gnutls" \
CMAKE_OPTIONS+= \
-DENABLE_PYTHON=OFF \
-DENABLE_PERL=OFF \
-DENABLE_LUA=OFF
TARGET_LDFLAGS += \
-L$(ICONV_PREFIX)/lib \
-Wl,-rpath-link,$(STAGING_DIR)/usr/lib
ifneq ($(CONFIG_PACKAGE_weechat-mod-lua),)
CONFIGURE_ARGS+= \
--enable-lua \
--enable-plugins \
--with-plugins="lua" \
--with-lua-inc="$(STAGING_DIR)/usr/include" \
--with-lua-lib="$(STAGING_DIR)/usr/lib"
CONFIGURE_VARS+= \
LIBS="-ldl -lm"
TARGET_LDFLAGS += -lcrypt
else
CONFIGURE_ARGS+= \
--disable-lua
endif
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
$(LUA_FLAGS) \
DESTDIR="$(PKG_INSTALL_DIR)" \
LUACONFIG="" \
all install
endef
define Package/weechat/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/weechat-curses $(1)/usr/bin/
$(INSTALL_DIR) $(1)/usr/lib/weechat/plugins
endef
define BuildPlugin
define Package/weechat-mod-$(1)/install
$(INSTALL_DIR) $$(1)/usr/lib/weechat/plugins
$(CP) $(PKG_INSTALL_DIR)/usr/lib/weechat/plugins/$(1).so* $$(1)/usr/lib/weechat/plugins/
endef
$$(eval $$(call BuildPackage,weechat-mod-$(1)))
$(CP) \
$(PKG_INSTALL_DIR)/usr/lib/weechat/plugins/* \
$(1)/usr/lib/weechat/plugins/
endef
$(eval $(call BuildPackage,weechat))
$(eval $(call BuildPlugin,charset))
$(eval $(call BuildPlugin,lua))

View File

@ -1,56 +0,0 @@
--- a/configure
+++ b/configure
@@ -29625,8 +29625,7 @@ echo $ECHO_N "checking for iconv usabili
{ { echo "$as_me:$LINENO: error: cannot run test program while cross compiling
See \`config.log' for more details." >&5
echo "$as_me: error: cannot run test program while cross compiling
-See \`config.log' for more details." >&2;}
- { (exit 1); exit 1; }; }
+See \`config.log' for more details." >&2;} }
else
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
@@ -29683,7 +29682,6 @@ echo "${ECHO_T}no" >&6; }
echo "${ECHO_T}yes" >&6; }
fi
fi
-
if test "x$iconv_found" = "xno" ; then
{ { echo "$as_me:$LINENO: error:
*** Iconv headers and/or libraries couldn't be found in your system.
@@ -29692,8 +29690,7 @@ if test "x$iconv_found" = "xno" ; then
echo "$as_me: error:
*** Iconv headers and/or libraries couldn't be found in your system.
*** Try to install them with your software package manager.
-*** WeeChat can't be built without Iconv support." >&2;}
- { (exit 1); exit 1; }; }
+*** WeeChat can't be built without Iconv support." >&2;} }
fi
# ------------------------------------------------------------------------------
--- a/configure.in
+++ b/configure.in
@@ -208,22 +208,8 @@ if test "x$ac_found_iconv_header" = "xye
if test "x$ac_found_iconv_lib" = "xyes" ; then
ICONV_LFLAGS="-liconv"
LIBS="$LIBS $ICONV_LFLAGS"
+ iconv_found="yes"
fi
- AC_MSG_CHECKING(for iconv usability in programs)
- AC_TRY_RUN([
- #include <iconv.h>
- int main(int argc, char **argv) {
- iconv_t conv = iconv_open("ISO8859-1", "UTF-8");
- if (conv != (iconv_t) -1) {
- return 0;
- }
- return 1;
- }],iconv_found="yes")
- if test "x$iconv_found" = "xno" ; then
- AC_MSG_RESULT(no)
- else
- AC_MSG_RESULT(yes)
- fi
fi
if test "x$iconv_found" = "xno" ; then

View File

@ -1,24 +0,0 @@
diff -urN weechat-0.2.5/Makefile.am weechat-0.2.5.new/Makefile.am
--- weechat-0.2.5/Makefile.am 2007-01-05 20:12:16.000000000 +0100
+++ weechat-0.2.5.new/Makefile.am 2007-09-05 19:28:55.000000000 +0200
@@ -15,7 +15,7 @@
# Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
#
-SUBDIRS = po doc intl src
+SUBDIRS = po intl src
EXTRA_DIST = config.rpath BUGS FAQ FAQ.fr \
debian/changelog debian/control \
diff -urN weechat-0.2.5/Makefile.in weechat-0.2.5.new/Makefile.in
--- weechat-0.2.5/Makefile.in 2007-06-07 16:52:50.000000000 +0200
+++ weechat-0.2.5.new/Makefile.in 2007-09-05 19:28:48.000000000 +0200
@@ -290,7 +290,7 @@
sysconfdir = @sysconfdir@
target_alias = @target_alias@
weechat_libdir = @weechat_libdir@
-SUBDIRS = po doc intl src
+SUBDIRS = po intl src
EXTRA_DIST = config.rpath BUGS FAQ FAQ.fr \
debian/changelog debian/control \
debian/copyright debian/compat \

View File

@ -1,17 +0,0 @@
--- a/configure
+++ b/configure
@@ -30177,14 +30177,6 @@ fi
test -n "$LUACONFIG" && break
done
- if test "x$LUACONFIG" != "x" ; then
- { echo "$as_me:$LINENO: checking for Lua headers and librairies with lua-config" >&5
-echo $ECHO_N "checking for Lua headers and librairies with lua-config... $ECHO_C" >&6; }
- echo
- LUA_CFLAGS=`$LUACONFIG --include`
- LUA_LFLAGS=`$LUACONFIG --libs`
- LUA_VERSION="5.0.x"
- fi
fi
if test "x$LUA_CFLAGS" = "x" -o "x$LUA_LFLAGS" = "x" ; then

View File

@ -1,51 +0,0 @@
--- a/configure.in
+++ b/configure.in
@@ -176,21 +176,7 @@ fi
# WXWIDGETS_LIBS=""
#fi
-if test "x$enable_gtk" = "xyes" ; then
- AM_PATH_GTK_2_0(2.4.0, LIBGTK_FOUND=1, LIBGTK_FOUND=0)
- if test "$LIBGTK_FOUND" = "0" ; then
- AC_MSG_WARN([
-*** Gtk library not found!
-*** WeeChat will be built without Gtk support.])
- enable_gtk="no"
- not_found="$not_found gtk"
- else
- GTK_CFLAGS=`pkg-config --cflags gtk+-2.0`
- GTK_LIBS=`pkg-config --libs gtk+-2.0`
- AC_SUBST(GTK_CFLAGS)
- AC_SUBST(GTK_LIBS)
- fi
-fi
+enable_gtk="no"
# ------------------------------------------------------------------------------
# iconv
@@ -586,20 +572,11 @@ fi
# ------------------------------------------------------------------------------
if test "x$enable_gnutls" = "xyes" ; then
- found_gnutls="no"
- AM_PATH_LIBGNUTLS( 1.0.0, found_gnutls=yes, AC_MSG_WARN([[
-*** libgnutls was not found. You may want to get it from ftp://ftp.gnutls.org/pub/gnutls/
-*** WeeChat will be built without GnuTLS support.]]))
- if test "x$found_gnutls" = "xyes" ; then
- GNUTLS_CFLAGS=`libgnutls-config --cflags`
- GNUTLS_LFLAGS=`libgnutls-config --libs`
- AC_SUBST(GNUTLS_CFLAGS)
- AC_SUBST(GNUTLS_LFLAGS)
- AC_DEFINE(HAVE_GNUTLS)
- else
- enable_gnutls="no"
- not_found="$not_found gnutls"
- fi
+ GNUTLS_CFLAGS=`pkg-config --cflags gnutls`
+ GNUTLS_LFLAGS=`pkg-config --libs gnutls`
+ AC_SUBST(GNUTLS_CFLAGS)
+ AC_SUBST(GNUTLS_LFLAGS)
+ AC_DEFINE(HAVE_GNUTLS)
fi
# ------------------------------------------------------------------------------

View File

@ -1,15 +0,0 @@
diff --git a/configure b/configure
index f388ffe..c9ec352 100755
--- a/configure
+++ b/configure
@@ -31400,8 +31400,8 @@ echo "$as_me: WARNING:
if test "x$found_gnutls" = "xyes" ; then
- GNUTLS_CFLAGS=`libgnutls-config --cflags`
- GNUTLS_LFLAGS=`libgnutls-config --libs`
+ GNUTLS_CFLAGS=`pkg-config gnutls --cflags`
+ GNUTLS_LFLAGS=`pkg-config gnutls --libs`
cat >>confdefs.h <<\_ACEOF