Update weechat: 0.2.4 > 0.2.5
git-svn-id: svn://svn.openwrt.org/openwrt/packages@7801 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
f1d13bd5db
commit
9a512f3978
@ -9,12 +9,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=weechat
|
||||
PKG_VERSION:=0.2.4
|
||||
PKG_RELEASE:=1
|
||||
PKG_VERSION:=0.2.5
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=http://weechat.flashtux.org/download/
|
||||
PKG_MD5SUM:=c7c7f89d6dac502ad31d12198a8836c1
|
||||
PKG_MD5SUM:=42f96620c3b2fd3dca9768d9ce16dd06
|
||||
PKG_CAT:=bzcat
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
@ -32,30 +32,25 @@ define Package/weechat
|
||||
URL:=http://weechat.flashtux.org/
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
$(call Build/Configure/Default, \
|
||||
--with-debug=0 \
|
||||
--with-libgnutls-prefix=$(STAGING_DIR)/usr \
|
||||
--without-doc-xsl-prefix \
|
||||
--with-libiconv-prefix="$(STAGING_DIR)/usr/lib/libiconv" \
|
||||
--without-libintl-prefix \
|
||||
--disable-aspell \
|
||||
--enable-lua \
|
||||
--with-lua-inc="$(STAGING_DIR)/usr/include" \
|
||||
--with-lua-lib="$(STAGING_DIR)/usr/lib" \
|
||||
--disable-perl \
|
||||
--disable-python \
|
||||
--disable-ruby \
|
||||
, \
|
||||
LIBS="-llua -ldl -lm -L$(STAGING_DIR)/usr/lib/libiconv/lib" \
|
||||
)
|
||||
endef
|
||||
CONFIGURE_ARGS += \
|
||||
--with-debug=0 \
|
||||
--with-libgnutls-prefix=$(STAGING_DIR)/usr \
|
||||
--without-doc-xsl-prefix \
|
||||
--with-libiconv-prefix="$(STAGING_DIR)/usr/lib/libiconv" \
|
||||
--without-libintl-prefix \
|
||||
--disable-aspell \
|
||||
--enable-lua \
|
||||
--with-lua-inc="$(STAGING_DIR)/usr/include" \
|
||||
--with-lua-lib="$(STAGING_DIR)/usr/lib" \
|
||||
--disable-perl \
|
||||
--disable-python \
|
||||
--disable-ruby \
|
||||
, \
|
||||
LIBS="-llua -ldl -lm -L$(STAGING_DIR)/usr/lib/libiconv/lib"
|
||||
|
||||
define Build/Compile
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||
all install
|
||||
endef
|
||||
MAKE_FLAGS += \
|
||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||
all install
|
||||
|
||||
define Package/weechat/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
|
@ -1,7 +1,8 @@
|
||||
diff -urN weechat-0.2.0/configure weechat-0.2.0.new/configure
|
||||
--- weechat-0.2.0/configure 2006-08-19 13:22:12.000000000 +0200
|
||||
+++ weechat-0.2.0.new/configure 2006-09-17 13:51:42.000000000 +0200
|
||||
@@ -29801,8 +29801,7 @@
|
||||
Index: weechat-0.2.5/configure
|
||||
===================================================================
|
||||
--- weechat-0.2.5.orig/configure 2007-06-30 17:15:36.000000000 +0200
|
||||
+++ weechat-0.2.5/configure 2007-06-30 17:15:36.000000000 +0200
|
||||
@@ -29349,8 +29349,7 @@
|
||||
{ { echo "$as_me:$LINENO: error: cannot run test program while cross compiling
|
||||
See \`config.log' for more details." >&5
|
||||
echo "$as_me: error: cannot run test program while cross compiling
|
||||
@ -11,7 +12,7 @@ diff -urN weechat-0.2.0/configure weechat-0.2.0.new/configure
|
||||
else
|
||||
cat >conftest.$ac_ext <<_ACEOF
|
||||
/* confdefs.h. */
|
||||
@@ -29859,7 +29858,6 @@
|
||||
@@ -29407,7 +29406,6 @@
|
||||
echo "${ECHO_T}yes" >&6; }
|
||||
fi
|
||||
fi
|
||||
@ -19,7 +20,7 @@ diff -urN weechat-0.2.0/configure weechat-0.2.0.new/configure
|
||||
if test "x$iconv_found" = "xno" ; then
|
||||
{ { echo "$as_me:$LINENO: error:
|
||||
*** Iconv headers and/or libraries couldn't be found in your system.
|
||||
@@ -29868,8 +29866,7 @@
|
||||
@@ -29416,8 +29414,7 @@
|
||||
echo "$as_me: error:
|
||||
*** Iconv headers and/or libraries couldn't be found in your system.
|
||||
*** Try to install them with your software package manager.
|
||||
|
Loading…
x
Reference in New Issue
Block a user