wavemon: moved to github

git-svn-id: svn://svn.openwrt.org/openwrt/packages@41604 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
cyrus 2014-07-13 10:51:15 +00:00
parent 23c763fded
commit 9aaacc311f
2 changed files with 0 additions and 61 deletions

View File

@ -1,50 +0,0 @@
#
# Copyright (C) 2008-2014 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=wavemon
PKG_VERSION:=0.7.5
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://eden-feed.erg.abdn.ac.uk/wavemon/stable-releases
PKG_MD5SUM:=77d4a0f099ca98cf98a915adc70694ba
PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
define Package/wavemon
SECTION:=net
CATEGORY:=Network
MAINTAINER:=Jonathan McCrohan <jmccrohan@gmail.com>
TITLE:=N-curses based wireless network devices monitor
DEPENDS:=+libncurses
SUBMENU:=wireless
URL:=http://eden-feed.erg.abdn.ac.uk/wavemon/
endef
define Package/wavemon/description
wavemon is a ncurses-based monitoring application for wireless network
devices. It currently works under Linux with devices that are supported
by the wireless extensions by Jean Tourrilhes (included in Kernel 2.4
and higher), e.g. the Lucent Orinoco cards.
endef
CONFIGURE_VARS += \
ac_cv_lib_cap_cap_get_flag=no
MAKE_FLAGS += \
CFLAGS="$(TARGET_CFLAGS) -L$(STAGING_DIR)/usr/lib -I$(STAGING_DIR)/usr/include"
define Package/wavemon/install
$(INSTALL_DIR) $(1)/usr/bin
$(CP) $(PKG_INSTALL_DIR)/usr/bin/wavemon $(1)/usr/bin/
endef
$(eval $(call BuildPackage,wavemon))

View File

@ -1,11 +0,0 @@
--- a/configure
+++ b/configure
@@ -2174,8 +2174,6 @@ cat >>confdefs.h <<_ACEOF
_ACEOF
-CFLAGS="-O2 -Wall"
-
# wavemon is only supported on Linux, warn user about futile compilations
# Make sure we can run config.sub.
$SHELL "$ac_aux_dir/config.sub" sun4 >/dev/null 2>&1 ||