[packages] jansson: update to v2.2.1, remove extra LDFLAGS - based on patch by Roman Yeryomin <leroi.lists@gmail.com>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@29817 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
4aa2853d66
commit
9ac02ee95a
@ -1,5 +1,5 @@
|
||||
#
|
||||
# Copyright (C) 2011 OpenWrt.org
|
||||
# Copyright (C) 2011-2012 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
@ -9,12 +9,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=jansson
|
||||
PKG_VERSION:=2.2
|
||||
PKG_VERSION:=2.2.1
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://www.digip.org/jansson/releases/
|
||||
PKG_MD5SUM:=198fbff8265686894b6d088dca22896d
|
||||
PKG_MD5SUM:=ebf4ebc7af47de27f7b9d79ad5853176
|
||||
|
||||
PKG_INSTALL:=1
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
@ -27,8 +27,6 @@ define Package/jansson
|
||||
TITLE:=JSON library
|
||||
endef
|
||||
|
||||
CONFIGURE_ARGS+= LIBS="-Wl,-rpath-link=$(STAGING_DIR)/usr/lib"
|
||||
|
||||
TARGET_CFLAGS += $(FPIC)
|
||||
|
||||
define Build/InstallDev
|
||||
|
10
libs/jansson/patches/100-add-jason_object_deep_update.patch
Normal file
10
libs/jansson/patches/100-add-jason_object_deep_update.patch
Normal file
@ -0,0 +1,10 @@
|
||||
--- a/src/jansson.h
|
||||
+++ b/src/jansson.h
|
||||
@@ -126,6 +126,7 @@ int json_object_set_new_nocheck(json_t *
|
||||
int json_object_del(json_t *object, const char *key);
|
||||
int json_object_clear(json_t *object);
|
||||
int json_object_update(json_t *object, json_t *other);
|
||||
+int json_object_deep_update(json_t *object, json_t *other);
|
||||
void *json_object_iter(json_t *object);
|
||||
void *json_object_iter_at(json_t *object, const char *key);
|
||||
void *json_object_iter_next(json_t *object, void *iter);
|
Loading…
x
Reference in New Issue
Block a user