[package] update privoxy to 3.0.12 (#4945)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@15237 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
c046379534
commit
9bfb310749
@ -9,12 +9,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=privoxy
|
||||
PKG_VERSION:=3.0.8
|
||||
PKG_RELEASE:=3
|
||||
PKG_VERSION:=3.0.12
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-stable-src.tar.gz
|
||||
PKG_SOURCE_URL:=@SF/ijbswa
|
||||
PKG_MD5SUM:=252c0e085218fb930c4bc7563e9cedd9
|
||||
PKG_MD5SUM:=c973e608d27b248ef567b47664308da1
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)-stable
|
||||
|
||||
@ -46,7 +46,7 @@ define Build/Configure
|
||||
)
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
define Build/Compile
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
SPECIAL_CFLAGS="-pthread -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib"
|
||||
mkdir -p $(PKG_INSTALL_DIR)
|
||||
@ -57,7 +57,6 @@ endef
|
||||
|
||||
define Package/privoxy/conffiles
|
||||
/etc/privoxy/config
|
||||
/etc/privoxy/user.action
|
||||
endef
|
||||
|
||||
define Package/privoxy/install
|
||||
|
@ -1,21 +1,27 @@
|
||||
confdir /etc/privoxy
|
||||
logdir /var/log
|
||||
actionsfile standard.action # Internal purpose, recommended
|
||||
actionsfile default.action # Main actions file
|
||||
actionsfile user.action # User customizations
|
||||
filterfile default.filter
|
||||
logfile logfile
|
||||
jarfile jarfile
|
||||
trust-info-url http://www.example.com/why_we_block.html
|
||||
trust-info-url http://www.example.com/what_we_allow.html
|
||||
#admin-address privoxy-admin@example.com
|
||||
#proxy-info-url http://www.example.com/proxy-service.html
|
||||
debug 1 # show each GET/POST/CONNECT request
|
||||
debug 4096 # Startup banner and warnings
|
||||
debug 8192 # Errors - *we highly recommended enabling this*
|
||||
logfile privoxy
|
||||
actionsfile match-all.action # Actions that are applied to all sites and maybe overruled later on.
|
||||
actionsfile default.action # Main actions file
|
||||
#actionsfile user.action # User customizations
|
||||
listen-address 127.0.0.1:8118
|
||||
toggle 1
|
||||
enable-remote-toggle 1
|
||||
enable-remote-http-toggle 0
|
||||
enable-edit-actions 1
|
||||
permit-access 192.168.1.0/24
|
||||
enforce-blocks 0
|
||||
buffer-limit 4096
|
||||
forwarded-connect-retries 0
|
||||
accept-intercepted-requests 0
|
||||
allow-cgi-request-crunching 0
|
||||
split-large-forms 0
|
||||
keep-alive-timeout 300
|
||||
socket-timeout 300
|
||||
permit-access 192.168.1.0/24
|
||||
debug 1 # show each GET/POST/CONNECT request
|
||||
debug 4096 # Startup banner and warnings
|
||||
debug 8192 # Errors - *we highly recommended enabling this*
|
||||
#admin-address privoxy-admin@example.com
|
||||
#proxy-info-url http://www.example.com/proxy-service.html
|
||||
|
||||
|
@ -1,14 +0,0 @@
|
||||
Index: privoxy-3.0.6-stable/configure.in
|
||||
===================================================================
|
||||
--- privoxy-3.0.6-stable.orig/configure.in 2007-06-21 14:51:38.000000000 +0200
|
||||
+++ privoxy-3.0.6-stable/configure.in 2007-06-21 14:51:38.000000000 +0200
|
||||
@@ -1125,7 +1125,8 @@
|
||||
AC_PROG_GCC_TRADITIONAL
|
||||
dnl uncommenting does not work for swa. suse linux
|
||||
dnl AC_FUNC_MALLOC
|
||||
-AC_FUNC_SETPGRP
|
||||
+dnl uncommenting does not work for openwrt
|
||||
+dnl AC_FUNC_SETPGRP
|
||||
AC_TYPE_SIGNAL
|
||||
dnl uncommenting does not work for swa. suse linux
|
||||
dnl AC_FUNC_STAT
|
@ -1,27 +0,0 @@
|
||||
Index: privoxy-3.0.6-stable/GNUmakefile.in
|
||||
===================================================================
|
||||
--- privoxy-3.0.6-stable.orig/GNUmakefile.in 2007-06-21 14:51:38.000000000 +0200
|
||||
+++ privoxy-3.0.6-stable/GNUmakefile.in 2007-06-21 14:51:38.000000000 +0200
|
||||
@@ -55,15 +55,15 @@
|
||||
USER = @USER@
|
||||
GROUP = @GROUP@
|
||||
|
||||
-prefix = @prefix@
|
||||
-exec_prefix = @exec_prefix@
|
||||
-CONF_BASE = @sysconfdir@
|
||||
-SBIN_DEST = @sbindir@
|
||||
-MAN_DIR = @mandir@
|
||||
+prefix = $(DESTDIR)@prefix@
|
||||
+exec_prefix = $(DESTDIR)@exec_prefix@
|
||||
+CONF_BASE = $(DESTDIR)@sysconfdir@
|
||||
+SBIN_DEST = $(DESTDIR)@sbindir@
|
||||
+MAN_DIR = $(DESTDIR)@mandir@
|
||||
MAN_DEST = $(MAN_DIR)/man1
|
||||
-SHARE_DEST = @datadir@
|
||||
+SHARE_DEST = $(DESTDIR)@datadir@
|
||||
DOC_DEST = $(SHARE_DEST)/doc/privoxy
|
||||
-VAR_DEST = @localstatedir@
|
||||
+VAR_DEST = $(DESTDIR)@localstatedir@
|
||||
LOGS_DEST = $(VAR_DEST)/log/privoxy
|
||||
PIDS_DEST = $(VAR_DEST)/run
|
||||
|
Loading…
x
Reference in New Issue
Block a user