[package] update apache to 2.2.13, drop httpd.conf file and patch it directly in the sources (#5858)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@17645 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
42788dbeef
commit
9d038fb0d6
@ -8,14 +8,14 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=apache
|
PKG_NAME:=apache
|
||||||
PKG_VERSION:=2.2.9
|
PKG_VERSION:=2.2.13
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=1
|
||||||
PKG_SOURCE_NAME:=httpd
|
PKG_SOURCE_NAME:=httpd
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_SOURCE_NAME)-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=$(PKG_SOURCE_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
PKG_SOURCE_URL:=http://ftp.uni-erlangen.de/pub/mirrors/apache/httpd/ \
|
PKG_SOURCE_URL:=http://ftp.uni-erlangen.de/pub/mirrors/apache/httpd/ \
|
||||||
http://apache.imsam.info/httpd/
|
http://apache.imsam.info/httpd/
|
||||||
PKG_MD5SUM:=3afa8137dc1999be695a20b62fdf032b
|
PKG_MD5SUM:=8d8d904e7342125825ec70f03c5745ef
|
||||||
|
|
||||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_SOURCE_NAME)-$(PKG_VERSION)
|
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_SOURCE_NAME)-$(PKG_VERSION)
|
||||||
|
|
||||||
@ -37,7 +37,7 @@ endef
|
|||||||
|
|
||||||
define Package/apache
|
define Package/apache
|
||||||
$(call Package/apache/Default)
|
$(call Package/apache/Default)
|
||||||
DEPENDS:=+libapr +libaprutil +zlib +libexpat +libpcre +libopenssl +libsqlite3
|
DEPENDS:=+libapr +libaprutil +libpcre +libopenssl
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/apache/description
|
define Package/apache/description
|
||||||
@ -85,7 +85,7 @@ $(call Package/apache/Default/description)
|
|||||||
This package contains the icons from Apache.
|
This package contains the icons from Apache.
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Build/Configure
|
define Build/Configure
|
||||||
$(call Build/Configure/Default, \
|
$(call Build/Configure/Default, \
|
||||||
--with-apr="$(STAGING_DIR)/usr/bin/apr-1-config" \
|
--with-apr="$(STAGING_DIR)/usr/bin/apr-1-config" \
|
||||||
--with-apr-util="$(STAGING_DIR)/usr/bin/apu-1-config" \
|
--with-apr-util="$(STAGING_DIR)/usr/bin/apu-1-config" \
|
||||||
@ -98,12 +98,12 @@ define Build/Configure
|
|||||||
--enable-mime-magic \
|
--enable-mime-magic \
|
||||||
--without-suexec-bin \
|
--without-suexec-bin \
|
||||||
--sysconfdir=/etc/apache \
|
--sysconfdir=/etc/apache \
|
||||||
ap_void_ptr_lt_long=no \
|
ap_cv_void_ptr_lt_long=no \
|
||||||
logfiledir="/var/log" \
|
logfiledir="/var/log" \
|
||||||
)
|
)
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Build/Compile
|
define Build/Compile
|
||||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||||
all install
|
all install
|
||||||
@ -138,15 +138,14 @@ endef
|
|||||||
|
|
||||||
define Package/apache/install
|
define Package/apache/install
|
||||||
$(INSTALL_DIR) $(1)/usr/sbin
|
$(INSTALL_DIR) $(1)/usr/sbin
|
||||||
# we don't need apxs on the router, it's just for building apache modules.
|
# we don't need apxs on the router, it's just for building apache modules.
|
||||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/{ab,apachectl,checkgid,dbmmanage,envvars,envvars-std,htcacheclean,htdbm,htdigest,htpasswd,httpd,httxt2dbm,logresolve,rotatelogs} $(1)/usr/sbin/
|
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/{ab,apachectl,checkgid,dbmmanage,envvars,envvars-std,htcacheclean,htdbm,htdigest,htpasswd,httpd,httxt2dbm,logresolve,rotatelogs} $(1)/usr/sbin/
|
||||||
$(INSTALL_DIR) $(1)/usr/lib
|
$(INSTALL_DIR) $(1)/usr/lib
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/httpd.exp $(1)/usr/lib/
|
$(CP) $(PKG_INSTALL_DIR)/usr/lib/httpd.exp $(1)/usr/lib/
|
||||||
$(INSTALL_DIR) $(1)/usr/share
|
$(INSTALL_DIR) $(1)/usr/share
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/share/{error,htdocs,cgi-bin,build} $(1)/usr/share/
|
$(CP) $(PKG_INSTALL_DIR)/usr/share/{error,htdocs,cgi-bin,build} $(1)/usr/share/
|
||||||
$(INSTALL_DIR) $(1)/etc/apache
|
$(INSTALL_DIR) $(1)/etc/apache
|
||||||
$(CP) $(PKG_INSTALL_DIR)/etc/apache/{magic,mime.types,extra} $(1)/etc/apache/
|
$(CP) $(PKG_INSTALL_DIR)/etc/apache/{httpd.conf,magic,mime.types,extra} $(1)/etc/apache/
|
||||||
$(CP) ./files/etc/apache/httpd.conf $(1)/etc/apache/
|
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/apache/postrm
|
define Package/apache/postrm
|
||||||
|
@ -1,409 +0,0 @@
|
|||||||
#
|
|
||||||
# This is the main Apache HTTP server configuration file. It contains the
|
|
||||||
# configuration directives that give the server its instructions.
|
|
||||||
# See <URL:http://httpd.apache.org/docs/2.2> for detailed information.
|
|
||||||
# In particular, see
|
|
||||||
# <URL:http://httpd.apache.org/docs/2.2/mod/directives.html>
|
|
||||||
# for a discussion of each configuration directive.
|
|
||||||
#
|
|
||||||
# Do NOT simply read the instructions in here without understanding
|
|
||||||
# what they do. They're here only as hints or reminders. If you are unsure
|
|
||||||
# consult the online docs. You have been warned.
|
|
||||||
#
|
|
||||||
# Configuration and logfile names: If the filenames you specify for many
|
|
||||||
# of the server's control files begin with "/" (or "drive:/" for Win32), the
|
|
||||||
# server will use that explicit path. If the filenames do *not* begin
|
|
||||||
# with "/", the value of ServerRoot is prepended -- so "/var/log/foo_log"
|
|
||||||
# with ServerRoot set to "/usr" will be interpreted by the
|
|
||||||
# server as "/usr//var/log/foo_log".
|
|
||||||
|
|
||||||
#
|
|
||||||
# ServerRoot: The top of the directory tree under which the server's
|
|
||||||
# configuration, error, and log files are kept.
|
|
||||||
#
|
|
||||||
# Do not add a slash at the end of the directory path. If you point
|
|
||||||
# ServerRoot at a non-local disk, be sure to point the LockFile directive
|
|
||||||
# at a local disk. If you wish to share the same ServerRoot for multiple
|
|
||||||
# httpd daemons, you will need to change at least LockFile and PidFile.
|
|
||||||
#
|
|
||||||
ServerRoot "/usr"
|
|
||||||
|
|
||||||
#
|
|
||||||
# Listen: Allows you to bind Apache to specific IP addresses and/or
|
|
||||||
# ports, instead of the default. See also the <VirtualHost>
|
|
||||||
# directive.
|
|
||||||
#
|
|
||||||
# Change this to Listen on specific IP addresses as shown below to
|
|
||||||
# prevent Apache from glomming onto all bound IP addresses.
|
|
||||||
#
|
|
||||||
#Listen 12.34.56.78:80
|
|
||||||
Listen 80
|
|
||||||
|
|
||||||
#
|
|
||||||
# Dynamic Shared Object (DSO) Support
|
|
||||||
#
|
|
||||||
# To be able to use the functionality of a module which was built as a DSO you
|
|
||||||
# have to place corresponding `LoadModule' lines at this location so the
|
|
||||||
# directives contained in it are actually available _before_ they are used.
|
|
||||||
# Statically compiled modules (those listed by `httpd -l') do not need
|
|
||||||
# to be loaded here.
|
|
||||||
#
|
|
||||||
# Example:
|
|
||||||
# LoadModule foo_module modules/mod_foo.so
|
|
||||||
#
|
|
||||||
|
|
||||||
<IfModule !mpm_netware_module>
|
|
||||||
<IfModule !mpm_winnt_module>
|
|
||||||
#
|
|
||||||
# If you wish httpd to run as a different user or group, you must run
|
|
||||||
# httpd as root initially and it will switch.
|
|
||||||
#
|
|
||||||
# User/Group: The name (or #number) of the user/group to run httpd as.
|
|
||||||
# It is usually good practice to create a dedicated user and group for
|
|
||||||
# running httpd, as with most system services.
|
|
||||||
#
|
|
||||||
User nobody
|
|
||||||
Group nogroup
|
|
||||||
|
|
||||||
</IfModule>
|
|
||||||
</IfModule>
|
|
||||||
|
|
||||||
# 'Main' server configuration
|
|
||||||
#
|
|
||||||
# The directives in this section set up the values used by the 'main'
|
|
||||||
# server, which responds to any requests that aren't handled by a
|
|
||||||
# <VirtualHost> definition. These values also provide defaults for
|
|
||||||
# any <VirtualHost> containers you may define later in the file.
|
|
||||||
#
|
|
||||||
# All of these directives may appear inside <VirtualHost> containers,
|
|
||||||
# in which case these default settings will be overridden for the
|
|
||||||
# virtual host being defined.
|
|
||||||
#
|
|
||||||
|
|
||||||
#
|
|
||||||
# ServerAdmin: Your address, where problems with the server should be
|
|
||||||
# e-mailed. This address appears on some server-generated pages, such
|
|
||||||
# as error documents. e.g. admin@your-domain.com
|
|
||||||
#
|
|
||||||
ServerAdmin you@example.com
|
|
||||||
|
|
||||||
#
|
|
||||||
# ServerName gives the name and port that the server uses to identify itself.
|
|
||||||
# This can often be determined automatically, but we recommend you specify
|
|
||||||
# it explicitly to prevent problems during startup.
|
|
||||||
#
|
|
||||||
# If your host doesn't have a registered DNS name, enter its IP address here.
|
|
||||||
#
|
|
||||||
#ServerName www.example.com:80
|
|
||||||
|
|
||||||
#
|
|
||||||
# DocumentRoot: The directory out of which you will serve your
|
|
||||||
# documents. By default, all requests are taken from this directory, but
|
|
||||||
# symbolic links and aliases may be used to point to other locations.
|
|
||||||
#
|
|
||||||
DocumentRoot "/usr/share/htdocs"
|
|
||||||
|
|
||||||
#
|
|
||||||
# Each directory to which Apache has access can be configured with respect
|
|
||||||
# to which services and features are allowed and/or disabled in that
|
|
||||||
# directory (and its subdirectories).
|
|
||||||
#
|
|
||||||
# First, we configure the "default" to be a very restrictive set of
|
|
||||||
# features.
|
|
||||||
#
|
|
||||||
<Directory />
|
|
||||||
Options FollowSymLinks
|
|
||||||
AllowOverride None
|
|
||||||
Order deny,allow
|
|
||||||
Deny from all
|
|
||||||
</Directory>
|
|
||||||
|
|
||||||
#
|
|
||||||
# Note that from this point forward you must specifically allow
|
|
||||||
# particular features to be enabled - so if something's not working as
|
|
||||||
# you might expect, make sure that you have specifically enabled it
|
|
||||||
# below.
|
|
||||||
#
|
|
||||||
|
|
||||||
#
|
|
||||||
# This should be changed to whatever you set DocumentRoot to.
|
|
||||||
#
|
|
||||||
<Directory "/usr/share/htdocs">
|
|
||||||
#
|
|
||||||
# Possible values for the Options directive are "None", "All",
|
|
||||||
# or any combination of:
|
|
||||||
# Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
|
|
||||||
#
|
|
||||||
# Note that "MultiViews" must be named *explicitly* --- "Options All"
|
|
||||||
# doesn't give it to you.
|
|
||||||
#
|
|
||||||
# The Options directive is both complicated and important. Please see
|
|
||||||
# http://httpd.apache.org/docs/2.2/mod/core.html#options
|
|
||||||
# for more information.
|
|
||||||
#
|
|
||||||
Options Indexes FollowSymLinks
|
|
||||||
|
|
||||||
#
|
|
||||||
# AllowOverride controls what directives may be placed in .htaccess files.
|
|
||||||
# It can be "All", "None", or any combination of the keywords:
|
|
||||||
# Options FileInfo AuthConfig Limit
|
|
||||||
#
|
|
||||||
AllowOverride None
|
|
||||||
|
|
||||||
#
|
|
||||||
# Controls who can get stuff from this server.
|
|
||||||
#
|
|
||||||
Order allow,deny
|
|
||||||
Allow from all
|
|
||||||
|
|
||||||
</Directory>
|
|
||||||
|
|
||||||
#
|
|
||||||
# DirectoryIndex: sets the file that Apache will serve if a directory
|
|
||||||
# is requested.
|
|
||||||
#
|
|
||||||
<IfModule dir_module>
|
|
||||||
DirectoryIndex index.html
|
|
||||||
</IfModule>
|
|
||||||
|
|
||||||
#
|
|
||||||
# The following lines prevent .htaccess and .htpasswd files from being
|
|
||||||
# viewed by Web clients.
|
|
||||||
#
|
|
||||||
<FilesMatch "^\.ht">
|
|
||||||
Order allow,deny
|
|
||||||
Deny from all
|
|
||||||
Satisfy All
|
|
||||||
</FilesMatch>
|
|
||||||
|
|
||||||
#
|
|
||||||
# ErrorLog: The location of the error log file.
|
|
||||||
# If you do not specify an ErrorLog directive within a <VirtualHost>
|
|
||||||
# container, error messages relating to that virtual host will be
|
|
||||||
# logged here. If you *do* define an error logfile for a <VirtualHost>
|
|
||||||
# container, that host's errors will be logged there and not here.
|
|
||||||
#
|
|
||||||
ErrorLog "/var/log/error_log"
|
|
||||||
|
|
||||||
#
|
|
||||||
# LogLevel: Control the number of messages logged to the error_log.
|
|
||||||
# Possible values include: debug, info, notice, warn, error, crit,
|
|
||||||
# alert, emerg.
|
|
||||||
#
|
|
||||||
LogLevel debug
|
|
||||||
|
|
||||||
<IfModule log_config_module>
|
|
||||||
#
|
|
||||||
# The following directives define some format nicknames for use with
|
|
||||||
# a CustomLog directive (see below).
|
|
||||||
#
|
|
||||||
LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined
|
|
||||||
LogFormat "%h %l %u %t \"%r\" %>s %b" common
|
|
||||||
|
|
||||||
<IfModule logio_module>
|
|
||||||
# You need to enable mod_logio.c to use %I and %O
|
|
||||||
LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\" %I %O" combinedio
|
|
||||||
</IfModule>
|
|
||||||
|
|
||||||
#
|
|
||||||
# The location and format of the access logfile (Common Logfile Format).
|
|
||||||
# If you do not define any access logfiles within a <VirtualHost>
|
|
||||||
# container, they will be logged here. Contrariwise, if you *do*
|
|
||||||
# define per-<VirtualHost> access logfiles, transactions will be
|
|
||||||
# logged therein and *not* in this file.
|
|
||||||
#
|
|
||||||
CustomLog "/var/log/access_log" common
|
|
||||||
|
|
||||||
#
|
|
||||||
# If you prefer a logfile with access, agent, and referer information
|
|
||||||
# (Combined Logfile Format) you can use the following directive.
|
|
||||||
#
|
|
||||||
#CustomLog "/var/log/access_log" combined
|
|
||||||
</IfModule>
|
|
||||||
|
|
||||||
<IfModule alias_module>
|
|
||||||
#
|
|
||||||
# Redirect: Allows you to tell clients about documents that used to
|
|
||||||
# exist in your server's namespace, but do not anymore. The client
|
|
||||||
# will make a new request for the document at its new location.
|
|
||||||
# Example:
|
|
||||||
# Redirect permanent /foo http://www.example.com/bar
|
|
||||||
|
|
||||||
#
|
|
||||||
# Alias: Maps web paths into filesystem paths and is used to
|
|
||||||
# access content that does not live under the DocumentRoot.
|
|
||||||
# Example:
|
|
||||||
# Alias /webpath /full/filesystem/path
|
|
||||||
#
|
|
||||||
# If you include a trailing / on /webpath then the server will
|
|
||||||
# require it to be present in the URL. You will also likely
|
|
||||||
# need to provide a <Directory> section to allow access to
|
|
||||||
# the filesystem path.
|
|
||||||
|
|
||||||
#
|
|
||||||
# ScriptAlias: This controls which directories contain server scripts.
|
|
||||||
# ScriptAliases are essentially the same as Aliases, except that
|
|
||||||
# documents in the target directory are treated as applications and
|
|
||||||
# run by the server when requested rather than as documents sent to the
|
|
||||||
# client. The same rules about trailing "/" apply to ScriptAlias
|
|
||||||
# directives as to Alias.
|
|
||||||
#
|
|
||||||
ScriptAlias /cgi-bin/ "/usr/share/cgi-bin/"
|
|
||||||
|
|
||||||
</IfModule>
|
|
||||||
|
|
||||||
<IfModule cgid_module>
|
|
||||||
#
|
|
||||||
# ScriptSock: On threaded servers, designate the path to the UNIX
|
|
||||||
# socket used to communicate with the CGI daemon of mod_cgid.
|
|
||||||
#
|
|
||||||
#Scriptsock /var/log/cgisock
|
|
||||||
</IfModule>
|
|
||||||
|
|
||||||
#
|
|
||||||
# "/usr/share/cgi-bin" should be changed to whatever your ScriptAliased
|
|
||||||
# CGI directory exists, if you have that configured.
|
|
||||||
#
|
|
||||||
<Directory "/usr/share/cgi-bin">
|
|
||||||
AllowOverride None
|
|
||||||
Options None
|
|
||||||
Order allow,deny
|
|
||||||
Allow from all
|
|
||||||
</Directory>
|
|
||||||
|
|
||||||
#
|
|
||||||
# DefaultType: the default MIME type the server will use for a document
|
|
||||||
# if it cannot otherwise determine one, such as from filename extensions.
|
|
||||||
# If your server contains mostly text or HTML documents, "text/plain" is
|
|
||||||
# a good value. If most of your content is binary, such as applications
|
|
||||||
# or images, you may want to use "application/octet-stream" instead to
|
|
||||||
# keep browsers from trying to display binary files as though they are
|
|
||||||
# text.
|
|
||||||
#
|
|
||||||
DefaultType text/plain
|
|
||||||
|
|
||||||
<IfModule mime_module>
|
|
||||||
#
|
|
||||||
# TypesConfig points to the file containing the list of mappings from
|
|
||||||
# filename extension to MIME-type.
|
|
||||||
#
|
|
||||||
TypesConfig /etc/apache/mime.types
|
|
||||||
|
|
||||||
#
|
|
||||||
# AddType allows you to add to or override the MIME configuration
|
|
||||||
# file specified in TypesConfig for specific file types.
|
|
||||||
#
|
|
||||||
#AddType application/x-gzip .tgz
|
|
||||||
#
|
|
||||||
# AddEncoding allows you to have certain browsers uncompress
|
|
||||||
# information on the fly. Note: Not all browsers support this.
|
|
||||||
#
|
|
||||||
#AddEncoding x-compress .Z
|
|
||||||
#AddEncoding x-gzip .gz .tgz
|
|
||||||
#
|
|
||||||
# If the AddEncoding directives above are commented-out, then you
|
|
||||||
# probably should define those extensions to indicate media types:
|
|
||||||
#
|
|
||||||
AddType application/x-compress .Z
|
|
||||||
AddType application/x-gzip .gz .tgz
|
|
||||||
|
|
||||||
#
|
|
||||||
# AddHandler allows you to map certain file extensions to "handlers":
|
|
||||||
# actions unrelated to filetype. These can be either built into the server
|
|
||||||
# or added with the Action directive (see below)
|
|
||||||
#
|
|
||||||
# To use CGI scripts outside of ScriptAliased directories:
|
|
||||||
# (You will also need to add "ExecCGI" to the "Options" directive.)
|
|
||||||
#
|
|
||||||
#AddHandler cgi-script .cgi
|
|
||||||
|
|
||||||
# For type maps (negotiated resources):
|
|
||||||
#AddHandler type-map var
|
|
||||||
|
|
||||||
#
|
|
||||||
# Filters allow you to process content before it is sent to the client.
|
|
||||||
#
|
|
||||||
# To parse .shtml files for server-side includes (SSI):
|
|
||||||
# (You will also need to add "Includes" to the "Options" directive.)
|
|
||||||
#
|
|
||||||
#AddType text/html .shtml
|
|
||||||
#AddOutputFilter INCLUDES .shtml
|
|
||||||
</IfModule>
|
|
||||||
|
|
||||||
#
|
|
||||||
# The mod_mime_magic module allows the server to use various hints from the
|
|
||||||
# contents of the file itself to determine its type. The MIMEMagicFile
|
|
||||||
# directive tells the module where the hint definitions are located.
|
|
||||||
#
|
|
||||||
MIMEMagicFile /etc/apache/magic
|
|
||||||
|
|
||||||
#
|
|
||||||
# Customizable error responses come in three flavors:
|
|
||||||
# 1) plain text 2) local redirects 3) external redirects
|
|
||||||
#
|
|
||||||
# Some examples:
|
|
||||||
#ErrorDocument 500 "The server made a boo boo."
|
|
||||||
#ErrorDocument 404 /missing.html
|
|
||||||
#ErrorDocument 404 "/cgi-bin/missing_handler.pl"
|
|
||||||
#ErrorDocument 402 http://www.example.com/subscription_info.html
|
|
||||||
#
|
|
||||||
|
|
||||||
#
|
|
||||||
# EnableMMAP and EnableSendfile: On systems that support it,
|
|
||||||
# memory-mapping or the sendfile syscall is used to deliver
|
|
||||||
# files. This usually improves server performance, but must
|
|
||||||
# be turned off when serving from networked-mounted
|
|
||||||
# filesystems or if support for these functions is otherwise
|
|
||||||
# broken on your system.
|
|
||||||
#
|
|
||||||
#EnableMMAP off
|
|
||||||
EnableSendfile off
|
|
||||||
|
|
||||||
# Supplemental configuration
|
|
||||||
#
|
|
||||||
# The configuration files in the /etc/apache/extra/ directory can be
|
|
||||||
# included to add extra features or to modify the default configuration of
|
|
||||||
# the server, or you may simply copy their contents here and change as
|
|
||||||
# necessary.
|
|
||||||
|
|
||||||
# Server-pool management (MPM specific)
|
|
||||||
#Include /etc/apache/extra/httpd-mpm.conf
|
|
||||||
|
|
||||||
# Multi-language error messages
|
|
||||||
#Include /etc/apache/extra/httpd-multilang-errordoc.conf
|
|
||||||
|
|
||||||
# Fancy directory listings
|
|
||||||
#Include /etc/apache/extra/httpd-autoindex.conf
|
|
||||||
|
|
||||||
# Language settings
|
|
||||||
#Include /etc/apache/extra/httpd-languages.conf
|
|
||||||
|
|
||||||
# User home directories
|
|
||||||
#Include /etc/apache/extra/httpd-userdir.conf
|
|
||||||
|
|
||||||
# Real-time info on requests and configuration
|
|
||||||
#Include /etc/apache/extra/httpd-info.conf
|
|
||||||
|
|
||||||
# Virtual hosts
|
|
||||||
#Include /etc/apache/extra/httpd-vhosts.conf
|
|
||||||
|
|
||||||
# Local access to the Apache HTTP Server Manual
|
|
||||||
#Include /etc/apache/extra/httpd-manual.conf
|
|
||||||
|
|
||||||
# Distributed authoring and versioning (WebDAV)
|
|
||||||
#Include /etc/apache/extra/httpd-dav.conf
|
|
||||||
|
|
||||||
# Various default settings
|
|
||||||
#Include /etc/apache/extra/httpd-default.conf
|
|
||||||
|
|
||||||
# Secure (SSL/TLS) connections
|
|
||||||
#Include /etc/apache/extra/httpd-ssl.conf
|
|
||||||
#
|
|
||||||
# Note: The following must must be present to support
|
|
||||||
# starting without SSL on platforms with no /dev/random equivalent
|
|
||||||
# but a statically compiled-in mod_ssl.
|
|
||||||
#
|
|
||||||
#<IfModule ssl_module>
|
|
||||||
#SSLRandomSeed startup builtin
|
|
||||||
#SSLRandomSeed connect builtin
|
|
||||||
#</IfModule>
|
|
@ -1,6 +1,6 @@
|
|||||||
--- a/server/Makefile.in
|
--- a/server/Makefile.in
|
||||||
+++ b/server/Makefile.in
|
+++ b/server/Makefile.in
|
||||||
@@ -26,7 +26,10 @@
|
@@ -26,7 +26,10 @@ gen_test_char: $(gen_test_char_OBJECTS)
|
||||||
$(LINK) $(EXTRA_LDFLAGS) $(gen_test_char_OBJECTS) $(EXTRA_LIBS)
|
$(LINK) $(EXTRA_LDFLAGS) $(gen_test_char_OBJECTS) $(EXTRA_LIBS)
|
||||||
|
|
||||||
test_char.h: gen_test_char
|
test_char.h: gen_test_char
|
||||||
|
@ -22,5 +22,5 @@
|
|||||||
+ 54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,
|
+ 54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,
|
||||||
+ 54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,
|
+ 54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,
|
||||||
+ 54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,
|
+ 54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,
|
||||||
+ 54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54
|
+ 54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54
|
||||||
+};
|
+};
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/build/mkconfNW.awk
|
--- a/build/mkconfNW.awk
|
||||||
+++ b/build/mkconfNW.awk
|
+++ b/build/mkconfNW.awk
|
||||||
@@ -24,7 +24,7 @@
|
@@ -24,7 +24,7 @@ BEGIN {
|
||||||
A["sysconfdir"] = "conf"
|
A["sysconfdir"] = "conf"
|
||||||
A["iconsdir"] = "icons"
|
A["iconsdir"] = "icons"
|
||||||
A["manualdir"] = "manual"
|
A["manualdir"] = "manual"
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/include/scoreboard.h
|
--- a/include/scoreboard.h
|
||||||
+++ b/include/scoreboard.h
|
+++ b/include/scoreboard.h
|
||||||
@@ -42,7 +42,7 @@
|
@@ -42,7 +42,7 @@ extern "C" {
|
||||||
|
|
||||||
/* Scoreboard file, if there is one */
|
/* Scoreboard file, if there is one */
|
||||||
#ifndef DEFAULT_SCOREBOARD
|
#ifndef DEFAULT_SCOREBOARD
|
||||||
|
60
net/apache/patches/005-httpd_conf.patch
Normal file
60
net/apache/patches/005-httpd_conf.patch
Normal file
@ -0,0 +1,60 @@
|
|||||||
|
--- a/docs/conf/httpd.conf.in
|
||||||
|
+++ b/docs/conf/httpd.conf.in
|
||||||
|
@@ -51,7 +51,6 @@ Listen @@Port@@
|
||||||
|
# Example:
|
||||||
|
# LoadModule foo_module modules/mod_foo.so
|
||||||
|
#
|
||||||
|
-@@LoadModule@@
|
||||||
|
|
||||||
|
<IfModule !mpm_netware_module>
|
||||||
|
<IfModule !mpm_winnt_module>
|
||||||
|
@@ -63,8 +62,8 @@ Listen @@Port@@
|
||||||
|
# It is usually good practice to create a dedicated user and group for
|
||||||
|
# running httpd, as with most system services.
|
||||||
|
#
|
||||||
|
-User daemon
|
||||||
|
-Group daemon
|
||||||
|
+User nobody
|
||||||
|
+Group nogroup
|
||||||
|
|
||||||
|
</IfModule>
|
||||||
|
</IfModule>
|
||||||
|
@@ -191,7 +190,7 @@ ErrorLog "@rel_logfiledir@/error_log"
|
||||||
|
# Possible values include: debug, info, notice, warn, error, crit,
|
||||||
|
# alert, emerg.
|
||||||
|
#
|
||||||
|
-LogLevel warn
|
||||||
|
+LogLevel debug
|
||||||
|
|
||||||
|
<IfModule log_config_module>
|
||||||
|
#
|
||||||
|
@@ -336,7 +335,7 @@ DefaultType text/plain
|
||||||
|
# contents of the file itself to determine its type. The MIMEMagicFile
|
||||||
|
# directive tells the module where the hint definitions are located.
|
||||||
|
#
|
||||||
|
-#MIMEMagicFile @rel_sysconfdir@/magic
|
||||||
|
+MIMEMagicFile @rel_sysconfdir@/magic
|
||||||
|
|
||||||
|
#
|
||||||
|
# Customizable error responses come in three flavors:
|
||||||
|
@@ -358,7 +357,7 @@ DefaultType text/plain
|
||||||
|
# broken on your system.
|
||||||
|
#
|
||||||
|
#EnableMMAP off
|
||||||
|
-#EnableSendfile off
|
||||||
|
+EnableSendfile off
|
||||||
|
|
||||||
|
# Supplemental configuration
|
||||||
|
#
|
||||||
|
@@ -404,7 +403,7 @@ DefaultType text/plain
|
||||||
|
# starting without SSL on platforms with no /dev/random equivalent
|
||||||
|
# but a statically compiled-in mod_ssl.
|
||||||
|
#
|
||||||
|
-<IfModule ssl_module>
|
||||||
|
-SSLRandomSeed startup builtin
|
||||||
|
-SSLRandomSeed connect builtin
|
||||||
|
-</IfModule>
|
||||||
|
+#<IfModule ssl_module>
|
||||||
|
+#SSLRandomSeed startup builtin
|
||||||
|
+#SSLRandomSeed connect builtin
|
||||||
|
+#</IfModule>
|
Loading…
x
Reference in New Issue
Block a user