[package] add xdelta3
Signed-off-by: Alexander Gordeev <lasaine@lvk.cs.msu.su> git-svn-id: svn://svn.openwrt.org/openwrt/packages@28231 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
10cbe04885
commit
9d15943a83
42
utils/xdelta3/Makefile
Normal file
42
utils/xdelta3/Makefile
Normal file
@ -0,0 +1,42 @@
|
|||||||
|
#
|
||||||
|
# Copyright (C) 2011 Alexander Gordeev <lasaine@lvk.cs.msu.su>
|
||||||
|
#
|
||||||
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
|
# See /LICENSE for more information.
|
||||||
|
#
|
||||||
|
|
||||||
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
|
PKG_NAME:=xdelta3
|
||||||
|
PKG_VERSION:=3.0.0
|
||||||
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
|
PKG_SOURCE:=xdelta$(PKG_VERSION).tar.gz
|
||||||
|
PKG_SOURCE_URL:=http://xdelta.googlecode.com/files
|
||||||
|
PKG_MD5SUM:=5fe038be3a266d2a7913e10d1cec6d88
|
||||||
|
|
||||||
|
PKG_BUILD_DIR:=$(BUILD_DIR)/xdelta$(PKG_VERSION)
|
||||||
|
|
||||||
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
define Package/xdelta3
|
||||||
|
SECTION:=utils
|
||||||
|
CATEGORY:=Utilities
|
||||||
|
URL:=http://xdelta.org
|
||||||
|
TITLE:=A diff utility which works with binary files
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/xdelta3/description
|
||||||
|
Xdelta3 is a set of tools designed to compute changes between binary
|
||||||
|
files. These changes (delta files) are similar to the output of the
|
||||||
|
"diff" program, in that they may be used to store and transmit only
|
||||||
|
the changes between files. The "delta files" that Xdelta3 manages are
|
||||||
|
stored in RFC3284 (VCDIFF) format.
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/xdelta3/install
|
||||||
|
$(INSTALL_DIR) $(1)/usr/bin
|
||||||
|
$(INSTALL_BIN) $(PKG_BUILD_DIR)/xdelta3 $(1)/usr/bin/
|
||||||
|
endef
|
||||||
|
|
||||||
|
$(eval $(call BuildPackage,xdelta3))
|
19
utils/xdelta3/patches/001-decrease-default-window-size.patch
Normal file
19
utils/xdelta3/patches/001-decrease-default-window-size.patch
Normal file
@ -0,0 +1,19 @@
|
|||||||
|
diff --git a/xdelta3.h b/xdelta3.h
|
||||||
|
index 5dafd8d..22bc37f 100644
|
||||||
|
--- a/xdelta3.h
|
||||||
|
+++ b/xdelta3.h
|
||||||
|
@@ -38,12 +38,12 @@
|
||||||
|
* buffer is used directly.
|
||||||
|
*/
|
||||||
|
#ifndef XD3_DEFAULT_WINSIZE
|
||||||
|
-#define XD3_DEFAULT_WINSIZE (1U << 23)
|
||||||
|
+#define XD3_DEFAULT_WINSIZE (1U << 16)
|
||||||
|
#endif
|
||||||
|
|
||||||
|
/* Default total size of the source window used in xdelta3-main.h */
|
||||||
|
#ifndef XD3_DEFAULT_SRCWINSZ
|
||||||
|
-#define XD3_DEFAULT_SRCWINSZ (1U << 26)
|
||||||
|
+#define XD3_DEFAULT_SRCWINSZ (1U << 19)
|
||||||
|
#endif
|
||||||
|
|
||||||
|
/* When Xdelta requests a memory allocation for certain buffers, it
|
Loading…
x
Reference in New Issue
Block a user