[packages] lang/luaposix: updated to 5.1.3

git-svn-id: svn://svn.openwrt.org/openwrt/packages@11585 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
cyrus 2008-06-27 07:27:50 +00:00
parent 78ccd3a1a8
commit 9d3b86fb4e
3 changed files with 9 additions and 40 deletions

View File

@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=luaposix
PKG_VERSION:=5.1.2
PKG_VERSION:=5.1.3
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://luaforge.net/frs/download.php/3063
PKG_MD5SUM:=31deeb4add91f76b3c2d36aae2888d81
PKG_SOURCE_URL:=http://luaforge.net/frs/download.php/3449
PKG_MD5SUM:=4271f321c39d0560d9fbe6ca882a67aa
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install

View File

@ -1,27 +0,0 @@
Index: luaposix-5.1.2/Makefile
===================================================================
--- luaposix-5.1.2.orig/Makefile 2008-01-29 14:49:27.000000000 +0100
+++ luaposix-5.1.2/Makefile 2008-05-28 14:15:30.000000000 +0200
@@ -34,6 +34,13 @@
T= $(MYLIB).so
+OS=$(shell uname)
+ifeq ($(OS),Darwin)
+ LDFLAGS_SHARED=-bundle -undefined dynamic_lookup
+else
+ LDFLAGS_SHARED=-shared
+endif
+
# targets
phony += all
all: $T
@@ -43,7 +50,7 @@
$(LUA) test.lua
$T: $(OBJS)
- $(CC) $(LDFLAGS) -o $@ -shared $(OBJS)
+ $(CC) $(LDFLAGS) -o $@ $(LDFLAGS_SHARED) $(OBJS)
$(OBJS): modemuncher.c

View File

@ -1,8 +1,6 @@
Index: luaposix-5.1.2/lposix.c
===================================================================
--- luaposix-5.1.2.orig/lposix.c 2008-06-02 17:35:21.000000000 +0200
+++ luaposix-5.1.2/lposix.c 2008-06-02 17:35:26.000000000 +0200
@@ -1006,6 +1006,29 @@
--- a/lposix.c
+++ b/lposix.c
@@ -1016,6 +1016,29 @@
}
#endif
@ -32,7 +30,7 @@ Index: luaposix-5.1.2/lposix.c
static const luaL_reg R[] =
{
{"access", Paccess},
@@ -1013,6 +1036,7 @@
@@ -1023,6 +1046,7 @@
{"chdir", Pchdir},
{"chmod", Pchmod},
{"chown", Pchown},
@ -40,10 +38,8 @@ Index: luaposix-5.1.2/lposix.c
{"ctermid", Pctermid},
{"dirname", Pdirname},
{"dir", Pdir},
Index: luaposix-5.1.2/Makefile
===================================================================
--- luaposix-5.1.2.orig/Makefile 2008-06-02 17:35:26.000000000 +0200
+++ luaposix-5.1.2/Makefile 2008-06-02 17:35:18.000000000 +0200
--- a/Makefile
+++ b/Makefile
@@ -37,8 +37,10 @@
OS=$(shell uname)
ifeq ($(OS),Darwin)